cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED
  • The questioner has marked this post as solved.

Unable to change MyCloud subscription (button "Select" not working)

Highlighted
Novice
1 of 3

I have the "inOne Home" Internet subcription, and in paperwork that I received from Swisscom I can see that I can use STANDARD MyCloud free subscription (250 GB).

 

I made new login account this evening in order to start using MyCloud for the first time (with the same email address I use for Swisscom). When I login in MyCloud, I can see that LIGHT MyCloud subscription is set for me.

 

But, when I click on "Change subscription", and on next screen when I click on the blue "Select" button below STANDARD Subcription, nothing happens (as if the "Select" button is not working).

 

I am using latest version of Firefox browser. Any ideas what could be the problem? 

 

 

 

MOST HELPFUL ANSWER

Accepted Solutions
Novice
3 of 3

Thank you for your reply.


I arleady solved this problem. Here is the solution (it will maybe help others who are experiencing similar problems):

Ad Blocker in my browser was causing this situation - the problem was solved when I turned it off (so, it turned out that when the Ad Blocker is on, the blue "Select" button on Swisscom website does not work. Strange...)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2 Comments
Contributor
2 of 3

Hello @felix55 

 

It is probably easiest if you open a support request and describe the issue you're experiencing (maybe attach screenshots of how you proceed):

https://help.mycloud.ch/hc/de/requests/new?ticket_form_id=114093978493

 

I'm sure myCloud support can help you. 

 

cymett

Novice
3 of 3

Thank you for your reply.


I arleady solved this problem. Here is the solution (it will maybe help others who are experiencing similar problems):

Ad Blocker in my browser was causing this situation - the problem was solved when I turned it off (so, it turned out that when the Ad Blocker is on, the blue "Select" button on Swisscom website does not work. Strange...)