cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED
  • The questioner has marked this post as solved.

MyCloud not working

Highlighted
Contributor
2 of 5

Whats up with My Cloud, it seems to be completly broken.

It was working several months ago.

 

With Chrome going to MyCloud.ch and clicking on login gives a blank page, impossible to login.

Chrome version : 60.0.3112.90 (official build) (64bit)

 

With Safari it is possible to login but then nothing functions. The hamburger menu doesn't do anything, clicking on "All Files" doesn't do anything, its not even possible to logoout.

With safari MyCloud displays version 17.27.2

Safari version : 10.1.2

 

I've cleared the history on both browsers but it didn't change anything.

I'm on Mac OS X 10.11.6

 

Regards

Paul

MOST HELPFUL ANSWER

Accepted Solutions
Contributor
4 of 5

Hi

 

No more problems.

Its working as before.

 

Best Regards

4 Comments
Novice
1 of 5

When I click on the login button from the mycloud welcome page, the login screen doesn't load, I just get a blank page. I am on a Mac using Safari v10.1.

Community Manager
3 of 5

Hello @PaulM

 

Are you still experiencing problems with myCloud ?

 

Cheers,

Un like fait toujours plaisir 😉 Une réponse t'a aidé? -> Accepte-la comme solution!
Contributor
4 of 5

Hi

 

No more problems.

Its working as before.

 

Best Regards

Community Manager
5 of 5

Hi,

 

Great, thanks for your feedback.

 

Cheers,

Un like fait toujours plaisir 😉 Une réponse t'a aidé? -> Accepte-la comme solution!
Back to top