abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 
Gelöst
  • Der Fragesteller hat diesen Beitrag als gelöst markiert.

Swisscombox Plus nur als Modem vor Ubiquiti USG benutzen

Highlighted
Level 1
141 von 236

Hallo Roli

 

Stimmen diese Einstellungen aus deiner Antwort vom 3. Mai 17 heute noch? Frage nach, weil ich genau dieses Problem habe und es bei mir leider nicht funktioniert....

 

Habe einen USG sowie eine IB 2 am Start.

 

Gruss

Andy

Editiert
Highlighted
Super User
142 von 236

Hallo @Thildirio81 

 

 

Die Einstellung hier im Forum stimmen immer noch. 

 

Auch mit der IB3 funktioniert meine USG3 oder USG4 Pro problemlos. Das einzige was du bei der USG4 Pro abänderung musst  ist unten ersichtlich. 

 

Auch die FW updates von Unifi funktionieren in der Regel ohne Probleme, gibt höchst selten das ich den Cloudy Key neu starten muss. Wenn es mal nicht funktioniert, lösche auf dem Cloudy Key die Datei, boote den Key neu, und kopiere die Datei wieder dort hin.

 

Bei der USG Pro-4 ist WAN1=eth2, LAN1=eth0,  LAN2=eth1 , WAN2=eth3 .

 

Die USG 3P hat folgende Zuordnung: WAN=eth0, LAN=eth1, VOIP=eth2.

 

 

Warum funktioniert es dennoch nicht.....

 

Meistens ist die Datei config.gateway.json nicht richtig formatiert. Ich mache es von meinen MAC aus mit dem Program "TextWrangler" dieser kann den richtigen Pfad direkt von Program aus öffnen und dort richtig abspeichern. 

 

Gruss Lorenz

Highlighted
Level 3
143 von 236

Hoi Andy @Thildirio81 ,

 

prüf das Config File mit einem JSON Validator, zB. https://jsonlint.com

 

Wenn das ok ist, kann es noch an der Formatierung liegen, muss zwingend Unicode UTF-8, Unix (nicht MS-DOS) Formatierung sein.

 

Gruess

Roli

Editiert
Highlighted
Level 3
144 von 236

@Deitathepp87 

Hast du das Config File im richtigen Format erstellt, siehe einen Thread vorher.

 

Gruess

Roli

Highlighted
Level 2
145 von 236

Hallo zusammen

 

Leider habe ich auch ein Problem mit dem Swisscom TV beim Live schauen. Es erscheint nur die Meldung "Leider ist von diesem Sender zurzeit kein TV Signal verfügbar". Dies auf allen Sendern. Replay funktioniert problemlos.

 

Ich betreibe einen UniFi Security Gateway 4 Pro direkt ab der OTO Dose. Dafür habe ich im config.gateway das entsprechende VLAN und die nötigen DHCP Optionen gesetzt. Dies funktioniert auch problemlos. Sprich der USGP bekommt direkt die öffentliche IPv4 Adresse.

 

Unbenannt2.PNG

 

Ebenfalls habe ich die IGMP Einstellungen und Firewall Regeln gemäss der Anleitung eingefügt. Ca. 1 Woche hat auch alles problemlos funktioniert. Nun erscheint aber die oben genannte Meldung auf allen Sendern.

 

Die Verbindung zur TV Box ist wie folgt:

 

UniFi Security Gateway 4 Pro -> UniFi Switch 16XG -> UniFi Switch 8 POE-150W --(Port 5)--> Swisscom TV Box

 

Ich habe die TV Box mit UHD in der Software Release Version 3.99.14

 

Die UniFi Controller Version ist die Aktuellste (5.12.35.0).

 

Auf beiden Switches ist igmpsnooping aktiv sowie die IGMP header validation inaktiv:

 

 

  ___ ___      .__________.__
 |   |   |____ |__\_  ____/__|
 |   |   /    \|  ||  __) |  |   (c) 2010-2019
 |   |  |   |  \  ||  \   |  |   Ubiquiti Networks, Inc.
 |______|___|  /__||__/   |__|
            |_/                  https://www.ui.com/

      Welcome to UniFi USW-XG!

UniFi-US-16-XG-1-US.v4.0.80# telnet localhost

Entering character mode
Escape character is '^]'.

Warning!
The changes may break controller settings and only be effective until reboot.

(UBNT) >en

(UBNT) #show igmpsnooping

Admin Mode..................................... Enable
Multicast Control Frame Count.................. 465
IGMP header validation......................... Disabled
Interfaces Enabled for IGMP Snooping........... None
VLANs enabled for IGMP snooping................ 1

 

 

Und der zweite Switch: 

 

  ___ ___      .__________.__
 |   |   |____ |__\_  ____/__|
 |   |   /    \|  ||  __) |  |   (c) 2010-2019
 |   |  |   |  \  ||  \   |  |   Ubiquiti Networks, Inc.
 |______|___|  /__||__/   |__|
            |_/                  https://www.ui.com/

      Welcome to UniFi USW-8P-150!

UniFi-US-8-150W-US.v4.0.80# telnet localhost

Entering character mode
Escape character is '^]'.

Warning!
The changes may break controller settings and only be effective until reboot.

(UBNT) >en

(UBNT) #show igmpsnooping

Admin Mode..................................... Enable
Multicast Control Frame Count.................. 457
IGMP header validation......................... Disabled
Interfaces Enabled for IGMP Snooping........... None
VLANs enabled for IGMP snooping................ 1

 

 Im LAN ist "IGMP snooping" ebenfalls aktiviert.

 

Unbenannt.PNG

 

Hier noch die config.gateway.json Konfig. Gemäss https://jsonlint.com/ ist diese valide und wird auch angewendet.

 

{
"firewall": {
	"group": {
		"address-group": {
			"IPTV_Source": {
				"address": [
					"224.0.0.0/4",
					"239.0.0.0/8",
					"195.186.0.0/16"
				],
				"description": "IPTV Source"
			},
			"SCTV2_Source": {
				"address": [
					"213.3.72.0/24"
				],
				"description": "SCTV2 Multicast Source"
			}				
		}
	},
	"name": {
		"WAN_IN": {
			"rule": {
				"3100": {
					"action": "accept",
					"description": "allow IPTV Multicast UDP",
					"destination": {
						"group": {
							"address-group": "IPTV_Source"
						}
					},
					"log": "disable",
					"protocol": "udp",
					"source": {
						"group": {
							"address-group": "SCTV2_Source"
						}
					}
				},
				"3110": {
					"action": "accept",
					"description": "allow IGMP",
					"log": "disable",
					"protocol": "igmp"
				}
			}
		},
		"WAN_LOCAL": {
			"rule": {
				"3100": {
					"action": "accept",
					"description": "allow IPTV Multicast UDP",
					"destination": {
						"group": {
							"address-group": "IPTV_Source"
						}
					},
					"log": "disable",
					"protocol": "udp",
					"source": {
						"group": {
							"address-group": "SCTV2_Source"
						}
					}
				},
				"3110": {
					"action": "accept",
					"description": "allow IGMP",
					"log": "disable",
					"protocol": "igmp"
				}
			}
		}
	}
},
"protocols": {
	"igmp-proxy": {
		"interface": {
			"eth2": {
				"alt-subnet": [
					"0.0.0.0/0"
				],
				"role": "upstream",
				"threshold": "1"
			},
			"eth0": {
				"alt-subnet": [
					"0.0.0.0/0"
				],
				"role": "downstream",
				"threshold": "1"
			}
		}
	}
},
"interfaces": {
	"ethernet": {
		"eth2": {
			"description": "Internet Swisscom",
			"vif": {
				"10": {
					"dhcp-options": {
					"client-option": "send vendor-class-identifier "100008,0001";"
					}
				}
			}
		}
	}
}
}

 

 

Und die config.properties Datei:

 

config.system_cfg.1=switch.igmp.header_checking=false

 

 

Die TV Box hat eine IP-Adress-Reservierung vom Unifi DHCP.

 

Ich habe folgendes schon versucht:

  • TV Box auf Werkseinstellungen zurückgesetzt
  • Alle Geräte neugestartet (USGP, Switch, TV Box)
  • Verschiedene Ports
  • Alle Konfigurationen gelöscht, provisioniert, neugestartet und alles wieder gesetzt

 

Nun bin ich etwas ratlos... hat jemand von euch eine Idee?

 

Danke und beste Grüsse

Highlighted
Super User
146 von 236

Halllo @Mister.Deeds 

 

Meine Unifi Produkte laufen immer noch ohne Probleme. 

 

Meistens passiert das wenn es ein FW von Unifi gibt. 

 

In der Regel reicht es wenn ich der UniFi Security Gateway 4 Pro neu starte. 

 

Auch musste ich schon das config.gateway.json entfernen, neu provisieren, Datei wieder hochladen und nochmals provisieren. 

 

Der einzige Unterschied ist, das du Glas hast und direct auf den USG 4 Pro gehst, und ich eine IB3 davor habe. 

 

Gruss Lorenz

 

 

Highlighted
Level 2
147 von 236

Hallo @Lori-77 

 

Danke für die schnelle Antwort. Welche Firmwareversionen sind bei dir im Einsatz?

 

Der UniFi Security Gateway 4P hat bei mir 4.4.44.5213871 und die restlichen Geräte 4.0.80.10875

 

Danke und beste Grüsse

Highlighted
Super User
148 von 236

Hallo @Mister.Deeds 

 

Der USG 4 Pro 4.4.44.5213871

Der 16 POE 4.0.80.10875

 

Controller 5.12.35

 

IMGP Hacken rausnehmen, neu provisieren und neu setzten.

 

gruss Lorenz 

 

 

Highlighted
Level 2
149 von 236

Hallo @Lori-77 

 

Danke für die Rückmeldung. Dies habe ich soeben gemacht - leider keinen Unterschied - nach wie vor "Leider ist von diesem Sender zurzeit kein TV Signal verfügbar.".

 

Habt ihr noch eine Idee?

 

Danke und Grüsse

Highlighted
Super User
150 von 236

Hallo @Mister.Deeds 

 

Der USG 4P hat eine ganz leicht andere Zuordnung wie der USG 3. 

 

USG Pro-4

 

Bei der USG Pro-4 ist WAN1=eth2, LAN1=eth0,  LAN2=eth1 , WAN2=eth3 .

Die USG 3P hat folgende Zuordnung: WAN=eth0, LAN=eth1, VOIP=eth2.

 

Ich habe dir unten meine Jonsen-Datei reingestellt. 

 

Bei mir war die Datei auch mal nicht im Richtigen Format abgespeichert, und wenn du sie falsch abspeicherst, funktioniert es einfach nicht. 

Ich habe sie auf dem MAC mit dem TextWrangler erstellt. 

 

Hier kannst du die Datei überprüfen:https://jsonformatter.curiousconcept.com/

 

 

jonsen-Datei:

{
"protocols": {
"igmp-proxy": {
"interface": {
"eth2": {
"alt-subnet": [ "0.0.0.0/0" ],
"role": "upstream",
"threshold": "1"
},
"eth0": {
"alt-subnet": [ "0.0.0.0/0" ],
"role": "downstream",
"threshold": "1"
}
}
}
}
}

 

Gruss Lorenz

Highlighted
Level 1
151 von 236

Hallo @Mister.Deeds 

 

Hast du mal versucht, die Swisscom Box direkt via VLAN an den Swisscom Router anzuschliessen??

Also ohne USG und ohne IGMP Proxy??

Dann müsste es sicherlich funktionieren und du weisst, das von Seiten Swisscom alles ok ist.

Denn ich finde es komisch, dass es eine Woche funktionierte und nun plötzlich nicht mehr.

 

Gruess

 

Highlighted
Level 2
152 von 236

Hallo @Lori-77  und @snoopy5707 

 

Danke für eure Antworten. Ich habe nun zwischenzeitlich folgendes getestet:

 

  • Swisscom TV Box direkt an Internet Box 3: Funktioniert
  • Swisscom TV Box hinter Switch an Internet Box 3: Funktioniert für ca. 5 - 10 Sekunden anschliessend friert das Bild ein.
  • Swisscom TV Box hinter Switch und USGP: Keine Verbindung möglich

Sprich es liegt am USGP und oder den Switches dazwischen.

 

Ich werde den USGP nochmals resetten und neu in die Site nehmen. Mal schauen ob das eine Lösung ist.

 

Falls zwischenzeitlich noch jemand eine Idee hat bin ich dankbar.

 

Beste Grüsse

Highlighted
Super User
153 von 236

Hallo @Mister.Deeds 

 

Evt hast du noch ein IP Konflikt:

 

IB3 lass diese auf dem Original Range 192.168.1.1

 USG4 P Bezieht dort eine DHCP Adresse:

 

Den USG 4 P vergibst du am besten die Adresse 192.168.2.1 

 

Dort stehst du dann auf DHCP und verteilst von dort die IP-Adressen. 

 

So funktioniert es bei mir seit beginn her. 

 

 

Gruss Lorenz

 

Highlighted
Level 1
154 von 236

@Mister.Deeds 

 

Ich vermute ein Problem mit dem Switch, denn so wie du schreibst, funktioniert es ja auch nicht, wenn du direkt an der Internetbox via Switch auf die Swisscom-TV Box geht und das muss ja funktionieren, wenn du IGMPv3 aktiviert hast.

Das mit der IP eher nicht, denn dann würde Replay auch nicht funktionieren 🙂

Mach doch nochmals ein Force Prov., des Switches.

 

Gruss

 

 

Highlighted
Level 2
155 von 236

Hallo @Lori-77 

 

Der USGP hängt bei mir direkt im WAN. Sprich das WAN-Interface (eth2) hat ein GBIC Modul und bekommt direkt die öffentliche IPv4 Adresse.

 

Ich habe nun den USGP geresettet und neu provisioniert aber auch das bringt keinen Unterschied. Ebenfalls habe ich die Reservierungen für die TV Boxen gelöscht. Leider auch ohne Erfolg.

 

@snoopy5707 

Habe ich soeben auch gemacht. TV Box neugestartet.... leider keinen Unterschied.

 

Und komischerweise hat es ja eine Zeit lang funktioniert.

 

Danke für eure Inputs!

 

Beste Grüsse

Highlighted
Level 1
156 von 236

@Mister.Deeds 

 

So nebenbei.... hast du "Auto-Optimize Network" eingeschaltet??

Und getestet, ob der Proxy läuft??

 

ps -ef | grep igmpproxy

 

root 3512 1 0 2019 ? 00:04:06 /sbin/igmpproxy /etc/igmpproxy.conf

 

und die Information dazu??

 

show ip multicast interfaces

 

 

Editiert
Highlighted
Super User
157 von 236

Hallo @Mister.Deeds 

 

Was passiert wenn du die IB3 wieder anschliesst und mit dem Netzwerkkabel von der IB3 auf den WAN1=eth2 Port gehst. 

Ohne das du das GBIC drin hast funktioniert es dann? 

 

So weisst du ob du der USG4P richtig eingestellt hast. 

Auf dem Controller kannst du ja noch den Port einstellen. 

 

 

Gruss Lorenz

Highlighted
Level 2
158 von 236

Hallo zusammen

 

Vielen Dank für eure Rückmeldungen!

 

 

Nun bin ich der Sache auf die Schliche gekommen. Da ich den USGP direkt am Glas dran habe und der WAN Port mit dem VLAN 10 versehen ist, ändert sich auch der Name.
Somit ist es nicht "eth2" sondern "eth2.10". Meine config.gateway.json Datei sieht so aus:

 

{
	"protocols": {
		"igmp-proxy": {
			"interface": {
				"eth2.10": {
					"alt-subnet": [
						"0.0.0.0/0"
					],
					"role": "upstream",
					"threshold": "1"
				},
				"eth0": {
					"alt-subnet": [
						"0.0.0.0/0"
					],
					"role": "downstream",
					"threshold": "1"
				}
			}
		}
	},
	"interfaces": {
		"ethernet": {
			"eth2": {
				"description": "Internet Swisscom",
				"vif": {
					"10": {
						"dhcp-options": {
							"client-option": "send vendor-class-identifier "100008,0001";"
						}
					}
				}
			}
		}
	}
}

Die Firewalleinträge habe ich wieder via der Oberfläche gemacht.

 

Zu Beginn hatte ich den USGP hinter der Internet Box, somit war der WAN natürlich nicht mit einem VLAN getaggt. Da ich aber nun den Gateway direkt ans Netz genommen habe, hat sich dies geändert.

 

Schönen Sonntag zusammen und beste Grüsse

 

 

 

 

Highlighted
Level 1
159 von 236

Ich verwende https://jsonformatter.org/json-parser, um JSON-Daten zu validieren und zu analysieren

Highlighted
160 von 236

Ich bin auch die ganze Zeit am basteln.

 

Habe es wie in der Anleitung gemacht.

 

Das ist meine Config:

 

IB3:

- IP 192.168.0.1/24

- DHCP statische IP für USG auf 192.166.0.101

- DMZ auf USG gesetzt

- DDNS von SC aktiviert

 

USG:

- WAN auf DHCP gesetzt

 

Die Config File "config.gateway.json" im Unix Format und die Kodierung reines UTF-8 auf den CK kopiert.

 

Hier meine Abfrage ssh:

root@UniFi-CloudKey:/usr/lib/unifi/data/sites/default# ls

config.gateway.json  map

 

Die Regel alle wie abgebildet auch erstellt und den USG neu gestartet.

 

Aber nach ca. 5-10 sec bleibt das Bild immer noch stehen.

 

Was ich mich immer wieder Frage ist, warum in der Firewall Gruppe Regel unter der Adresse die 213.3.72.0/24 steht.

Muss ich da nicht meine statische IP für USG 192.166.0.101 eintragen?

 

Vielen Dank für eure Hilfe.

Nach oben