abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 
Gelöst
  • Der Fragesteller hat diesen Beitrag als gelöst markiert.

Eigene Webseite via xyz.internet-box.ch wird komisch dargestellt

Highlighted
1 von 7

Hallo zusammen

 

Habe mir mit MAMP einen eigenen Webserver eigerichtet und daraf ein Wordpress installiert. Hat alles geklappt. Nun wollte ich die Seite mit dem Swisscom DynDns Dienst internet-box.ch ins Netz stellen. Das klappt eigentlich auch, nur sieht die Seite von aussen aufgerufen völlig unbrauchbar aus! Nur Text und alles völlig verschoben. Als ob man mit einem uralten Browser drauf ginge. Habe es von verschiedenen Endgeräten aus versucht, überall das Selbe!

 

Was mache ich hier falsch? Danke für die Hilfe!

HILFREICHSTE ANTWORT

Akzeptierte Lösungen
Highlighted
Super User
5 von 7

Soo... 

Entschuldige ich hatte gestern noch etwas mehr los als geplant. Daher verspätet meine Antwort.

 

Ich habe mir die URL, die Du mir gesendet hast angesehen und bemerkt dass einige Fehler auftreten:

Die URL ist ja diese http://blog.internet-box.ch... Jedoch verweist die Seite von sich aus auf einige Dateien die gebraucht werden mit der Adresse localhost/wp/..../datei.js und so weiter.

 

Nun stellt sich für mich die Frage, ob du einen "echten Server" nutzt oder nur einen PC? Rein wirtschaftlich macht der Dauerbetrieb mit PC nicht viel Sinn. Schau dir dafür vielleicht mal den Raspberry Pi an ;).

 

Ich bin mir nicht sicher ob das Problem eventuell daran liegen kann dass Du die Installation über http://localhost/wp vorgenommen hast?

Mein Tipp fürs nächste Mal: mach Die installation von Wordpress am besten direkt via URL selber, damit ersparst du dir späteren Ärger.

 

 

Aber nun zu einer potenziellen Lösung: Besuche auf dem Server selber (also Lokal) mal die URL http://localhost/wp/wp-admin/options-general.php . Melde Dich falls nötig an.

 

Prüfe anschliessend die im unteren Bild rot markierten Felder, ob dort deine http://blog.internet-box.ch/wp-URL steht oder Localhost. Passe diese falls nötig mit der internet-box.ch-URL an.

Bildschirmfoto 2020-09-18 um 11.08.01.png

 

ACHTUNG! Die URL muss genau diese sein, welche Du später auch nutzen willst! Also z.B. https://test.ch oder https://blog.test.ch! Localhost kann Probleme mit sich bringen.

 

Starte danach, falls möglich den PC oder die Server-App neu.

 

Sollte es dann noch immer nicht klappen, kannst Du mir gerne mal einen Screenshot der Seite bei Dir in den Einstellungen senden. Dann können wir da noch tiefer gehen.

 

 

Gruess, Cordial salids, Cordialement, Cordiali saluti
Dominik

https://dev.exena.ga
6 Kommentare
Highlighted
2 von 7

Ich nehme an, dass die Web-Seite 'intern' richtig dargestellt wird - korrekt?

 

Ev. hast du absolute Adressen (mit dem Server / IP-Adresse) anstelle von relativen Adressen verwendet. Z.Bsp. musst du bei der Webseite angeben, wo das CSS und die Scripte liegen.

 

Prüfe mal, ob du überall relative Adressen benutzt werden.

Highlighted
Super User
3 von 7

Das mit den "internen Adressen" ist zwar eine Möglichkeit, diese schliesse ich jedoch eher aus, da Wordpress dieses Routing in der Regel übernimmt.

 

@Thappotauff91 wenn du möchtest, kannst du mir mal per Privatnachricht deine URL senden, dann werde ich mir das mal anschauen. 😉

Habe da so einige Tools womit es relativ schnell gehen kann.

Gruess, Cordial salids, Cordialement, Cordiali saluti
Dominik

https://dev.exena.ga
Highlighted
4 von 7

@Grioliflautt61  schrieb:

Ich nehme an, dass die Web-Seite 'intern' richtig dargestellt wird - korrekt?

 

Ev. hast du absolute Adressen (mit dem Server / IP-Adresse) anstelle von relativen Adressen verwendet. Z.Bsp. musst du bei der Webseite angeben, wo das CSS und die Scripte liegen.

 

Prüfe mal, ob du überall relative Adressen benutzt werden.


Also intern, also auf dem Server selber, wird sie korrekt angezeigt. Die Permalinks stehen auf "Tag und Name". Oder wo kann man da sonst noch etwas einstellen?

Highlighted
Super User
5 von 7

Soo... 

Entschuldige ich hatte gestern noch etwas mehr los als geplant. Daher verspätet meine Antwort.

 

Ich habe mir die URL, die Du mir gesendet hast angesehen und bemerkt dass einige Fehler auftreten:

Die URL ist ja diese http://blog.internet-box.ch... Jedoch verweist die Seite von sich aus auf einige Dateien die gebraucht werden mit der Adresse localhost/wp/..../datei.js und so weiter.

 

Nun stellt sich für mich die Frage, ob du einen "echten Server" nutzt oder nur einen PC? Rein wirtschaftlich macht der Dauerbetrieb mit PC nicht viel Sinn. Schau dir dafür vielleicht mal den Raspberry Pi an ;).

 

Ich bin mir nicht sicher ob das Problem eventuell daran liegen kann dass Du die Installation über http://localhost/wp vorgenommen hast?

Mein Tipp fürs nächste Mal: mach Die installation von Wordpress am besten direkt via URL selber, damit ersparst du dir späteren Ärger.

 

 

Aber nun zu einer potenziellen Lösung: Besuche auf dem Server selber (also Lokal) mal die URL http://localhost/wp/wp-admin/options-general.php . Melde Dich falls nötig an.

 

Prüfe anschliessend die im unteren Bild rot markierten Felder, ob dort deine http://blog.internet-box.ch/wp-URL steht oder Localhost. Passe diese falls nötig mit der internet-box.ch-URL an.

Bildschirmfoto 2020-09-18 um 11.08.01.png

 

ACHTUNG! Die URL muss genau diese sein, welche Du später auch nutzen willst! Also z.B. https://test.ch oder https://blog.test.ch! Localhost kann Probleme mit sich bringen.

 

Starte danach, falls möglich den PC oder die Server-App neu.

 

Sollte es dann noch immer nicht klappen, kannst Du mir gerne mal einen Screenshot der Seite bei Dir in den Einstellungen senden. Dann können wir da noch tiefer gehen.

 

 

Gruess, Cordial salids, Cordialement, Cordiali saluti
Dominik

https://dev.exena.ga
Highlighted
6 von 7

Danke vielmals! So einfach kann es sein. Und das beste ist, dass ich in der unteren Zeile bereits die richtige URL hatte.

 

Leider wirft eine Lösung dann auch gleich wieder weitere Fragen auf.

 

Ist es einfach möglich die Seite noch mit SSL (https) zu versehen? Momentan fehlt dies ja noch. Ist mir eben erst aufgefallen.

 

Noch zu deiner Frage nach dem Server. Ja ist nur ein "PC" (MacMini). Das ganze ist nicht als Dauerlösung gedacht und ja an einen Raspy habe ich auch schon gedacht. 😉

Highlighted
Super User
7 von 7

Gut dass es jetzt einigermassen Funktioniert.

 

Um auf weitere Fragen einzugehen:

 

  • Und wenn du mit dem Pi arbeitest:
    • Du kannst zum Beispiel DietPi (mit Apache2) nutzen und dies dann mit Certbot absichern
      • Kostenloses SSL von Let's Encrypt

 

Wenn Du eine etwas schönere URL haben möchtest, kannst Du dir sonst auch mal Freenom ansehen:

  • Kostenlose Domains (ga, ml, tk, ...)
  • Subdomains sind möglich
    • z.B. schweiz.ga
      • blog.schweiz.ga
      • free.schweiz.ga
      • ...
  • Mailempfang über diese Domain ist auch möglich

 

Bei Fragen, kannst Du jederzeit hier im Forum nachfragen. Wir versuchen Dir zu helfen.

Gruess, Cordial salids, Cordialement, Cordiali saluti
Dominik

https://dev.exena.ga
Nach oben