cancel
Showing results for 
Search instead for 
Did you mean: 

Selecting Swisscom as a network provider - 4G limited

Novice
1 of 7

Hi,

as I have a mobile subscription from a foreign country, every time I am in CH, I have the possibility to switch between carriers. By far, where i am located, Swisscom has the best coverage. Only issue is that 4G connectivity is heavily restricted, resulting in very low internet speed, not allowing web browsing or messaging. 

Although, when switched to 3G / 2G, the Swisscom network seems to work.

 

Is there something that needs to be specified in the phone's settings in order to have a 4G with Swisscom that works ?

Thanks for your help.

 

6 Comments
Expert
2 of 7

Hi there,
Apparently there are configuration problems on your phone.


Every time you "change" the provider - that is to say change the SIM, you should receive a "welcome message" or a "setup message" from the provider.

 

Because you now have various configurations (e.g. from your home country e.g. Vodafone in Germany, Salt and Sunrise from your previous tests) available on your device, it is possible that the device cannot connect correctly to Swisscom.

I therefore always recommend that you insert a different SIM, even if it is within the country to remove the configurations.

Note that the APN settings are adjusted in the "Setup message".

You must therefore reset them and overwrite them with the new ones from Swisscom.

 

Instructions for removing APN's can be found here: https://my.econnectjapan.com/set-up/uninstall/#android

You can find sample instructions for adding the Swisscom APN on Android here: https://devicesupport.swisscom.ch/huawei/mate-20-pro/getting-started/set-up-your-mobile-phone-for-in... ,
Depending on the device, the menu items may vary slightly!

 

On iPhones it is possible that APNs are automatically adapted depending on the version of the device.

However, you will find a good help here: https://support.apple.com/en-md/HT201699


It is important that you restart your mobile after editing the APN's. Otherwise the device may not be able to dial into the network correctly.

 

If the APN is configured correctly, you should be able to use 4G at speeds of up to 100 Mbit / s with inOne Mobile Go and with prepaid from around 30 to 50 Mbit / s.

 

I hope I was of help. Otherwise, please let me know if you need further assistance.

Kind regards,
Dominik

Viele Wege führen zum Ziel - wenn dir meine Antwort gefällt, drück doch auf den Daumen - wenn sie dein Problem gelöst hat, drück auf das Häckchen.

https://herbertvonkaramalz.github.io
Novice
3 of 7

Hi, thanks for your reply. My issue is a bit different, apologies if it was not clear on my side: I do not have a subscription with Swisscom. I have an "European" subscription from Vodafone which includes Switzerland and have the possibility to select carriers (Salt, Sunrise & Swisscom) when in CH.

Nevertheless, every time I switch to Swisscom 4G's network, it seems to be limited, and I'm not able to even load a web page. Swisscom 3G works fine, but it's 3G.... other carriers do not have a better coverage in my location.

 

Is there any known limitation in Swisscom's 4G network when used with a foreign provider ?

 

Thanks for any of your help.

Expert
4 of 7

Hi there!
Excuse me, I misunderstood you.

 

In fact it is the case that Swisscom limits the speeds to 3G and 4G to the contract - I think in your case a contract with similar services is taken as a comparison.

 

With us it is the case that very small subscriptions usually have 30 Mbit / s. Medium subscriptions get 50 Mbit / s and the large subscriptions then have a maximum of about 100 Mbit / s.

 

You can only have faster internet if you pay for something.

However, I do not know exactly what the contracts between Vodafone and Swisscom for this offer are.
I would suggest that if you are in Switzerland, just go to a Swisscom shop and ask. Alternatively you can call: 0041 800 800.

 

If you are in the country where your subscription is connected, I would ask Vodafone directly. Most of these can also help you.

 

But I'm still guessing a configuration error on the part of Swisscom or with the APN access on your phone.

I personally have tried different SIM cards, among others from Sri Lanka and Great Britain, but the speed was not slow but about the same level as in the other countries (Sri Lanka: 50 Mbit / s; Great Britain: 30 Mbit / s ).

 

Best regards,
Dominik

Viele Wege führen zum Ziel - wenn dir meine Antwort gefällt, drück doch auf den Daumen - wenn sie dein Problem gelöst hat, drück auf das Häckchen.

https://herbertvonkaramalz.github.io
Novice
5 of 7

Thanks Dominik, I think there's an agreement between Swisscom and my specific foreign provider which is not working very well for me.

 

I tried playing around with APN settings, but there's not much configurations to change e.g. IPV v4 / v6, added the Swisscom proxy etc... but no success.

 

There should be more transparency between Swisscom and the different agreement between countries !

Best regards.

Highlighted
Expert
6 of 7

Hi,

did you already asked someone from Swisscom e.g in a Shop or by Hotline?

Maybe they could have an idea on how to fix this issue...

 

Best regards

Viele Wege führen zum Ziel - wenn dir meine Antwort gefällt, drück doch auf den Daumen - wenn sie dein Problem gelöst hat, drück auf das Häckchen.

https://herbertvonkaramalz.github.io
Novice
7 of 7

Not yet, will keep you posted when done

Back to top