annulla
Visualizzazione dei risultati per 
Cerca invece 
Intendevi dire: 
RISOLTO
  • L'interrogante ha segnato questo contributo come risolto.

SIP Credentials ed Asterisk

Highlighted
Level 1
Level 1
1 di 3

Buongiorno a tutti, 

 

sto utilizzando le credenziali SIP di una linea inOne con un PBX Asterisk (v.11) ed in generale riesco ad effettuare e ricevere chiamate.

Tuttavia dopo poco piu' di un minuto di inutilizzo resto irraggiungibile e mi becco un :

[2019-06-07 10:33:06] WARNING[10210][C-00000529]: chan_sip.c:23019 handle_response_invite: Received response: "Forbidden" from '<sip:+4191922XXXX@swisscom.ch>;tag=as6cd12bc5'

fino al successivo refresh della registrazione da parte di asterisk, che avviene ogni circa 3 minuti, dato che il tempo di expiry di fs1.ims.swisscom.ch e' di minimo 179 secondi.

Attualmente uso questa configurazione sul trunk di FreePBX:

 

OUTGOING:

user=+41919XXXXX
type=peer
srvlookup=yes
secret=XXXXXXXXXXX
outboundproxy=fs1.ims.swisscom.ch
nat=yes
insecure=invite, port
host=swisscom.ch
fromuser=+41919XXXXX
fromdomain=swisscom.ch
dtmfmode=auto
disallow=all
defaultuser=NC00000XXXXXX@swisscom.ch
canreinvite=no
allow=alaw & ulaw & g729 & gsm & slinear & ulaw

INCOMING:

type=peer
host=fs1.ims.swisscom.ch
fromdomain=swisscom.ch
disallow=all
allow=alaw & ulaw & g729 & gsm & slinear & ulaw

Con una register string:

+41919XXXXX@swisscom.ch:XXXXXXXX:NC00000XXXXXX@fs1.ims.swisscom.ch/+419192XXXXX

Per ora ho aggirato il problema con un cronjob che ricarica il sip ogni minuto e quindi rieffettua il register, ma non e' una soluzione che mi piace molto e vorrei capire se qualcuno ha lo stesso problema e/o e' riuscito a dominare la cosa.

 

Grazie

Giuseppe

LA RISPOSTA PIÙ UTILE

Soluzioni accettate
Highlighted
Level 1
3 di 3

Ciao Yari, 

ho parzialmente risolto la questione, nel senso che sono riuscito a fare funzionare il tutto con il CHAN_SIP ma non il CHAN_PJSIP.

Comunque la configurazione funzionante per il trunk e' questa:

 

OUTGOING:

user=+$NUMBER
type=peer
srvlookup=yes
secret=$SECRET
outboundproxy=fs1.ims.swisscom.ch
nat=yes
insecure=invite, port
host=swisscom.ch
fromuser=+$NUMBER
fromdomain=swisscom.ch
dtmfmode=auto
disallow=all
defaultuser=$LOGIN@swisscom.ch
canreinvite=no
allow=alaw & ulaw & g729 & gsm & slinear & ulaw

 

INCOMING:

type=peer
host=fs1.ims.swisscom.ch
fromdomain=swisscom.ch
disallow=all
allow=alaw & ulaw & g729 & gsm & slinear & ulaw

 

REGISTRATION STRING:

+$NUMBER@swisscom.ch:$SECRET:$LOGIN@fs1.ims.swisscom.ch/+$NUMBER

 

E' anche necessario che il default expiry sia impostato a 120 e che il CHAN_SIP sia in ascolto sulla porta 5060 e non su altre (per esempio negli ultimi FreePBX la 5060 e' usata dal pjsip e il chan_sip e' sulla 5160).

Senza il chan_sip sulla 5060 si riuscira' solo a ricevere ma non ad effettuare chiamate.

 

Spero che questo post possa essere utile a tutti e magari che qualcuno riesca a trovare i giusti settings per il chan_pjsip

 

Giuseppe

 

2 Commenti 2
Highlighted
Moderatore
2 di 3

Caro Giuseppe, 

 

Ti contatto per sapere se avessi trovato una soluzione alla tua domanda.

 

Cari saluti

N'oubliez pas d'accepter les solutions ?! Salutations
Highlighted
Level 1
3 di 3

Ciao Yari, 

ho parzialmente risolto la questione, nel senso che sono riuscito a fare funzionare il tutto con il CHAN_SIP ma non il CHAN_PJSIP.

Comunque la configurazione funzionante per il trunk e' questa:

 

OUTGOING:

user=+$NUMBER
type=peer
srvlookup=yes
secret=$SECRET
outboundproxy=fs1.ims.swisscom.ch
nat=yes
insecure=invite, port
host=swisscom.ch
fromuser=+$NUMBER
fromdomain=swisscom.ch
dtmfmode=auto
disallow=all
defaultuser=$LOGIN@swisscom.ch
canreinvite=no
allow=alaw & ulaw & g729 & gsm & slinear & ulaw

 

INCOMING:

type=peer
host=fs1.ims.swisscom.ch
fromdomain=swisscom.ch
disallow=all
allow=alaw & ulaw & g729 & gsm & slinear & ulaw

 

REGISTRATION STRING:

+$NUMBER@swisscom.ch:$SECRET:$LOGIN@fs1.ims.swisscom.ch/+$NUMBER

 

E' anche necessario che il default expiry sia impostato a 120 e che il CHAN_SIP sia in ascolto sulla porta 5060 e non su altre (per esempio negli ultimi FreePBX la 5060 e' usata dal pjsip e il chan_sip e' sulla 5160).

Senza il chan_sip sulla 5060 si riuscira' solo a ricevere ma non ad effettuare chiamate.

 

Spero che questo post possa essere utile a tutti e magari che qualcuno riesca a trovare i giusti settings per il chan_pjsip

 

Giuseppe

 

Scorrere verso l'alto