cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

VPN connection never works for me

Helvet
Level 3
1 of 7
Happy New Year, everyone.
 
I have a problem with VPN.  I checked with Swisscom shop. Staff  there could not help because they were salesmen not technicians. The techy guy on Swisscom hotline could not figure out the issue and pointed me to the Community website, so here I am.
 
I have an InOneHome package for over a year now and recently replaced Internet-Box 2 with a slim Internet-Box 3.  Everything seems to be working so far, except the VPN connection. As a matter of fact, my Swisscom VPN has never worked for me from the first time I tried a year ago.
 
I followed religiously the step-by-step instruction given on the  Help page on VPN connection .
 
I created my own DynDNS address (mingle.internet-box.ch) on MySwisscom homepage (under the menu Network with Expert mode on).  Shared key for VPN and password for one individual user plus the DynDNS address have  been duly entered in the VPN setup of my Android phone and my laptop PC.
 
Yet, every attempt has failed to connect to my VPN from outside my home, including from Swisscom free Wfif in  a Swisscom Shop.
 
My Android phone showed 'Connection unsuccessful' without giving details of the problem.
 
My laptop showed the following error message  after failure to connect to my home VPN from a public WiFI:
'Cant't connect to HomeVPN
The L2TP connection attempt failed because the security layer encoutered a processing error during initial negiations with the remote computer'
(Sorry. Impossible to embed screenshots in the post)
 
 

 

When I manually entered my DynDNS mingle.internet-box.ch in the address pane a browser, it was not working. The following error messages showed up:
 
This page isn’t working
mingle.internet-box.ch didn’t send any data.
ERR_EMPTY_RESPONSE (Chrome browser)
 

The connection was reset

The connection to the server was reset while the page was loading. (Firefox browser)

 

I would be grateful for enlightenment and help on solving my VPN mystry.

 
 
6 Comments 6
DomiP
Level 3
2 of 7

There might be an error with the Domain, DynDNS itself. It shows errors for your page also at my PC...

 

Did you routed your URL to the correct Port/Device?

Gruess, Cordial salids, Cordialement, Cordiali Saluti, Cheers!
Dominik

Helvet
Level 3
3 of 7

Thanks for your reply.


Did you routed your URL to the correct Port/Device?


I used the default network setting. Could you please tell me how to find out if the URL was routed  to the correct Port/Device?

 

FYI: here are some of the settings on my Internet-box:

DynDNS: Activated

 

IP application part: Automatic

DNS Server: Automatic

IP address distribution (DHCP): Activated

Static IP address has been assigned to TV-Box-Swisscom

Spanning Tree Protocol; Not activated.

 

DMZ: Not activated.

 

Automatic port forwarding (UPnP IGD): Enabled.

 

Firewall mode: Standard

Static routes: None

 

Is the above setting correct for VPN to work?

 

By the way, a WLAN box is used for connecting TV Box in another room in my home.

 

 

DomiP
Level 3
4 of 7

@Helvet it depends if you are using an own VPN-Service (like on a PC or Raspberry Pi) then you should route the Port of the VPN-App (lets say 1194 for OpenVPN) to your Device into the Port-Forwarding-Options.

 

If you are talking from the built-in VPN from the Internet-Box and the Configuration as following is not working, try to deactivate VPN and DynDNS. Then restart the Box and reenable the VPN and DynDNS. Then it could probably work...

 

To connect a mobile device to your IB-VPN, use the following instruction: https://www.swisscom.ch/en/residential/help/internet/vpn-server.html

 

 

I expericened personally, that it doesn't work correctly on my Huawei Mate 20-Device, but on my old iPhone 7 it worked. It seems to be a problem with the VPN-Settings of my Android Device - in my Case.

 

If you are stuck also after the troubleshooting as told above, please do not hesitate to write here again. It would be glad if you can tell us exactly which device you are using, including Version and Operating-System.

 

Cheers!

Gruess, Cordial salids, Cordialement, Cordiali Saluti, Cheers!
Dominik

Helvet
Level 3
5 of 7
@DomiP Thanks for your detailed responses so far. 
I am trying to use the built-in VPN of my Swisscom Internet-Box. I do not use or have my own VPN.
This morning, as advised, I deactivated VPN an DynDNS before re-booting the Internet-Box and re-enabled VPN and DynDNS after its re-start.
Unfortunately, the same outcome: VPN connection was not possible from my Huawei P30 Pro (Android 10, EMUI 10.1.0) or my old iPad Mini (iOS 9.3.5).
 
DomiP
Level 3
6 of 7

Seems strange. It should probably work without further settings in the Box.

 

@ThomasS do we have an Expert for Networking/VPN here in the Community?

Gruess, Cordial salids, Cordialement, Cordiali Saluti, Cheers!
Dominik

MichelB
Level 3
7 of 7

@Helvet : I checked your DynDNS. It's correctly resolving on your current IP. No problem there.

Did you take the hint on the help page into account:

https://www.swisscom.ch/en/residential/help/internet/vpn-server.html 

 

VPN connection not working?

This can happen when you test the VPN connection at home. If you are connected to your own home network, you cannot connect to the VPN. Check the VPN connection when you are not at home and not connected to your home network.

 

Can you try if it's working when using mobile instead of WiFi on your mobile.

 

Cheers,

MichelB

Experience Developer Router @ Product & Marketing Department, Swisscom (Schweiz) AG
Back to top