cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED
  • The questioner has marked this post as solved.

Upload speed painfully slow: Internet box plus

Contributor
1 of 4

I have a Internet box plus, with a Swisscom Internet S package. I'm not expecting our speed to be impressive, but I should have up to 40 Mbit/s (5MB/s) download/upload speed, and our neighbourhood is supported for 1Gbit/s speeds according to the Swisscom address checker. Running the Swisscom internet test, as well as dslreports.com's speedtest, I get the following results:

 

Swisscom: DL = ~2.13Mbit/s, UL = ~0.1Mbit/s

 

Screen Shot 2017-11-12 at 9.58.43 PM.png

dslreports summary of multiple tests:

 Screen Shot 2017-11-12 at 10.11.58 PM.png

 

Bizarrely, I get the same results when connected to the router by LAN (Fiber) or WiFi. So my network connection is great. Our upload speed is a problem though: video calls and online games constantly drop out.

 

I have manually updated the router's firmware to the latest version and rebooted the router, with no improvement. As mentioned, I have also tested the connection via LAN and WiFi (on a macbook pro), and I get the same results with our Nintendo Switch (WiFi).

 

Any suggestions?

MOST HELPFUL ANSWER

Accepted Solutions
Contributor
3 of 4

There is a technician coming to check out the internet box next week, so if it's a cable or something, we'll find out.

a) IB GUI = Internet Box GUI? I will check when I am home next, but note that I do get the same DL/UL speed when plugged in by LAN to my internet box.

b) I didn't include a screenshot to avoid cluttering the page, but the Swisscom home app measures the same speeds. My last test measured 2.13 Mbit/s DL and 0.09 MBit/s UL.

3 Comments
Super User
2 of 4

can you measure again with

a) the internet speed test of your internet box (accessible via IB GUI)

b) use the swisscom home app and do a speedtest from there

post your resulsts again please

Contributor
3 of 4

There is a technician coming to check out the internet box next week, so if it's a cable or something, we'll find out.

a) IB GUI = Internet Box GUI? I will check when I am home next, but note that I do get the same DL/UL speed when plugged in by LAN to my internet box.

b) I didn't include a screenshot to avoid cluttering the page, but the Swisscom home app measures the same speeds. My last test measured 2.13 Mbit/s DL and 0.09 MBit/s UL.

Contributor
4 of 4

Our connection was apparently set up through Swisscom Casa (max DL/UL at 2MB/s and 0.2MB/s). All is good now.