cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED
  • The questioner has marked this post as solved.

Port Forwarding Problems on Centro Grande

Highlighted
Novice
1 of 3

I have some issues regarding port forwarding setup on my Centro Grande modem/router.

 

Whenever I modify port forwarding rules the router simply crashes, I have to manually restart it a couple of times before it works again, it's super annoying... My computers cannot connect to the Wi-Fi, even though the Wi-Fi and internet status lights are OK. I guess there's something wrong with the DNS. Does this happen to anybody else?

 

Also I'd like to choose the input and output ports in the forwarding rules. I have different computers on my network and I'd like to SSH to them (port 22 on multiple computers), but Centro Grande only allows forwarding ports one to one. Bascilly I want to make rules in the "Services" tab such that myHomeIP:1 (arbitrary) goes to computer1:22, myHomeIP:2 goes to computer2:22... Is there any way to do this without having to use another router?

 

To illustrate that:

 

Instead of one service taking care of port 22...

Screen Shot 2015-10-16 at 14.27.29.png

 

...I'd like to make 2 services, each having an input port and an output port. The service is tied to one machine on the network.

 

Service 1, for computer1:

Screen Shot 2015-10-16 at 14.26.56.png

Service 2, for computer2:

Screen Shot 2015-10-16 at 14.27.12.png

 

 

The Centro Grande control panel has been simplified too much IMO... I'd like to have more freedom in how I set up my home network. My suggestion is an "advanced control panel" where the user could access all the functionalities of a standard router. Actually it'd be nice to be able to access the router system and do things from the command line...

MOST HELPFUL ANSWER

Accepted Solutions
Novice
2 of 3

I was thinking about using another modem/router than the Centro Grande, with a firmware that suits me better.

 

Is it technically possible to use a different modem than the one provided by Swisscom?

 

Never mind, I found the solution using the Centro Grande. It turns out it is possible to define the external and local ports, but not from the web interface. Here's the topic with the solution.

 

Basically one must telnet to the router and change the rules from command line, it's super easy:

 

$ telnet 192.168.1.1

The credentials are the same as for the graphical user interface, so probably <admin> and your router password

 

You can type "ls" to view the commands available to you.

 

$ portmap add <serice name> <external port> <ip of device> <internal port> <protocol>

For me it was

 

$ portmap list
$ portmap add osmc1ssh 221 192.168.1.101 22 tcp $ portmap add osmc2ssh 222 192.168.1.102 22 tcp
$ save
$ portmap list

Now I can access the ssh port 22 of both of my computers, using ports 221 and 222.

 

I called Swisscom support and they were completely unhelpful, they said it cannot be done and didn't even try to find a solution... quite appalling service I must say.

Edited
2 Comments
Novice
2 of 3

I was thinking about using another modem/router than the Centro Grande, with a firmware that suits me better.

 

Is it technically possible to use a different modem than the one provided by Swisscom?

 

Never mind, I found the solution using the Centro Grande. It turns out it is possible to define the external and local ports, but not from the web interface. Here's the topic with the solution.

 

Basically one must telnet to the router and change the rules from command line, it's super easy:

 

$ telnet 192.168.1.1

The credentials are the same as for the graphical user interface, so probably <admin> and your router password

 

You can type "ls" to view the commands available to you.

 

$ portmap add <serice name> <external port> <ip of device> <internal port> <protocol>

For me it was

 

$ portmap list
$ portmap add osmc1ssh 221 192.168.1.101 22 tcp $ portmap add osmc2ssh 222 192.168.1.102 22 tcp
$ save
$ portmap list

Now I can access the ssh port 22 of both of my computers, using ports 221 and 222.

 

I called Swisscom support and they were completely unhelpful, they said it cannot be done and didn't even try to find a solution... quite appalling service I must say.

Edited
Novice
3 of 3

It appears Swisscom has disabled many telnet commands.  I get errors trying to set port mapping on the command line.  Unless I'm doing something terrible wrong.