abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 
  • Der Fragesteller hat diesen Beitrag als gelöst markiert.

Streaming: Microruckler & Tonaussetzer

Gelöst
Contributor
Nachricht 1 von 4

Hallo COmmunity

Ich hoffe jemand hat eine Idee für mein kleines (leider Nerviges Problem).
Folgendes Setup:

Swisscom Glas Modem (1GB)
Swisscom TV UHD
Synology NAS DS1515+
Nvidia Shield TV
Switch Wohnzimmer: Netgear GS908E
Switch Arbeitszimmer: Netgear GS908E

Gestreamt wird vom NAS. Der Source ist via NFS Protokoll freigegeben und wird direkt von der Shield verarbeitet.
Als Streaming Software ist Kodi/SPMC im einsatz.

Die Problematik liegt darin, das es beim Streaming von 4k Material mit 3D Tonformaten (Auro/DTSX/Atmos) gerne mal zu sogenannten Microruckler(Bild) und ganz kurzen Tonaussetzer kommt. Die Aussetzer sind willkürlich und tretten nicht an der selben Stelle auf, somit schliesse ich das Quellmaterial aus.

Meine Vermutung liegt irgendwo im in den Netzwerkprotokollen.
Daher wäre ich Dankbar, wenn mir jemand ein paar Tips hat....

Gruss

chlu

 

HILFREICHSTE ANTWORT

Akzeptierte Lösungen
Contributor
Nachricht 4 von 4

So, auch hier mal noch ein kleines Update.
Musste mir die Lösung erst nochmal erarbeiten...
Es scheint auch nicht an der Netz Konfiguration zu liegen, sondern brauchte ein paar andere Eingriffe

Folgendes habe ich geändert:

Nvidia Shield Android TV HDMI Settings angepasst:

4:2:2 (BT2020) mit 12 Bit

Desweiteren im Kodi die Cache Settings aktiviert mittels der AdvancedSettings.xml mit folgenden Werten:

 

 <cache>
  <memorysize>104857600</memorysize>
  <buffermode>1</buffermode>
  <readfactor>4</readfactor>
 </cache>

 

Zusätzlich in den Playback Einstellungen für Video im Kodi, die Option aktiviert für das Anpassen der Bildwiederholfrequenz beim Starten und stoppen eines Filmes.


Seither läuft alles stabil.
Werde dies aber sicher noch weiter beobachten und gegebennenfalls auch hier gerne nochmal ein update posten...

3 Kommentare
Super User
Nachricht 2 von 4

http://linux-voodoo.de/2017/03/synology-video-station-audio-format-wird-nicht-unterstuetzt/

 

Lies dir dies mal durch  ev hilfts. Hatte bei einem Kunden ein ähndliches problem, da war dies die lösung

Contributor
Nachricht 3 von 4

Danke Dir für den Hinweis @FlySmurf
Jedoch liegt darin leider nicht die Lösung,da es in dem Artikel um den DTS Support der Synology Videostation geht.
Das Problem ist nicht, das ein Audio Tonformat nicht unterstützt wird. Es wird alles abgespielt, aber wie gesagt es kommt immer wieder zu leichten ruckler im Bild bei 2160p Videos. Wenn das File ein 3D Tonformat (Atmos; DTS-X, AUro-3D) hat, gibt es auch kurze Tonaussetzer. Wenn ich dann kurz zurückspule, läuft die selbe passage ohne Probleme. 
Gemäss auslastung der Shield, tummelt diese aber eher vor sich hin und ist alles andere als wirklich ausgelastet...

 

Contributor
Nachricht 4 von 4

So, auch hier mal noch ein kleines Update.
Musste mir die Lösung erst nochmal erarbeiten...
Es scheint auch nicht an der Netz Konfiguration zu liegen, sondern brauchte ein paar andere Eingriffe

Folgendes habe ich geändert:

Nvidia Shield Android TV HDMI Settings angepasst:

4:2:2 (BT2020) mit 12 Bit

Desweiteren im Kodi die Cache Settings aktiviert mittels der AdvancedSettings.xml mit folgenden Werten:

 

 <cache>
  <memorysize>104857600</memorysize>
  <buffermode>1</buffermode>
  <readfactor>4</readfactor>
 </cache>

 

Zusätzlich in den Playback Einstellungen für Video im Kodi, die Option aktiviert für das Anpassen der Bildwiederholfrequenz beim Starten und stoppen eines Filmes.


Seither läuft alles stabil.
Werde dies aber sicher noch weiter beobachten und gegebennenfalls auch hier gerne nochmal ein update posten...