cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Grandstream GXP2130 - VOIP outgoing calls no longer work

jason.j2
Super User
1 of 9

I am using 3 VOIP phones connected directly to my Swisscom router (well, there is an unmanaged switch in-between): 2 Grandstream GXP2130 phones and one Cisco "dumb" VOIP phone.

 

I've set these up 2 or 3 years ago using the SIP settings provided by the swisscom router and everything worked perfectly since then.  The phones do not get automatic updates.

 

About 1 or 2 months ago the Grandstream phones became unable to dial out.  All phones can still receive calls without problem, voice is ok, etc. and the Cisco can still dial out without problem.  But on the Grandstreams, now when you dial any number they instantly do a busy signal and the phone shows "NO RESPONSE" on the display.

 

Given that I've changed nothing, and it is affecting both phones Swisscom must have changed something recently in their VOIP protocol.  I don't know enough about this technology to troubleshoot it myself.  Does anyone know anything about this?  I tried calling support but they said they do not have support for VOIP beyond simple configuration checking on the router.  Any support would be greatly appreciated.

8 Comments 8
LeylaG
Super User
2 of 9

Hello @jason.j2

 

We made some change lately, see this post.

 

We also informed affected customers by letter and phone.

 

Since the 1st of April, only the following outbound proxy is available fs1.ims.swisscom.ch

 

Let me know if it is working after that setting change?

 

 

Un like fait toujours plaisir 😉 Une réponse t'a aidé? -> Accepte-la comme solution!
A like always brings a smile 😄 Don't forget to accept helpful solutions
jason.j2
Super User
3 of 9

Hi and thanks for your response

 

I tried the server you mentioned but the phone would not connect.  Under "Local Phone Credentials" in my Swisscom router I see the following instructions:

 

Authentication user name: Your authentication user name defined above
Authentication password:   Your password defined above
Username:                                 The internal phone number matching your phone credentials (e.g. 220)
Display name:                           Your name
Domain:                                      192.168.1.1
Proxy server address:             192.168.1.1
Proxy server port:                    5060
Registration server:                192.168.1.1
Registration port:                   5060
STUN server:                            No
Outbound proxy address:  192.168.1.1
 
So I put fs1.ims.swisscom.ch as the SIP server, this did not work.  I tried it as the SIP server with 192.168.1.1 as the outbound proxy, which the phone thought was working but I still could not make outbound calls.  Having 192.168.1.1 as the SIP server with fs1 as the outbound proxy makes no sense since the fs1 server won't know how to get to 192.168.1.1 (though I did try it anyway, and it did not work).
 
It's still not clear to me what settings I should be using.
 
Thanks
LeylaG
Super User
4 of 9

Hi again @jason.j2

 

A specialist will get in touch with you as there is probably something wrong with your phones.

 

Have a nice afternoon

Un like fait toujours plaisir 😉 Une réponse t'a aidé? -> Accepte-la comme solution!
A like always brings a smile 😄 Don't forget to accept helpful solutions
jason.j2
Super User
5 of 9

Hi

 

Is there any update here?  I don't believe there is a problem with my phones.  I have 2 of the exact same model and both worked for several years now with no issue.  Swisscom has obviously changed something and I need help in how the phones must now be configured.

 

Alternatively, if you could set things back like they were that would also fix the problem.

Zarkex01
Super User
6 of 9

yeah, he's not trying to use the phones externally, he's trying to use the Internet Box's integrated PBX locally.

 

Have you tried deleting your accounts for your phones in the Internet Box and adding it again?

jason.j2
Super User
7 of 9

I have, multiple times.  Factory resets, etc.

Rizeuttausch36
Super User
8 of 9

I'm also interested in an update to this, as my Grandstream phones have also lost their ability to make outgoing calls.

 

Clearly something changed within the Internet Box, and now all that appears to happen is that I get an authentication failure (407) response from the box whenever I try to make outbound calls.

 

Therefore, is there any way to roll back to a previous version of the Internet Box firmware, or can the Swisscom engineers release a new version which allows us to turn off whatever they "fixed"?

apeknx
Super User
9 of 9

@Rizeuttausch36 @jason.j2 

Did you find a solution?
I have the same problem.

Back to top