abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 

Outbound-Caller-ID bei inOne KMU Office und 3CX

Highlighted
Novice
1 von 9

Hallo zusammen.

 

Meine Frage ist wohl ziemlich spezialisiert, aber evtl. kann mir doch jemand helfen.

 

Wir haben inOne KMU Office mit "Business Telefonie S". Den entsprechenden SIP-Trunk konnte ich in unserer 3CX-Anlage auch einrichten und ein- sowie ausgehende Telefonie funktioniert. Wir würden nun aber gerne unsere Oudbound-Caller-ID selbst festlegen, damit Kunden uns auf unserer (nicht-Swisscom) Hauptnummer zurückrufen.

 

Leider ist dies bisher nicht von Erfolg gekrönt: sobald eine Caller-ID definiert wird ist kein Anruf mehr möglich. 3CX zeigt folgenden Fehler:

01/02/2019 1:31:27 PM - Call to T:Line:10002>>076XXXXXXXX@[Dev:sip:+41XXXXXXXXX@swisscom.ch:5062] from L:7643.1[Extn:402] failed, cause: Cause: 403 Forbidden/INVITE from 195.186.128.164:5060

 

Wir verwenden nicht die lokalen SIP-Credentials vom Centro Business 2.0, sondern haben 3CX direkt mit fs1.ims.swisscom.ch konfiguriert.

 

Weiss jemand hier, ob und wie wir unsere Vorstellung umsetzen können?

 

8 Kommentare
Super User
2 von 9

Als erstes würde ich die lokalen sipcredentials vom centro verwenden. Die callerid kannst du siviel ich weiss im siptrunk definieren. Wo weiss ich gerade nicht auswendig.

 

Warum nimmst du nicht die hauptnummer auf die 3cx?

Editiert
Novice
3 von 9

Wir haben den Centro Business 2.0 im PPPoE-Passthrough-Modus konfiguriert aufgrund mehrerer statischen Public-IPs welche wir direkt auf eigener Hardware terminieren wollen. Dementsprechend ist natürlich der Centro vom LAN her nicht mehr erreichbar. Wir könnten höchstens die 3CX mit einer zweiten NIC ausstatten und diese mit dem LAN-Port-2 des Centro verbinden - diese Lösung möchte ich jedoch vermeiden.

 

Im Siptrunk selbst kann ich im Reiter "Caller ID" die gewünschte ID hinterlegen - per Wireshark sehe ich auch dass diese beim SIP Invite an Swisscom mitgegeben wird, jedoch ist ab diesem Moment keine Verbindung mehr möglich -> der erwähnte 403 Fehler.

 

Die Hauptnummer ist bereits auf der 3CX hinterlegt. Wir sind aktuell am Evaluieren ob wir evtl. komplett auf Swisscom wechseln sollen deshalb wollten wir erste Tests mit der bereits verfügbaren Swisscom-Nummer durchführen.

Super User
4 von 9

Du kannst auf dem cb den dhcp auf dem lan abschalten und diesen mitels lankabel an port 2 bis 4 an deine switch anschliessen. So ist dieser auch per lan erreichbar

Novice
5 von 9

Da habe ich wohl irgendwie viel zu weit gedacht :smile_sweat:

Habe nun den Centro ebenfalls ins LAN genommen, und auf der 3CX lokale SIP-Credentials eingetragen. Verbindung funktioniert immernoch nur, solange im SIP-Trunk oder auf einer Nebenstelle keine abweichende Outbound-Caller-ID hinterlegt ist.

 

Wenn als Outbound-Caller-Id die Swisscom-Nummer eingetragen wird funktionieren ausgehende Anrufe. Wenn jedoch schon nur eine Ziffer abweichend ist, jedoch im selben Format, ertönt die Ansage "Anruf wurde vom Administrator verboten".

 

Könnte es sein, dass bei inOne KMU einfach keine Outbound-Caller-ID zugelassen ist?

Super User
6 von 9

Mach die nummer mal im e.164 format, also 41xxxxxxx. Die ansage der anruf wurde vom administrator verboten kommt von der pbx

Novice
7 von 9

Hat leider nichts gebracht. Angenommen unsere Swisscomnummer ist +41001112233

 

Wenn ich +41001112233 als Caller-ID Angebe funktioniert der Anruf. Mit 41001112233 klappt es nicht, genausowenig mit +41001112234. Die Ansage kommt schon von der PBX, aber gemäss Wireshark wird vom Centro (oder von fs1.ims.swisscom.ch falls Trunk direkt mit Cloud registriert) das 403 Forbidden als Antwort auf den SIP-Invite geschickt.

Super User hed
Super User
8 von 9

Soviel ich weiss ist das nur mit der Option "Special Arrangement" möglich.

Ob das im inOne KMU Office inkludiert ist oder separat bestellt werden muss, ist mir nicht bekannt. 

 

Betreffend Format musst du immer das Format "+E.164" verwenden, darum funktioniert es auch mit deiner Nummer nicht, wenn du das + weg lässt.

Editiert
Novice
9 von 9

Nach Kontakt mit der Swisscom wurde mir mitgeteilt, dass die Option "Special Arrangement" für inOne KMU Office nicht verfügbar ist. Die einzige Möglichkeit die ausgehende Rufnummer zu verändern, ist über die "Business Telephony" App - und auch dann ist nur eine Rufnummer aus dem selben Block verwendbar.

 

Schade, aber ist wohl nicht umsetzbar wie wir uns dies vorstellen.