abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 

Nur einseitige Audio mit Swisscom SIP Credentials auf Fritzbox 7490

Contributor
1 von 20

Seit Kurzem habe ich die nun erhältlichen Swisscom Credentials auf meiner Fritzbox 7490 programmiert. Funktioniert an sich einwandfrei, die Registrierung klappt, doch ich habe ein Problem: Es kommt relativ häufig vor, dass der Sprechweg in einer Richtung nicht durchgeschaltet wird. Meistens kann mich der Angerufene hören, doch auf meiner Seite herrscht Stille. Ich höre auch keinen Rufkontrollton, obwohl es beim Angerufenen läutet. Das Problem tritt sporadisch auf.

 

Mich würde interessieren, ob auch andere dieses Problem kennen und ob es eine Lösung gibt, dieses zu beseitigen.

19 Kommentare
Expert
2 von 20

Hallo funke44

 

Einseitiges Audio ist so etwa das häufigste Problem bei VOIP... leider

 

Ich denke Du müsstest versuchen das Problem einzugrenzen, achte z.B. mal darauf welche Arten von Nummern Probleme haben (Welcher Provider, Festnetz oder Mobile, Spezialnummern 058,08xx,09xx).

Oft liegt das Problem am Uebergang von einem Netz ins andere.

 

Benutzt du die FB als Router oder hinter einem Swisscom-Router?

Und was für Telefone benutzt du an der FB?

 

Evtl. kannst Du mal einen zweiten Client konfigurieren (zB. auf dem Natel) und schauen, ob es sich gleich verhält.

 

Gruss

 

NotNormal

 

Contributor
3 von 20
Vielen Dank für die Mitteilung. Meine Fritzbox 7490 hängt an einem
Kabelmodem von UPC (Ethernet-Schnittstelle). Ich habe auf der Fritbox
noch andere IP-Nummern eingerichtet (sipcall, JustvOiP), die alle ohne
Problemen funktionieren.
Ich benutze von der 7490 nur die ISDC-Schnittstelle, an welcher eine
Teilnehmervermittlungsanlage (Casatel 20) hängt.
Expert
4 von 20

@NotNormal schrieb:

Einseitiges Audio ist so etwa das häufigste Problem bei VOIP... leider

 


 

Hmm, ich mache ja nun schon eine Weile VoIP (gut 10 Jahre) und das Problem "einseitiges Audio" kannte ich bisher eigentlich einzig von einem bestimmten kleinen Anbieter mit notorisch schlecht gewarteter VoIP-Infrastruktur der (zur allseitigen Erleichterung) bereits vor fünf Jahren dicht gemacht hat. Seither hatte ich zum Glück nie mehr mit derartigen Problemen zu kämpfen.

 

Deine Tipps zur Eingrenzung sind prinzipiell gut. Tatsächlich sind bei den "klassischen" SIP-Providern (à la sipcall) ja oft die Transports in andere Netze der grösste Schwachpunkt (wobei wie gesagt eigentlich seit vielen Jahren alles problemnlos läuft). Wobei man eigentlich meinen müsste, dass das bei der Swisscom kein Problem sein sollte.

Da der TE ja zudem bereits über VoIP-Erfahrung zu verfügen scheint und andere Anbieter am Start hat, die problemlos laufen, würde ich den "Netzübergang" jetzt nicht als Hauptverdächtigen vermuten und auch die Leitung & der Router sollten i.O. sein.

Da der SIP-Client im Router integriert ist, sollten sich auch keine Portweiterleitungsfragen etc. stellen.

D.h. die klassischen "Stolpersteine" sind hier eigentlich bereits abgedeckt.

Editiert
Novice
5 von 20

Ich habe dasselbe Problem, sipcall funktioniert, bei swisscom funktioniert oft nur ein Weg dh der andere hört mich sprechen und ich höre nichts oder umgekehrt.

Das passiert wenn ich anrufe oder angerufen werde.

im Log sieht man das dann auch sehr gut ( keine Daten auf einem Kanal.

 

bei mir tritt dies auf seit ich den proxy konfigurieren musste

weil es sonst gar nicht mehr ging vor 2 Wochen.

 

an der Infra habe ich nichts geändert, Swisscom und Cablecom hängen an einer Firewall, die Sipbox im Lan der Firewall (Sophos Appliance)

 

wie gesagt mit sipcall klappts

 

nachtrag: mit bc1 klappt es mittlerweile bestens

Editiert
Contributor
6 von 20
Vielen Dank für Deinen Beitrag. Gelöst habe ich das Problem allerdings
nicht.

Es ist schon seltsam, dass das Problem mit der einseitigen Audio nur mit
der Swisscom Nummer auftritt. Mit allen anderen Service
Providern (SIPCall, VoIPBuster, EasyVoIP, JustVoIP, Green) auf derselben
Infrastruktur ist da Problem nie aufgetreten. Die einseitige
Audio tritt übrigens nicht immer auf (so etwa bei jedem dritten Anruf).

Als Notlösung betreibe ich nun die Swisscom Internet Box light parallel
zur Fritzbox 7490. Ich speise das analoge (a/b)-Signal aus
der Swisscom Internet Box in die Fritzbox als 'Standardanbieter' ein. An
der So-Schnittstelle der Fritzbox hängt meine
Nebenstellenanlage Casatel 20. So funktioniert es an sich einwandfrei.
Unschön ist nur, dass ich die internet Box der Swisscom
als zusätzlichen Stromfresser betreiben muss.

Eigenartig ist nur, dass das Audio-Problem nur bei Swisscom auftritt.
Swisscom hatte sich sehr dagegen gewehrt, die SIP Credentials
freizugeben, wurde aber dazu gezwungen. Der Weg zu den Credentials
gleicht einem Hürdenlauf. Ich werde dem Bauchgefühl nicht los,
dass Swisscom möglicherweise irgendwo etwas eingebaut hat, damit die
IP-Telefonie auf Fremdroutern trotz freigegebenen Credentals nicht
richtig funktioniert. Wäre dem so,
so wäre dies sehr dumm von Swisscom, denn frustrierte Benutzer werden
sich früher oder später von Swisscom abwenden, ihre Rufnummer zu einem
anderen SIP-
Anbieter portieren, von diesem die Credentials ohne Probleme erhalten
und auf vorhandenen Routern programmieren. Das Resultat wäre
eine gut funktionierende SIP-Telefonie ohne Audio-Probleme vermutlich
erst noch zu einem günstigeren Preis. Die Swisscom würde damit Kunden
verlieren, was
sicher nicht in ihrem Sinn wäre.
Super User
7 von 20

@funke44 schrieb:
.....Ich werde dem Bauchgefühl nicht los,
dass Swisscom möglicherweise irgendwo etwas eingebaut hat, damit die
IP-Telefonie auf Fremdroutern trotz freigegebenen Credentals nicht
richtig funktioniert.....

Wenn dem so wäre wäre hier viel mehr los bezüglich dieser Problematik - wenn nicht sogar ein richtiger Shtstorm...

 

Ich nutze auch die offiziellen SIP-Credentials, aber nicht mit einer FB, sondern mit diversen SIP-Softphone Apps. Hatte am Anfang das Problem auch mit teilweisem, einseitigen Audio, teilweise noch abhängig, ob das Smartphone WLAN oder Mobile Verbindung hatte und bin auf keine grünen Zweig gekommen.

 

Irgendwann hab ich mir meine SIP-Credentianl nochmals senden lassen (dabei wurde ein anderes Passwort generiert), seither läuft die SIP-Telefonie mit meinen Apps absolut problemlos. Audio immer in beide Richtungen und egal ob WLAN oder 3G/4G Verbindung.....0 Problemo

keep on rockin'
Expert
8 von 20

@funke44 schrieb:
Ich werde dem Bauchgefühl nicht los,
dass Swisscom möglicherweise irgendwo etwas eingebaut hat, damit die
IP-Telefonie auf Fremdroutern trotz freigegebenen Credentals nicht
richtig funktioniert.

 

Nicht völlig undenkbar. Es gibt aber auch einen anderen plausiblen alternativen Erklärungsansatz:

 

Andere SIP-Anbieter legen seit jeher viel Wert darauf, dass ihr Angebot standardkonform und kompatibel ist, denn es ist bei ihnen ja schon seit jeher so, dass ihr Angebot mit ganz verschiedenen Endgeräten (SIP-Clients) genutzt wird.
Die Swisscom hingegen hatte bis vor ein paar Wochen eine Infrastruktur, in welcher nur ihre eigenen Endgeräte vorkamen. D.h. es musste nicht standardkonform und/oder möglichst kompatibel sein, es musste einfach mit einer kleinen Handvoll Swisscom-Router funktionieren. Deswegen sind u.U. eben nicht so viele Gedanken in die Kompatibilität geflossen.

Editiert
Contributor
9 von 20
Vielen Dank für den Beitrag. Deine Ansicht scheint mir plausibel. Es
scheint, dass Swisscom das Schwergewicht auf Sicherheit legt, andere
VoIP-Anbieter eher auf Kompatibilität.

Ich habe inzwischen die Credentials nochmals heruntergeladen und das
Passwort geändert. Gebracht hat es nichts; etwa bei jeder 2. Verbindung
fehlt ein Sprechweg, auch bei ankommenden Verbindungen. So ist
VoIP-Telefonie mit Fremdrouter unbrauchbar.

Ich habe inwischen eine 'work around' Lösung gefunden, mit welcher ich
leben kann. Ich betreibe die Swisscom Internet Box light parallel
zur Fritzbox 7490 und speise das analoge a/b Signal aus der Internet Box
in die Fritzbox ein. So habe ich keine Probleme mit einseitigem Sprechweg.
Die Internet Box light scheint sich die Swisscom SIP Credentials selber
zu holen, jedenfalls war sie nach dem geänderten SIP Passwort nach einiger
Zeit wieder am Netz, ohne dass ich in sie eingreifen musste.

Dass Swisscom nur eine Handvoll ausgesuchter Router unterstützt, kann
ich nachvollziehen. Anderseits ist die Fritzbox 7490 keineswegs ein
exotischer Router
und ich denke, dass viele diese benützen. Daher würde es mich
interessieren, ob dasselbe Problem bei ihnen auch auftritt. Auch
positive Rückmeldungen
(keineProbleme mit Swisscom Credentials) würden mich interessieren.

Fazit: Problem nicht gelöst, aber mit 'work around' Lösung lässt es sich
zur Not leben.
Novice
10 von 20

Habe genau das selbe Problem.

Normalerweise wenn ich aufhänge und direkt anschliessend wieder telefoniere, funktioniert Audio in beide Richtungen.

Ist es möglich, dass doch ein STUN-Server angegeben werden muss?

 

wie sind die Einstellungen unter "weitere Einstellungen"?

 

Weitere Einstellungen

DTMF-ÜbertragungAutomatischINFO, RTP oder InbandRTP oder InbandInband
Rufnummernunterdrückung (CLIR)DeaktiviertCLIR über DisplaynamenCLIR über Display- und UsernamenCLIR über *31CLIR über *31*CLIR über RFC 3323 (Header)CLIR über RFC 3325 (Id)CLIR über RFC 3323 (Id)CLIR über *67*
RufnummerübermittlungDeaktiviertRufnummer im DisplaynamenRufnummer im UsernamenRufnummer im Display- und UsernamenRufnummer in "P-Preferred-Identity"
Rufnummer für die Anmeldung verwenden
Anbieter unterstützt Rückruf bei Besetzt (CCBS) nach RFC 4235
Paketgröße in Millisekunden in Senderichtung2030
Anmeldung immer über eine Internetverbindung
Falls Ihr Internetanbieter die separate Internettelefonie-Verbindung für eigene Rufnummern reserviert, aktivieren Sie diese Option, wenn es sich um eine Rufnummer eines anderen Anbieters handelt.
Der Anbieter unterstützt MWI (RFC 3842)
Der Anbieter unterstützt kein REGISTER-fetch
 
Danke und Gruss:
ColossusCH
Super User hed
Super User
11 von 20

Paketgröße in Millisekunden in Senderichtung2030 -->

 

Das ist sicher falsch, denn üblicherweise sind es 20ms und nicht 2030ms

Expert
12 von 20

@Colossus schrieb:

Habe genau das selbe Problem.

Normalerweise wenn ich aufhänge und direkt anschliessend wieder telefoniere, funktioniert Audio in beide Richtungen.

 

 

Hallo @Colossus und @funke44

 

Habt ihr das Problem mitlerweile lösen können? Ich bin nach dem Gebrauch der internen Credentials der IBS nun auch auf die Daten der Swisscom umgestiegen. Die IBS ist erst einmal noch in Betrieb. Die ähnlich gelagerten Hinweise in diesem Forum hab ich versucht umzusetzen...

 

Mein Setting ist also das Folgende:

IBS
  (192.168.1.0/24)
Fritzbox 7490 (Router, DHCP, WLAN-AP, DECT Basis)
  (10.0.0.0/16)
Fritzbox 7490 und 7390 (WLAN-AP, DECT Basis)

Dabei funktioniert die Fritzbox, welche als Router fungiert tadellos. VoIP Calls werden korrekt signalisiert und durchgeschaltet. Die 'hintern' beiden Fritzboxen bekommen den Rx Kanal (Nomenklatur der FB) nicht aufgeschaltet. In den FB Logs sehe ich, dass im gut Fall: Rx: G.722-HD aktiv ist und im schlechen Fall nur gerade Rx: (kein Codec angegeben) steht.

Ich hab die Frage auch an den AVM Support eskaliert, mal sehen ob die zusätzlich was wissen.

Den Tip von dir @POGO 1104 hab ich gestern auch schon einmal mit dem gleichen Ergebins erfolglos abgeschlossen. Hast du die Soft-Phones jemals hinter einer FB 7490 betrieben? Oder nur hinter den IBx-en?

Was mich besonders interessieren würde, sind die FB Settings, wie sie von @Colossus angefragt worden sind. Insbesondere die neuen, welche mit der letzten FB Firmware dazu gekommen sind.

Hat jemand einen Verdacht, ob das Problem bei der vordern Router-Fritzbox oder bei den nachgeschalteten Access-Point Boxen entsteht? Weil ich bei beiden 7490ern die identischen VoIP Settings verwendet habe, denke ich eher an ein Netzwerk Setting der vorderen Router-FB.

@Tux0ne: Hast du eine Idee?

Danke allen für die sachdienlichen Hinweise!

:smileysad:

 

Editiert
Contributor
13 von 20

Hallo @andiroid,

ich konnte das Problem mit der einseitigen Kommunikation lösen, indem ich den proxy-server umgestellt habe auf:

 

bc1.ims.swisscom.ch

 

Viel Glück

Editiert
Contributor
14 von 20

Heureka! Mit dem Outbound Proxy Server bc1.ims.swisscom.ch klappt es endlich. Immer beide Sprechwege vorhanden!

 

Herzlichen Dank, Colossus CH für den Hinweis.

 

Scheint sich zu bestätigen, was ich vermutet habe, nämlich dass das Problem bei Swisscom liegt und dass der in den Credenials angegebene Outbound Proxy Server fs1.ims.swisscom.ch faul ist. Swisscom täte gut daran, diesen Server in Ordnung zu bringen oder ganz zu löschen und in den credentials den Server bc1.ims.swisscom.ch anzugeben!

 

Für mich ist das Problem jedenfalls gelöst!

Swisscom
15 von 20

Ich habe es an die Kollegen von der Technik weitergegeben. Das sollte nicht sein. Falls da ein Problem besteht werden wir es finden und korrigieren. 

Head of Access & Communication Services @ Product & Marketing Department, Swisscom (Schweiz) AG
Expert
16 von 20

Danke @GuidoT fürs Weiterleiten. Ich bin der Meinung, dass der Work-around mit den Proxy-Servern bei mir mit beiden Einstellungen (fs1.ims.swisscom.ch und bc1.ims.swisscom.ch) versucht und jeweils bei beiden (zu unterschiedlichen Zeitpunkten) keine G722-HD Verbindung von Telefoniegeräten hinter dem Router bekommen. Die Router-Log-Einträge sind hier eindeutig und belegen die Beobachtungen bei den Verbindungs-Versuchen.

Ich kann mir sehr wohl vorstellen, dass das Problem ursächlich

  • an den Router Einstellungen (in meinem Fall eine FritzBox),
  • an den Einstellungen der Telefonie-Geräte "hinter" dem Router
  • oder aber am Proxy / am Swisscom Netz liegt.

Weshalb? Zuerst hat BC1 nicht funktioniert, später habe ich es mit "eure" Einstellungen (FS1) versucht und es hat plötzlich funktioniert - aber nur eine Zeit lang. Aber nur wiederum am "anderen" Endgerät. Weiter ist meine Beobachtung, dass bei mehreren Endgeräten hinter dem Router nur diejenigen am Router und von einem Endgerät hinter dem Router funktioniert hat.

Sag Bescheid, wenn ich dir meine Kontakt-Daten schicken soll. Ich helf gerne, wenn es darum geht Instabilitäten im Netz zu beheben.

:smileywink:

Contributor
17 von 20

Wenn ich von fs1.ims.swisscom.ch zu bc1.ims.swisscom.ch ändere, bekomme ich die 

Meldung: Forbidden.  

 

Bei mir hat der Sprechweg noch gar nie funktioniert. 

Ich habe aber nur etwa 4 Versuche unternommen und dann aufgegeben.

 

Contributor
18 von 20
Bei mir hat der Wechsel von fs1.ims.swisscom.ch auf bc1.ims.swisscom.ch problemlos geklappt. Eine Fehlermeldung erhielt ich nicht. Seit dem Wechsel hatte ich nie wieder Probleme mit einseitigen Sprechwegen.

Von meinem Samsung Galaxy Smartphone gesendet.
Highlighted
Contributor
19 von 20


 Kein (oder einseitiges)  Audio mit Swisscom SIP Credentials

Zur Info an:  @funke44  @andiroid   @ColossusCH    @GuidoT

 

Vorgeschichte
=============

Am 05.09.2017 9:01  hat    Colossus  an   andiroid  geschrieben, dass er mit
Umstellung des proxy-server auf bc1.ims.swisscom.ch das Problem lösen konnte.

 

Am 06.09.2017 12:48  hat    funke44 geschrieben:
Heureka! Mit dem Outbound Proxy Server bc1.ims.swisscom.ch klappt es endlich.
Immer beide Sprechwege vorhanden!

 

Ich habe am 11.10.2017 15:14  geschrieben:
Wenn ich von fs1.ims.swisscom.ch zu bc1.ims.swisscom.ch ändere, bekomme ich die
Meldung: Forbidden.

 

Am 12.10.2017 12:26  hat   funke44 geantwortet:
Bei mir hat der Wechsel von fs1.ims.swisscom.ch auf bc1.ims.swisscom.ch
problemlos geklappt. Eine Fehlermeldung erhielt ich nicht. Seit dem Wechsel
hatte ich nie wieder Probleme mit einseitigen Sprechwegen.

 

Augrund der Antwort von funke44 habe ich die Umstellung von
fs1.ims.swisscom.ch auf bc1.ims.swisscom.ch
am 12.10.2017 nochmals versucht. Mit dieser Einstellung endet die Registration
jedoch wie gehabt mit der Fehlermeldung "Forbidden (403)".


Meine Konfiguration
===================
Hardware und OS:
Altes iPad 2 (second hand) mit iOS 9.3.5  (kann nicht weiter aktualisiert werden).
Software / App:
Zoiper SIP softphone Version 3.14 für iPhone
(Kompatibilität iOS 5.1.1 oder neuer, iPhone, iPad und iPod touch.)
Verbindung / Netzwerk:
Nur WLAN keine 3G/4G Verbindung  (kein Mobile Abo vorhanden).
Problem:
Keine Audio Verbindung (auch nicht einseitig). Registrierung und Anruf-Signalisation OK.

 

Meine Lösung
============
Bei meiner weiteren Suche im Internet bin ich auf der Seite
https://www.zoiper.com/en/support/answer/for/android/11/SIP_-_No_audio_or_one_way_audio
auf den folgenden Rat gestossen:
Try enabling or disabling RPORT for signalling, save the changes and try to make a call.

 

In meiner Konfiguration habe ich gefunden:
Unter  Settings->Accounts->"MyAccount"->Network Settings->rport
war    "signaling"   ausgewählt.
Ich habe das geändert auf  "signaling & media"

Und nun endlich auch bei mir: Heureka, es funktioniert! Ich habe Sprechverbindung
in beide Richtungen.

 

Obwohl der Hinweis eigentlich für ANDROID ist, hat es auch mich zu einer
funktionierenden Lösung geführt. Wenn evtl. auch ein anderer Nutzer,
dank diesem Hinweis zu einer funktionierenden SIP App kommt, würde mich
das freuen.

Danke an alle!

 

 

 

Editiert
Super User
20 von 20

@ursepp

 

Die Standard-Installations-Einstellungen von Zoiper auf iPad sind meistens falsch, was dann zu den Ton-Problemen führt, d.h. meistens gar kein Ton.

 

Bei mir warens die Audio-Einstellungen, bei welchen die Parameter, noise-suppression und echo-cancellation auf den Wert „Software“ eingestellt werden mussten.

War aber schon vor ca. 2 Jahren, seit da läuft Zoiper bei mir auf verschiedenen iPads und iPhones (von unterwegs dann via VPN-Verbindung) problemlos mit den internen SIP-Credentials der Internetboxen

Selbstdeklaration: Emanzipierter Kunde und Hobby-Nerd ohne wirtschaftliche Abhängigkeiten zur Swisscom
Editiert