abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 
Gelöst
  • Der Fragesteller hat diesen Beitrag als gelöst markiert.

Internet - Box lokale SIP credentials

Contributor
1 von 16

Ich habe die App Linphone erfolgreich mit den lokalen SIP Credentials an der
Internet-Box registriert. Ich kann damit aber nur auf die lokalen dreistelligen
Nummern verbinden. Wenn ich eine Nationale Nummer eingebe geht es nicht.
Frage: Sind dafür unbedingt die "normalen" SIP Credentials nötig?
Im Internet steht, mit den lokalen SIP Credentials sei die App wie ein
anderes Telefon das an der Internet-Box angeschlossen ist.

HILFREICHSTE ANTWORT

Akzeptierte Lösungen
Contributor
9 von 16


Zu meinem Problem gibt es nun einige gute, aber auch schlechte Nachrichten.

 

Positiv: Es haben @POGO 1104@Tux0ne und @PoPo einen Beitrag reingestellt
         und dafür danke ich sehr.

Negativ: Keiner dieser Beiträge hat direkt zu einer Lösung geführt.

Positiv: Diese Beiträge, speziell der von @PoPo hat mich motiviert zum dran bleiben.

Negativ: Nach einem Versuch in den Einstellungen etwas zu verändern, bin ich immer
         aus der App rausgeflogen, wenn ich wieder die Einstellungen angewählt habe.
         Das heisst die Anzeige hat zum Home Screen gewechselt.

Negativ: Ich hatte während der ganzen Zeit das alte Prinzip "reboot tut immer gut"
         vernachlässigt.

Positiv: Nun war ich also gezwungen die App ganz rauszuschmeissen und dann neu zu
         installieren. (Reboot des iOS habe ich nicht gemacht)

Positiv: Nach den Neuinstallation konnte ich die App wieder normal bedienen und
         ein neues SIP Konto anlegen.

Negativ: Nach dem Anlegen des neuen Konto hat sich die App nicht mit der
         Internet-Box verbunden.

Positiv: Aufgrund meiner bisherigen Experimenten wusste ich was zu tun ist:
         1. "Weitere Optionen" einschalten.
         2. Unter "Benutzerkennung" den Namen eintragen der in der Internet-Box
            als "Anmeldename" definiert ist.

Positiv: Nun hat sich die App wieder mit der Box "vertragen" und die App in den
         Status "Registriert" versetzt. In der Box ist das der Status
         "Telefon angemeldet. Alles war wieder so eingestellt wie in den
         Screenshot im Beitrag vom 23.06.2017 12:26 zu sehen ist.

Positiv: Ich kann wieder Verbindungen zu den Lokalen Apparaten aufnehmen.
         Und, Heureka! auch mit Verbindungen nach und von aussen klappt es nun.

Negativ: Die Verbindungen halten nur kurze Zeit und werden dann spontan beendet.
         Die Sprachkanäle sind nicht durchgeschaltet.

Negativ: Ich habe mich nicht direkt zum WLAN der Internet-Box verbunden, weil ich
         im Normalfall über einen nachgeschalteten WLAN Router gehe.

Positiv: Nachdem ich direkt auf das WLAN der Internet-Box verbunden habe, klappt
         es auch mit der Sprechverbindung zum anderen Teilnehmer. Die spontenen
         Abbrüche bleiben aus.

Negativ: Das ganze funktioniert nur, wenn die App aktiv ist. Wenn eine andere
         App offen ist oder im Standby gibt's keine Benachrichtigung wenn ein
         Anruf reinkommt.

Positiv: Aber für mich funktioniert das Ganze nun wie erwartet und das Experiment
         ist gelungen. Ich kann das also "Als Lösung akzeptieren".

 

15 Kommentare
Super User
2 von 16

Mit den lokalen Sip Daten kann man problemlos auch extern telefonieren.

 


Gibts du denn die Nummer auch im internationalen Format ein?

Also z.B. +4161........, auch wenn du eine Schweizer Nummer wählst!

keep on rockin'
Contributor
3 von 16

Egal wie ich die Nummer eingebe, es kommt immer die Antwort:

Authentifizierung erforderlich. Registrierung fehlgeschlagen, da die

Authentifizierung fehlt oder ungültig ist für 228@Home.

 

Dabei ist 228 der Benutzername der offenbar für die internen

Verbindungen ok. ist. Aber woher das "@Home" kommt ist mir

nicht klar. Uebrigens schmeisst die App auch immer wieder die Eingabe

unter Proxy raus. Gemäss Angaben von Swisscom müsste auch dort

192.168.1.1 stehen. Aber lokal geht es auch ohne.

Contributor
4 von 16

Lässt sich evtl. auch @Tux0ne mit dieser Frage "erschrecken" ?

Super User
5 von 16

@ursepp schrieb:

Lässt sich evtl. auch @Tux0ne mit dieser Frage "erschrecken" ?


Erschrecken tut mich da gar nichts. Eventuell wecken, aber im Bezug auf Internet Box Wursteleien ja eigentlich nicht mal das 🙂 Und nein, interessieren liegt auch noch weit weg.

 

Ausgehenden Proxy verwenden aktivieren. Falls das nicht funktioniert. Screenshot der Einstellungen reinstellen, dann kann man schauen was allenfalls falsch konfiguriert wäre.

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Contributor
6 von 16

Dass etwas falsch konfiguriert ist, glaube ich nicht. Das heisst, es ist höchstens ein Problem,

dass der Eintrag für den Proxy jeweils rausfliegt.

 

Ich sehe das Problem darin, dass von der Internet-Box eine Autentifizierung für

"228@Home" verlangt wird. Mein Benutzername ist jedoch nur "228" und dafür ist

das richtige Passwort gesetzt. Das zeigt sich ja auch darin, dass die lokalen

Verbindungen funktionieren.

 

Ich glaube wenn nicht jemand ( incl. @Tux0ne oder @POGO 1104 ) selbst Erfahrung mit

dieser Kombination :  Linphone mit lokalen SIP Credentials an der Internet-Box

hat, dann bringt es nichts. Ich werde wohl bald den Versuch abbrechen und die

App wieder löschen.

 

Contributor
7 von 16

Wieso stellst du kein Screenshot mit den Einstellungen rein?

 

linphone.png

Mit diesen Einstellungen funkioniert es bei mir.

Contributor
8 von 16

Ja gut, dann versuche ich mal, ob ich die Bilder hier rein kriege:

 

BoxSIPconfig.JPGIMG_0017.PNG

Contributor
9 von 16


Zu meinem Problem gibt es nun einige gute, aber auch schlechte Nachrichten.

 

Positiv: Es haben @POGO 1104@Tux0ne und @PoPo einen Beitrag reingestellt
         und dafür danke ich sehr.

Negativ: Keiner dieser Beiträge hat direkt zu einer Lösung geführt.

Positiv: Diese Beiträge, speziell der von @PoPo hat mich motiviert zum dran bleiben.

Negativ: Nach einem Versuch in den Einstellungen etwas zu verändern, bin ich immer
         aus der App rausgeflogen, wenn ich wieder die Einstellungen angewählt habe.
         Das heisst die Anzeige hat zum Home Screen gewechselt.

Negativ: Ich hatte während der ganzen Zeit das alte Prinzip "reboot tut immer gut"
         vernachlässigt.

Positiv: Nun war ich also gezwungen die App ganz rauszuschmeissen und dann neu zu
         installieren. (Reboot des iOS habe ich nicht gemacht)

Positiv: Nach den Neuinstallation konnte ich die App wieder normal bedienen und
         ein neues SIP Konto anlegen.

Negativ: Nach dem Anlegen des neuen Konto hat sich die App nicht mit der
         Internet-Box verbunden.

Positiv: Aufgrund meiner bisherigen Experimenten wusste ich was zu tun ist:
         1. "Weitere Optionen" einschalten.
         2. Unter "Benutzerkennung" den Namen eintragen der in der Internet-Box
            als "Anmeldename" definiert ist.

Positiv: Nun hat sich die App wieder mit der Box "vertragen" und die App in den
         Status "Registriert" versetzt. In der Box ist das der Status
         "Telefon angemeldet. Alles war wieder so eingestellt wie in den
         Screenshot im Beitrag vom 23.06.2017 12:26 zu sehen ist.

Positiv: Ich kann wieder Verbindungen zu den Lokalen Apparaten aufnehmen.
         Und, Heureka! auch mit Verbindungen nach und von aussen klappt es nun.

Negativ: Die Verbindungen halten nur kurze Zeit und werden dann spontan beendet.
         Die Sprachkanäle sind nicht durchgeschaltet.

Negativ: Ich habe mich nicht direkt zum WLAN der Internet-Box verbunden, weil ich
         im Normalfall über einen nachgeschalteten WLAN Router gehe.

Positiv: Nachdem ich direkt auf das WLAN der Internet-Box verbunden habe, klappt
         es auch mit der Sprechverbindung zum anderen Teilnehmer. Die spontenen
         Abbrüche bleiben aus.

Negativ: Das ganze funktioniert nur, wenn die App aktiv ist. Wenn eine andere
         App offen ist oder im Standby gibt's keine Benachrichtigung wenn ein
         Anruf reinkommt.

Positiv: Aber für mich funktioniert das Ganze nun wie erwartet und das Experiment
         ist gelungen. Ich kann das also "Als Lösung akzeptieren".

 

Super User
10 von 16

@ursepp

 

Die App Linphone kenne ich nicht, aber wenn Du das mit der App Zoiper hinter einem nachgeschalteten Router (anderes Subnetz) oder via eine VPN-Verbindung machen möchtest, ist folgendes relevant:

 

Wichtig ist bei den Zoiper-Einstellungen auf dem iPhone oder iPad den Outbound-Proxy von Zoiper auf die IB2 auszurichten, also 192.168.1.1:5060 als Zieladresse einzutragen und natürlich die korrekten internen SIP-Daten der IB2 in der Konfiguration zu hinterlegen.

 

Falls Du dich nicht direkt im Netz der IB2 befindest, brauchst Du ein detaillierte Adressierung auf den SIP-Gateway der IB2, d.h. IP-Adresse und Port-Angabe, sonst kann Dein SIP-Phone die "Telefonverbindung" einfach nicht finden.

Selbstdeklaration: Emanzipierter Kunde und Hobby-Nerd ohne wirtschaftliche Abhängigkeiten zur Swisscom
Contributor
11 von 16


@Werner

Vielen Dank für deinen Hinweis. Also ich habe zwar nicht die
IB2, sondern die flache Internet-Box die man legen kann. Aber
ich habe sie an die Wand hoch gehängt, damit sich WLAN besser
ausbreiten kann. Ich denke jedoch dass das für diesen Fall
keine Rolle spielt.

Die Einstellungen welche Du für Zoiper angibst, habe ich auch
für Linphone so gesetzt, wie man aus den Screenshots sieht.
Trotzdem habe ich über den nachgeschalteten Router keine
Sprachverbindung. Es läutet zwar am anderen Ende und wenn
man abnimmt besteht diese Verbindung nur für kurze Zeit.
Dann bricht die Verbindung wieder ab. Auch während der kurzen
Zeit wird keine Sprache übermittelt.

Das heisst doch, dass die Internet-Box die "Telefonverbindung"
schon findet. Ich denke da müssten wohl im nachgeschalteten
Router noch irgendwelche Türen geöffnet werden.

Highlighted
Contributor
12 von 16


@Werner

 

Sorry, die Einstellung Port: 5060 sieht man gar nicht auf dem Screenshot. Diese Einstellung

ist in den Einstellungen für das Netzwerk.

Aber noch etwas anderes. Unter Audioport(s) ist "7200-7299" eingestellt. Direkt an der

Internet-Box funktioniert damit alles. Kannst Du dazu etwas aussagen?

 

Danke ursepp

 

Super User
13 von 16

@ursepp

 

Bei Zoiper unter IOS gibt es keinen Audio Port, kann ich also nichts dazu sagen.

Wichtig sind bei Verwendung eines eigenen Subnetzes m.E. nur der Outbound-Proxy und grundsätzlich (egal wie Du Dich einloggst) die Audioeinstellungen der SIP-App.

 

Bei Zoiper hatte ich zu Beginn auch Audio Probleme, lag aber nur an den Zoiper internen Audioeinstellungen.

Nachdem ich Noise cancellation, Audio Gain, etc. auf den Parameter "Software" gestellt hatte, lief aber alles problemlos.

 

Dass Du am nachgeschalteten Router für die SIP-App noch etwas "öffnen" müsstest, glaube ich nicht.

Hätte in jedem Fall keine Ahnung, was das den sein sollte.

Selbstdeklaration: Emanzipierter Kunde und Hobby-Nerd ohne wirtschaftliche Abhängigkeiten zur Swisscom
Contributor
14 von 16

@PoPo


Ich habe Linphone auf dem iPad installiert. Dieses Gerät ist
ja eigentlich nicht zum telefonieren konzipiert.

 

Ich nehme an, dass Du Linphone auf einem Smartphone installiert
hast. Darum wollte ich fragen, ob sich Linphone meldet, wenn die
App im Hintergrund ist, oder das Gerät im Standby ist?

 

Im iPad muss die App aktiv offen sein, damit der Klingelton
durchkommt.

 

Danke und freundliche Grüsse
Ursepp

 

Contributor
15 von 16

@ursepp

 

Nein habe ich nicht, aber bei Android kann eine App problemos in Hintergrund funktionieren, sofern sie nicht von der Stromspaarfunktion pausiert wird. Dies kann man jedoch einstellen.

 

Ich verwende Linphone auf Windows (Desktop). Sieht inzwischen auch wieder ganz anders aus.

 

Bei IOS kann ich dir nicht weiterhelfen.

Super User
16 von 16

@ursepp

 

Damit das mit den eingehenden Anrufen jederzeit klappt, brauchst Du eine stehende WLAN-Verbindung und eine (zumindest im Hintergrund) zuhörende App.

 

Bei Zoiper unter IOS sind das die Einstellungen für "incoming calls".

Die Parameter heissen: Keep WiFi alive und Force Background

 

Beides steigert allerdings den Stromverbrauch.

Falls das iPad häufig am Kabel hängt, ev. aber kein Problem. 

Selbstdeklaration: Emanzipierter Kunde und Hobby-Nerd ohne wirtschaftliche Abhängigkeiten zur Swisscom
Nach oben