cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED
  • The questioner has marked this post as solved.

Headset microphone not working with Business Communication

Highlighted
1 of 4

The microphone of my headset does not work when placing calls, or picking up calls, using Business Communication. I have the latest version 22.9.14 if that matters. I can hear the other person, but they cannot hear me.

 

It is not a problem with the microphone itself, as I am also using Skype, Teams or GoToMeeting for example without any issues, other people can hear me.

 

I have compared my settings, in both Business Communication and the computer's Control Panel, with those of my colleagues and cannot find anything different or that would cause an issue.

1 ACCEPTED SOLUTION 1

Accepted Solutions
Highlighted
3 of 4

Hello, thanks for your answer. I had already tried this, but it didn't work.

Now I am using another headset and this time the microphone works, but I have not changed any other settings in the application.

Highlighted
Swisscom
4 of 4

Great to hear that it now works. Could you please contact us at business.communication@swisscom.com so we can solve the problem with the other headset? You may be using a headset that is not certified to control calls in the Business Communication App.

I look forward to hearing from you.

 

Kind regards,
Maximilian

3 Comments 3
Highlighted
Swisscom
2 of 4

Hello,

Thank you for contacting us. Gladly I will try to help you further.

As a first attempt at a solution, I would ask you to check the following settings.

 

1) Navigate within your Business Communication App to the upper menu bar. There, select the menu item "Calls", then "Audio Device" and choose "Headset".

 

anrufeinstellungen.png

 

 

2) Please select the settings menu in the left menu bar. There you navigate to the menu "Audio/Video". Please select as Output and Input Device the headset you want to use for your calls. It is important to select the device explicitly and not the setting "Use Default". 

 

Audio einstellungen.png

 

Hope this helps.  If this does not solve the problem, you are welcome to contact us again.

 

Best wishes
Maximilian

Highlighted
3 of 4

Hello, thanks for your answer. I had already tried this, but it didn't work.

Now I am using another headset and this time the microphone works, but I have not changed any other settings in the application.

Highlighted
Swisscom
4 of 4

Great to hear that it now works. Could you please contact us at business.communication@swisscom.com so we can solve the problem with the other headset? You may be using a headset that is not certified to control calls in the Business Communication App.

I look forward to hearing from you.

 

Kind regards,
Maximilian

Back to top