cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED
  • The questioner has marked this post as solved.

Access LAN from Wifi to wired computer

Contributor
1 of 4

Hello.

 

Here is the background.

 

Swisscom Centro Business connected, with fixed IP.

One NAS wired to the centro Business with IP 192.168.1.6

One computer, used as server, wired to the Centro Business with IP 192.168.1.32

 

I configured the port forwarding, ports 22 / 80  443, from Centro Business to server IP 192.168.1.32

 

When I try to connect from "Internet" (with 4G mobile phone or other connection point as free wifi), I am correctly redirect to the server.

When it is wired to the Centro Business with a computer, I can access to the server directly with the IP (192.168.1.32) or by the public IP, because of the port forwarding.

 

BUT, when the computer is connected to the Centro Business throw WIFI, it can connect directly to the server by its IP (192.168.1.32) but not from the public IP.

I try many many things, because there is many topics with similar difficulty, and my only conclusion is that we can not access a machine, with the port forwarding, by the public IP and when connected with WIFI.

 

Does someone have this issue and manage to fix that ?

 

Thanks

 

Etienne

MOST HELPFUL ANSWER

Accepted Solutions
Contributor
3 of 4

Hello.

 

Finally I found a solution.

First, my objective was to have access to my website, server plug to box by cable, when connected by WIFI behind the Centro Business.

 

So It means that I have a server with Apache installed.

 

Because it seems that the NAT-Loopback is disabled on the Centro Business, I can not access the server throw the public IP nore the domain name.

 

So on the installed server, with Ubuntu OS, I installed bind9.

Then I configured bind9 in order to map the domain name to the internal IP of the server, something like 192.168.1.X

On bud9, I also allowed the query for only internal IP 192.168.1.0/24, so that the routeur can make request on it.

 

And finally on the routeur, I changed DNS definition. The primary DNS is the IP of the internal server, where I installed bind9.

 

Like this, I can request the server by its domain name anywhere from my Home, connected by WIFI or cable.

 

Etienne

3 Comments
Community Manager
2 of 4

Hello @Etienne Jouvin 

 

Did you find a solution to your issue ?

Un like fait toujours plaisir ;) Une réponse t'a aidé? -> ✅ Accepte-la comme solution!
Contributor
3 of 4

Hello.

 

Finally I found a solution.

First, my objective was to have access to my website, server plug to box by cable, when connected by WIFI behind the Centro Business.

 

So It means that I have a server with Apache installed.

 

Because it seems that the NAT-Loopback is disabled on the Centro Business, I can not access the server throw the public IP nore the domain name.

 

So on the installed server, with Ubuntu OS, I installed bind9.

Then I configured bind9 in order to map the domain name to the internal IP of the server, something like 192.168.1.X

On bud9, I also allowed the query for only internal IP 192.168.1.0/24, so that the routeur can make request on it.

 

And finally on the routeur, I changed DNS definition. The primary DNS is the IP of the internal server, where I installed bind9.

 

Like this, I can request the server by its domain name anywhere from my Home, connected by WIFI or cable.

 

Etienne

Highlighted
Community Manager
4 of 4

Hello Etienne,

 

Thank you very much for your complete response :)

 

I am glad you manage to find a solution. 

 

I hope it will be useful for someone else.

 

 

 

 

Un like fait toujours plaisir ;) Une réponse t'a aidé? -> ✅ Accepte-la comme solution!