abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 
Gelöst
  • Der Fragesteller hat diesen Beitrag als gelöst markiert.
  • Geschlossen

PLEX App auf Swisscom TV 2.0 Box

Contributor
21 von 50

hallo zusammen
ich denke ich hab soeben eine funktionierende lösung gefunden...
zwar nicht ideal aber es funktioniert.

ich habe einen alten router mit einem anderen netz segment (192.168.2.0) an meine internet box gehängt und an diesen dann mein nas (plex server).
das nas hat nun zwei ip adressen, die 192.168.1.x wie immer und neu noch ne 192.168.2.x.
und siehe da.... es funktioniert einwandfrei...

wäre cool wenn das jemand verifizieren könnte. es braucht einen zusätzlichen router und eine freie netzwerk schnittstelle auf dem plex server.... wahrscheinlich gehts auch wenn der plex server nur noch die adresse aus dem neuen segment hat, hab ich jedoch nicht probiert da ich genug freie schnittstellen im nas hab.

 

Sehr vereinfacht sieht das ganze bei mir dann so aus:

snap0001491.jpg

wünsch euch viel erfolg

Contributor
22 von 50

Was läuft den da irres ab, dass Plex nicht funktioniert wenn ein Switch dazwischen hängt?

Ist aber zumindest eine Erklärung.

 

Hast Du noch einige Details dazu was die Switche nicht durchlassen?

 

Somit fliegt Plex definitiv vom Server und ich behalte meinen Serviio.


Es kam wahrscheinlich nicht so rüber aber ich meinte damit das es sicher nicht am Switch fehlt. Es fehlt bei der Kommunikation Plex Server -> Plex App und umgekehrt im lokalen Netzwerk. Plex Server verwendet ja standartmässig Port 32400 lokal welcher dann nach aussen umgelenkt wird z.b. auf 26488. Möglich wäre nun das die Plex TV 2.0 App den Server erkennt im Internet auf 26488, lokal dann auch auf 26488 sucht statt 32400 und so nichts findet -> Error. Leider habe ich oft wenig Zeit um solche Sachen so gründlich zu untersuchen. Evtl. am Wochenende nächster Versuch mit zwingen auf Port 32400 auch von aussen.

 

btw.: Serviio ist soweit ich darüber informiert bin einer der besten DLNA-Server wo es im Web Profile für

zahlreiche Geräte gibt und auch viel Infos. Er braucht auch kein Quadcore um anständig zu laufen.

 

capitanguex

 

Contributor
23 von 50

@capitanguex schrieb:
Es kam wahrscheinlich nicht so rüber aber ich meinte damit das es sicher nicht am Switch fehlt. Es fehlt bei der Kommunikation Plex Server -> Plex App und umgekehrt im lokalen Netzwerk. Plex Server verwendet ja standartmässig Port 32400 lokal welcher dann nach aussen umgelenkt wird z.b. auf 26488. Möglich wäre nun das die Plex TV 2.0 App den Server erkennt im Internet auf 26488, lokal dann auch auf 26488 sucht statt 32400 und so nichts findet -> Error. Leider habe ich oft wenig Zeit um solche Sachen so gründlich zu untersuchen. Evtl. am Wochenende nächster Versuch mit zwingen auf Port 32400 auch von aussen.

 

btw.: Serviio ist soweit ich darüber informiert bin einer der besten DLNA-Server wo es im Web Profile für

zahlreiche Geräte gibt und auch viel Infos. Er braucht auch kein Quadcore um anständig zu laufen.

 

capitanguex

 


Scheint doch nicht ganz so einfach zu sein. Jedenfalls habe ich den Plex-Server auf den Port 32400 umgebogen und auch auf der Internet-Box die "Portweiterleitung" eingetragen.

 

Über die Webpage "http://xxxx:32400/web/index.html" kann ich von aussen mittels Webserver zugreifen (also ist die Konfiguration richtig).

Plex auf der SCTV Box funktioniert aber weiterhin nicht. (Du kannst Deine Zeit also für etwas besseres investieren :smileyhappy:)

Highlighted
Contributor
24 von 50

@heuby schrieb:

Scheint doch nicht ganz so einfach zu sein. Jedenfalls habe ich den Plex-Server auf den Port 32400 umgebogen und auch auf der Internet-Box die "Portweiterleitung" eingetragen.

 

Über die Webpage "http://xxxx:32400/web/index.html" kann ich von aussen mittels Webserver zugreifen (also ist die Konfiguration richtig).

Plex auf der SCTV Box funktioniert aber weiterhin nicht. (Du kannst Deine Zeit also für etwas besseres investieren :smileyhappy:)


ok danke für deine Mitteilung. Machen wir was besseres, gesünderes mit der Zeit und warten auf den nativen DLNA-Client :smileyhappy:

Contributor
25 von 50

@hangloose schrieb:

hallo zusammen
ich denke ich hab soeben eine funktionierende lösung gefunden...
zwar nicht ideal aber es funktioniert.

ich habe einen alten router mit einem anderen netz segment (192.168.2.0) an meine internet box gehängt und an diesen dann mein nas (plex server).
das nas hat nun zwei ip adressen, die 192.168.1.x wie immer und neu noch ne 192.168.2.x.
und siehe da.... es funktioniert einwandfrei...

wäre cool wenn das jemand verifizieren könnte. es braucht einen zusätzlichen router und eine freie netzwerk schnittstelle auf dem plex server.... wahrscheinlich gehts auch wenn der plex server nur noch die adresse aus dem neuen segment hat, hab ich jedoch nicht probiert da ich genug freie schnittstellen im nas hab.

 

 


Leider habe ich keinen zweiten Router (mehr) um das auszuprobieren.

 

Ich kenne auch die Synology-Box nicht. Sieht irgendwie nach doppeltem NAT aus. Wenn es funktioniert ist es toll. Ich Frage mich nur wie da die Box mit den zwei Adressen klar kommt.

Contributor
26 von 50
mit dem neuen swisscom client update (1.30.17) scheint plex nun problemlos zu funktionieren.
Community Manager
27 von 50

Hallo zusammen

 

Es scheint, dass die meisten von Euch die ein Problem mit der App Plex melden, ein NAS (Synology, Qnap) verwenden. 

Könnt Ihr bitte testen ob es mit der Installation von Plex-Server auf dem PC oder Mac funktioniert und uns hier über das Ergebnis informieren? 

Wenn die Anwendung funktioniert, könnte Plex-Server auf dem NAS ein Teil des Problems sein.

Vielen Dank im Voraus für Eure Rückmeldung und Mithilfe.

 

Liebe Grüsse

SamuelD

Swisscom

Ich moderiere das Kunden–Helfen–Kunden Forum, ein digitaler Begegnungsraum zu Themen rund um Swisscom Produkte.
Contributor
28 von 50

Hallo SamuelD

Ich habe zwei Plexserver installiert, einmal auf Synology NAS und einmal auf Windows PC.

diese funktionierten problemlos mit allen möglichen PLEX Clients (IOS, Android, Windows, LG TV, Samsung BD Player) eben nur nicht mit der App auf dem Swisscom TV 2.0.

Ich konnte mir nur damit behelfen einen weiteren Router zu installieren und den NAS PLEX Server in einem anderen IP Segment laufen zu lassen (siehe Grafik weiter oben im Thread) 

 

 

Jedoch funktioniert es nun seit dem neusten Swisscom Client Update bei mir auch ohne zusätzlichen Router Problemlos.

 

Hoffe es bleibt so :-)

 

 

Contributor
29 von 50

Hallo SamuelD

 

hier funktioniert es nun seit dem neuen update was gestern auf der TV-Box installiert wurde. Plex Server läuft unter Windows 8.1 in der Version 0.9.12.4 (neueste). Vielen Dank für dieses update !

 

capitanguex

 

Contributor
30 von 50
Hallo SamuelD

Bei mir läuft der Plex Server auf einem Win7 PC. Seit dem Update vom 21.7. läuft die App auf der Swisscom Box 2.0 ohne Probleme. Vielen Dank für die Lösung des Problems

Mfg Blumenau
Expert
31 von 50
Ich kann das Votum meiner Vorredner bestätigen. Seit dem letzten Update läuft Plex hier nun auch. Allerdings lässt der Komfort leicht zu wünschen übrig, es fühlt sich irgendwie nicht ganz rund an.

Alleine, dass ich mindestens 5 Schritte ausführen muss, um den Client überhaupt zu starten ist recht Mühsam. Zumal der Aufruf der jeweiligen Schritte teilweise noch mit relativ langen Responsezeiten verbundne ist:
Menü -> Apps -> Meine Apps -> Plex Client -> Client Starten
Eine Favoritenfunktion, oder eine andere Möglichkeit Apps schneller zu starten wäre wünschenswert.
Novice
32 von 50

Hallo

Heisst das jetzt, dass Plex mit all den neusten Swisscom und Plex updates auch ohne Plex Pass funktioniert?

danke für eure Antwort

gruss

franco

Novice
33 von 50

ok habe jetzt den plex Pass für einen Monat abonniert und dann funktioniert es. Allerdings für mich mit dieser performance unbrauchbar.... Full HD Filme ruckeln...obwohl alles über Kabel verbunden ist...

Mein Setup: synology DS214 play, SC 2.0, Swisscom Router.

 

Dann bleibe ich beim abspielen über die DS App in kombination mit dem i-pad und auf die Swisscom Box über DLNA streamen...dort funktioniert es nämlich perfekt.

 

gruss

franco

Expert
34 von 50

@fiaderosa schrieb:

ok habe jetzt den plex Pass für einen Monat abonniert und dann funktioniert es. Allerdings für mich mit dieser performance unbrauchbar.... Full HD Filme ruckeln...obwohl alles über Kabel verbunden ist...

Mein Setup: synology DS214 play, SC 2.0, Swisscom Router.

 

Dann bleibe ich beim abspielen über die DS App in kombination mit dem i-pad und auf die Swisscom Box über DLNA streamen...dort funktioniert es nämlich perfekt.

 

gruss

franco


Mit der DS App und Streaming per DLNA auf die Box, war ich insofern auch zufrieden, als dass es sehr zuverlässig funktioniert. Aber ich kann mich nicht so ganz damit anfreunden, die Auswahl über ein anderes Gerät zu treffen und dann am TV zu schauen. Ich hätte das gerne aus einem Guss. 

 

Plex funktioniert bei mir soweit gut. Ruckeln konnte ich keines feststellen, aber ich habe es auch noch nicht mit sehr hohen Bitraten getestet. Evtl. stimmt serverseitig bei Dir etwas nicht mit den Einstellungen bei Plex. Bei mir war das defaultmässig anfangs so eingestellt, dass Plex auch im Heimnetz die Streamingqualität bei 12 oder 20Mbps begrenzt hat. Wenn das Quellmaterial höhere Bitraten aufwies, dann hat Plex angefangen zu reencodieren. Da war dann die Synology am Anschlag und deswegen hat es geruckelt. 

 

Schau, dass bei "Streamingqualität für lokale Geräte" steht "Original" damit wird vermieden, dass Plex versucht den Content für das Streaming zu reencodieren. Dafür ist die Synology zu schwach. 

Novice
35 von 50

Hi ofaessler

danke für dein Feedback....muss ich mal heute Abend testen mit den Einstellungen.

Gruss

franco

Novice
36 von 50

HI ofaessler

 

habe kurz nachgeschut und es steht eigentlich orginal für lokale player...komisch..

ich hatte gestern beim Aufstarten der App über die Swisscom Box wie das Gefühl , dass beim Zugriff es zuerst raus geht ins Internet und dann wieder ins LAN.....eventuell ist das der Grund warum alles so langsam war?

 

läuft es bei dir flüssig über die SC 2.0 ?

danke

 

 

 

19-08-2015 11-11-56.jpg

Expert
37 von 50
@fiaderosa: Die Medieninhalte, die ich getestet hatte, die liefen flüssig, aber ich hab nur Inhalte bis 720p wahrscheinlich unter 10Mbps Bitrate gestreamt. Ich werde das heute Abend mal mit anspruchsvolleren Files versuchen.

Stell mal versuchsweise die Qualität für entfernte Geräte ebenfalls auf Original. Dann kannst du ausschliessen, dass es daran liegt, dass Plex versucht on the fly zu reencodieren.

Ich teste heute Abend mal ein bisschen ausführlicher.

Was mich bis anhin stört ist eigentlich hauptsächlich wie schon erwähnt, dass es Umständlich ist, bis der Player gestartet ist. Wenn er aber mal gestartet und das Hauptmenü geladen ist, dann funktioniert es relativ gut. Ein leichtes Gefühl von Trägheit bei der Bedienung ist vorhanden, aber ich kann damit leben.
Contributor
38 von 50
@fiaderosa: Wie schaut es mit der Prozesorleistung aus auf deinem NAS? Die App auf TV 2.0 geht übers Internet nicht übers LAN. Deshalb Transcodiert Plex auch alle Filme

Seit ich meinen Plexserver auf einem Leistungsstarken Win7 Rechner habe kenne ich kein Ruckeln mehr. Mein NAS brauche ich nur noch als Datenspeicher.

LG Blumenau
Contributor
39 von 50
Siehe hier die Liste von Plex über die unterstützten NAS und welche hohe Transcoderleistungen unterstützen:

https://support.plex.tv/hc/en-us/articles/201373803

Die DS214 ist leider nicht für 1080p
Expert
40 von 50

Also ich hab nun noch einwenig getestet und komme auf dass selbe Resultat wie fiaderosa:

 

ich kann zwar noch 1080p inhalte über Plex von meiner Synology DS411+II streamen, aber nur wenn die Codierung < 8Mbps ist. Bei höher codierten Videos (hab mit 11 und 18Mbps getestet) stockt die Wiedergabe. Dies ist aber nicht nur beim Client auf der TV 2.0 Box der Fall sondern auch beim PS4 Client. Einzig wenn ich auf mein iPad Streame hakelt nichts. 


Die selben Files spielen problemlos, wenn ich mit der DS Video App vom iPhone oder iPad via DLNA auf die TV 2.0 Box streame. 

 

Ich verstehe nun aber nicht, weshalb ich dem Plex Server nicht abgewöhnen kann, die Files transcodieren zu wollen, der soll sie einfach 1:1 streamen. Und beim iPad scheint das ja auch zu klappen, wenn ich darauf streame. 

 

Schade, weil eigentlich habe ich mich mit dem Client ansonsten jetzt angefreundet. Und Plex ist mit den ganzen zusätzlichen Metadaten die man aggregieren kann halt schon nett. 


DS Video macht das zwar ähnlich, aber eben nicht ganz so nett.