abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 
Gelöst
  • Der Fragesteller hat diesen Beitrag als gelöst markiert.
  • Geschlossen

IGMP Snooping und Switch

Highlighted
Level 2
1 von 19

Hallo zusammen,

 

Ich habe aktuell das Problem, dass wenn ich HD Sender auf der STB gucke, das Netzwerk mit udp Paketen geflutet wird. Geräte die per Ethernet mit dem Heimnetzwerk und dem Swisscom Router verbunden sind, haben dabei keine grossen Einbussen (vorallem beim Internetspeed). Über WLAN angeschlossene Clients merken aber eine massiv schlechtere Internetverbindung. Aber Grundsätzlich sind die iptv Pakete natürlich im gesammten Netzwerk messbar. Als Access Points verwende ich einerseits eine Airport Extreme im ersten Stock, wie eine Airport Express im 3 Stock.

 

Als Swiches setze ich die Netgear GS105 und GS108 ein. Genau da liegt ja offenbar das Problem, weil die kein IGMP Snooping können.

 

Ich möchte nun abklären, wie viele der Switches ich wechseln muss. Dazu habe ich folgende Frage:

Reicht es die Switches zu tauschen, die auf dem Weg zu einer STB sind. Und kann ich damit Switches belassen an die keine STB angeschlossen ist. 

Beispiel: Swisscom Router -> GS105E -> STB

                                                       -> GS105 -> andere Geräte (keine STB)

                                                       -> GS105E -> STB

                                                                       -> Airport Extreme -> andere Geräte (keine STB)

Wenn ich die funktionsweise des IGMP Snooping richtig verstehe würde ja in obigem Beispiel die problematischen IPTV Pakete nicht an die beiden GS105 Switches geroutet, da an diesen keine STB hängt.

 

Und falls jemand einen qualitativ guten iptv fähigen 8Port Router unter 100.00 CHF kennt, wäre ich froh um Tipps. Der 108E scheint ja nicht so gut zu taugen und beim 108T V2 scheint die Verarbeitung problematisch zu sein. Falls sich kein guter finden lässt, werde ich den 8er mit 2 GS105E ersetzen.

 

Vielen Dank für Eure Hilfe

 

 

 

HILFREICHSTE ANTWORT

Akzeptierte Lösungen
Highlighted
Super User
3 von 19

Der GS108E in der Version 2 geht bei mir seit Monaten problemlos. Hast du deine GS10xE mit dem Netgear-Tool richtig konfiguriert? Die Einstellungen sind:

 

netgear-multicast.png

 

Ansonsten reicht es, entweder alle Switches auf dem Pfad zu den TV-Boxen oder alle Switches, an denen ein Accesspoint hängt, auszutauschen. Im Sinne eines sauberen, schnellen und wartungsfreundlichen Netzwerks solltest du möglichst wenig Switches hintereinander kaskadieren, dh. lieber wenige Switches mit vielen Ports als viele Switches mit wenig Ports.

18 Kommentare
Highlighted
Highlighted
Super User
3 von 19

Der GS108E in der Version 2 geht bei mir seit Monaten problemlos. Hast du deine GS10xE mit dem Netgear-Tool richtig konfiguriert? Die Einstellungen sind:

 

netgear-multicast.png

 

Ansonsten reicht es, entweder alle Switches auf dem Pfad zu den TV-Boxen oder alle Switches, an denen ein Accesspoint hängt, auszutauschen. Im Sinne eines sauberen, schnellen und wartungsfreundlichen Netzwerks solltest du möglichst wenig Switches hintereinander kaskadieren, dh. lieber wenige Switches mit vielen Ports als viele Switches mit wenig Ports.

Highlighted
Level 6 XT
Level 6
4 von 19

Er hat die Version ohne e.

Highlighted
Level 2
5 von 19

Vielen Dank Euch allen für die hilfreichen Tipps!

 

Der Flaschenhals in meinem Netzwerk ist die Verkabelung durch das Haus. Leider brachte der Elektriker nicht mehrere Lankabel durch die Wandbuchsen und Rohre. Ich habe jetzt im untersten Stock einen Verteiler (Switch) von dem die Kabel in die restlichen Zimmer gehen. In gewissen Räumen brauche ich aber dann wieder mehrere Anschlüsse, z.B. Büro (Privatrechner, Bürorechner, Gamekonsole, STB, Airport Extreme) und Wohnzimmer (STB, WDTV, TV, Airport Express). Deshalb muss ich leider mehrere kleinere Switches verwenden. Allerdings ist dies jetzt auch schon so und funktioniert eigentlich prima.

Ich werde jetzt wie geraten die Switches auf dem Weg zu einer STB ersetzen mit den "E"-Modellen von Netgear. Dadurch sollte dann das gesamte Netzwerk eigentlich nicht mehr geflutet werden.

 

Ich schreib dann noch ob es geklappt hat, sobald die Switches eingetroffen sind.

 

 

Highlighted
Level 2
6 von 19

Hallo nochmal,

 

Die beiden GS105E Switches sind gestern geliefert worden. Die Vernetzung sieht jetzt wie folgt aus

Swisscom Router -> GS105E -> STB

                                         -> GS105 -> WDTV

                                                       -> TV

                                                       -> Airport Express

                                         -> Wandbuchse -> GS105E -> STB

                                                                               -> Wandbuchse -> GS105E -> Macbook Pro

                                                                                                                     -> Windows Laptop

                                                                               -> Airport Extreme -> MacMini

                                                                                                            -> Windows Laptop

                                                                               -> GS108 -> XBOX

                                                                                             -> Wandbuchse

                                                                                             -> Wandbuchse

Somit hängt an keinem GS105 / GS108 eine STB. Mit Wireshark kann ich weder auf dem Ethernet noch auf dem WLAN eine iptv-Packet Flut registrieren. Die beiden WLAN's verhalten sich wieder normal und die beiden STB funktionieren ebenfalls einwandfrei.

 

Vielen Dank noch einmal für Eure Hilfe!

Highlighted
Level 2
7 von 19

Leute ich habe diesbezüglich noch einmal eine Rückfrage. Bei meiner Lösung war es ebenfalls so, dass sich mein WLAN Router, als Access Point konfiguriert, aufgehängt hat. Dies weil wohl IGMP Snooping nicht darüber läuft. Das erklärt sich auch daher, dass immer wenn ich eine TV-Box aktivierte, das WLAN ausstieg.

 

Meine Frage ist nun aber die folgende: Ist es korrekt, dass ich keine Probleme haben sollte, wenn der WLAN Access Point an einem Switch hängt, wo keine TV-Box darüber läuft? Ich würde es wie folgt verkabeln:

 

Centro Grande als Mainrouter -> direkt an einen Port angeschlossen die Haupt-TV-Box

-> GS105 Switch von Swisscom verteilt LAN ins Haus

              -> GS105 Switch von Swisscom

                             -> daran hängt ein Verbindungskit DUE mit einer Zusatz TV-Box

                             -> weiterer GS105 Switch von Swisscom mit der letzten Zusatz TV-Box

              -> GS105 Switch von Swisscom

                             -> neu hängt hier alleine der WLAN Access Point

 

Muss ich mit dieser Konfiguration erneut mit Problemen rechnen, wenn ich TV und WLAN gleichzeitig nutze oder behebt der neue separate Switch wo der Access Point daran hängt das Problem? Denn schlussendlich geht der Traffic ja dann trotzdem über den gleichen Switch oder spielt das dann keine Rolle mehr?

Editiert
Highlighted
Super User
8 von 19

Ja, das sollte klappen und ist in deiner Situation die sauberste Lösung.

Highlighted
Level 2
9 von 19
Sorry, musste meinen Beitrag noch etwas anpassen. Hatte noch nicht alle Komponenten des LAN's aufgeführt. Meinst du trotzdem, dass es so gehen würde?
Highlighted
Super User
10 von 19

Ja, auch das sollte gehen. Eigentlich kannst du auch auch den letzten Switch, an dem allein der WLAN-AP hängt, verzichten und letzteren direkt an den "nächsthöheren" Switch anschliessen.

 

Hattest du denn bisher irgendwo einen nicht-IGMP-Snooping-fähigen Switch im Einsatz? Weil wenn du lauter Swisscom-Switches verwendest, sollte es sowieso keine Rolle spielen was du wo anhängst, und die Probleme mit dem gefluteten WLAN hätten eigentlich gar nie auftreten dürfen...

Highlighted
Super User
11 von 19
Das funktioniert so wie es geschrieben wurde nicht. Finde den Fehler 🙂
https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Highlighted
Super User
12 von 19

Ausser der Spitzfindigkeit, dass es natürlich nicht gehen kann, wenn *alleine* der AP am Switch hängt (ohne Uplink zum Rest des Netzwerks), finde ich auch nach mehrmaligem Durchlesen keinen Fehler. War es das was du meintest?!?

Level 2
13 von 19

Nun bisher war es so, dass ich den Router (Access Point) selber als Switch verwendete. Aber ich bin nun gespannt, was nicht funktioniert, damit ich dann auch sicher sein kann. Wäre froh um die Auflösung meiner falschen Lösung:smileyhappy:

Highlighted
Super User
14 von 19

Da Swisscom früher den Netgear GS105 verkauft hatte (blau) hoffe ich das du in deinem Post die neueren Netgear GS105E (anthrazit) gemeint hast.

Der eine kann snooping, der andere mit Garantie nicht.

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Highlighted
Level 2
15 von 19

@Tuxone: Ja die neuen anthrazitfarbenen habe ich gemeint. Habe alles solche direkt von Swisscom bezogen. Also geht es so, wie ich es aufführte?

Highlighted
Super User
16 von 19

Nun da dies geklärt ist bin ich gewollt weiterzulesen obwohl mir das E gefehlt hat 🙂

Nun stellt sich die Frage:

-Wieso ist da noch eine Duo Kit im Spiel, wo ist der Uno und für was soll das gut sein?

- Gemäss deiner Aufstellung war der AP ja bereits an einem GS105E. Nun hast du einfach noch einen zusätzlichen dazwischen gesteckt? Falls dies der Fall ist, so hätte es vorher schon funktionieren sollen und die Switches sind einfach falsch konfiguriert, also machen kein snooping.

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Highlighted
Level 5
17 von 19

Hallo zusammen,

hätte da auch noch eine Frage.

Ich habe ja in meinem Netgear Switch GS716T das IGMP Snooping konfiguriert. Nun habe ich ein Netzwerkkabel in die untere Wohnung gezogen und schliesse da die TV Box an.

Wenn ich jetzt dieses Netzwerkkabel am Switch anschliesse gibt es da irgendwie Probleme ?

 

Zwischenablage01.jpg

Highlighted
Super User
18 von 19

Es sind keine Probleme zu erwarten.

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Highlighted
Level 5
19 von 19

Ok, habe bei meinem GS716T alles so eingestellt wie hier beschrieben.

http://www.tuxone.ch/2013/07/swisscom-multicast-im-lan.html

Nach oben