abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 
Gelöst
  • Der Fragesteller hat diesen Beitrag als gelöst markiert.
  • Geschlossen

Problem bei WLAN Wechsel

Contributor
1 von 17

In meinem Netzwerk (Schema siehe Anhang) habe ich folgendes seltsames Phänomen:

Wenn mein Natel (S4) vom WLAN in unserer Scheune auf das WLAN im Haus wechselt sind die meisten Internetseiten (z.B. 20min.ch/blick.ch/cnn.com etc.) nicht mehr erreichbar. Seiten wie google.ch/facebook.com/abc.xyz sind aber ganz normal erreichbar.

Zuvor hatte ich 2 Fritzboxen (1. als Modem/Router im Haus, 2. als Access Point in der Scheune) und es hat alles einwandfrei funktioniert. Das Problem tritt erst seit dem Wechsel von DSL standard Abo auf ein Vivo Abo und dem damit verbundenen Wechsel auf die Swisscom Internet-Box (wegen Festnetz) auf.

Zudem habe ich festgestellt, dass wenn ich auf dem Natel in den Wifi Einstellungen eine fixe IP vergebe das Problem auch nicht auftritt.

Beim Iphone (S5) habe ich dieses Problem überhaupt nicht.

Ideen?

Netzwerk.jpg

HILFREICHSTE ANTWORT

Akzeptierte Lösungen
Super User
4 von 17

Ich denke dies könnte an einer schlechten Dual Stack Umsetzung im Galaxy S4 zusammenhängen.

Deaktiviere auf dem Swisscom Router mal IPv6 um dies zu überprüfen.


Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Selbstdeklaration


Swisscom spezifische Kenntnisse in Sales/Tech:

inOne/inOne KMU > In allen Rollen sowie own Gateway, own SIP Device

Smart Business Connect: Business Internet Services > CB2 Router Konfig in allen Rollen, Business Communication Services > Hosted, Trunk direct, UCC

BNS Business Network Solutions: Managed LAN > Switches, Access Points. Managed Security > Antivirus, Webfilter. RAS, PWLAN, DCS Anbindung

Generell: L1-L7, Firewall, DMZ, VPN Client/Site-Site, 802.1x, SIP, ISDN, Mivoice400, DNS, Dual Stack uvm. wie zB. Fachkundigkeit nach NIV.
16 Kommentare
Super User
2 von 17

Was ist der Grund das Du die Standard IP-Adresse 192.168.1.1 von der Internet-Box auf IP-Adresse 192.168.0.1 gwechselt hast ?

 

So wie es aussieht macht Deine Fritzbox welche keine Routerfunktion mehr haben darf, sondern als reiner WLAN Accesspoint funktionieren sollte ein Problem.

Super User
3 von 17

Die Theorie sagt, dass der Wechsel vom einen AP zum anderen AP (Roaming) rein vom Clienten gesteuert wird. Soweit gut...

 

Meine mehrfache Erfahrung zeigt aber (scheint gem. Onkel Google  aber auch sonst vorzukommen), dass häufig wenn eine Fritzbox im Spiel ist, dass die Clienten im WLAN der Fritzbox festhängen, obwohl der Client näher an einem anderen, stärkeren AP dran wäre mit identischer SSID.

 

Eine Verwendung von einem anderen AP als den der Fritz hat in meinen Fällen i.d.R. das Problem gelöst...

 

Gruess, POGO 1104

 

 

keep on rockin'
Super User
4 von 17

Ich denke dies könnte an einer schlechten Dual Stack Umsetzung im Galaxy S4 zusammenhängen.

Deaktiviere auf dem Swisscom Router mal IPv6 um dies zu überprüfen.


Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Selbstdeklaration


Swisscom spezifische Kenntnisse in Sales/Tech:

inOne/inOne KMU > In allen Rollen sowie own Gateway, own SIP Device

Smart Business Connect: Business Internet Services > CB2 Router Konfig in allen Rollen, Business Communication Services > Hosted, Trunk direct, UCC

BNS Business Network Solutions: Managed LAN > Switches, Access Points. Managed Security > Antivirus, Webfilter. RAS, PWLAN, DCS Anbindung

Generell: L1-L7, Firewall, DMZ, VPN Client/Site-Site, 802.1x, SIP, ISDN, Mivoice400, DNS, Dual Stack uvm. wie zB. Fachkundigkeit nach NIV.
Contributor
5 von 17

@WalterB Grund ist, dass mehrer Geräte bereits fixe IPs im 192.168.0.x Bereich zugeordnet hatten. Damit musste ich weniger Einstellungen anpassen.

@POGO 1104 Ich habe den Fritzbox AP durch einen Devolo dLan 500 WiFi ausgetauscht und das Probelm ist auch aufgetreten. Somit denke ich es liegt nicht an der FritzBox sondern eher an der Swisscom Internet-Box oder dem S4?!?

Super User
6 von 17

@swim

 

Hast Du bei der Internet-Box die beiden Frequenzen 2,4GHz und 5.0GHz schon auf einzeln eingestellt ?

Wurde mit dem vorhandenen WLAN Test bei der IB schon der beste Kanal eingestellt ?

Ist die neuste Firmware bei der IB vorhanden ?

7 von 17

@Tuxone ich empfinde deine Antwort als die am naheliegensten, da das Problem auf iOS iPhone nicht präsent ist. Trotz dem, dass Vieles geändert hat.

Mal schauen, was @swim herausfindet

Contributor
8 von 17

@Tux0ne Danke! Das hat geholfen. Sobald IPV6 ausgeschaltet auf der Internet-Box funktioniert der Wechsel. 

Aus Neugier: Warum haben gewisse Seiten wie google oder facebook funktioniert, die Mehrheit der Seiten jedoch nicht?

Super User
9 von 17

Ich bin immer dafür, dass man die Ursachen verfolgt und nicht Phantomen nachjagt.

In diesem Fall hast du die typischen IPv6 Player wie google und Facebook genannt. Zudem sind die anderen Seiten IPv4 only.

Was hat zudem geändert? Eigentlich nur das CPE. Was hat vermutlich geändert? Dual Stack Betrieb durch das Swisscom CPE.

 

Vermutlich liegt der Grund für dieses Problem, dass beim Wechsel auf das Heimnetz etwas mit dem IPv4 Routing nicht mehr stimmt. Woran das liegt kann ich dir so jetzt auch nicht sagen. Da müsste man mal mit zusätzlichen Tools auf dem Phone schauen, was an den Standorten mit den IP's geschieht und ein Traceroute starten. So sieht man am ehesten wo etwas blockiert.

 

Ich bin aber dafür, dass du IPv6 nicht deaktiviert belässt und mit dem Workaround, der fixen IPv4 auf diesem einen Phone, arbeitest. 


Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Selbstdeklaration


Swisscom spezifische Kenntnisse in Sales/Tech:

inOne/inOne KMU > In allen Rollen sowie own Gateway, own SIP Device

Smart Business Connect: Business Internet Services > CB2 Router Konfig in allen Rollen, Business Communication Services > Hosted, Trunk direct, UCC

BNS Business Network Solutions: Managed LAN > Switches, Access Points. Managed Security > Antivirus, Webfilter. RAS, PWLAN, DCS Anbindung

Generell: L1-L7, Firewall, DMZ, VPN Client/Site-Site, 802.1x, SIP, ISDN, Mivoice400, DNS, Dual Stack uvm. wie zB. Fachkundigkeit nach NIV.
10 von 17
Klasse! Nur würde ich IPv6 abgeschaltet lassen. Ich hatte auf meiner Fritzbox nur Ärger.
@Tuxone - wieso denkst du ipv6 soll an sein?
Es könnte je nachdem helfen wenn schon einschalten auch am Fritz AP ipv6 einzuschalten.
Super User hed
Super User
11 von 17

IPv6 generell abzuschalten ist auch meine Empfehlung.

 

Ich hatte auch mit der Internet Box Probleme mit verschiedenen drahtlosen Endgeräten, als noch das IPv6 aktiviert war. Ich habe IPv6 nicht nur bei der IB sondern auch bei allen andern Geräten wo das möglich war in der Netzwerkeinstellungen desaktiviert / gelöscht.

 

Damit wirke ich zwar dem Fortschritt entgegen, aber ein stabiles funktionierendes Netzwerk ist mir lieber, selbst wenn ich dazu auf das 35-jährige IPv4-Protokoll setzen muss.

 

Für mich ist IPv6 erst dann wieder ein Thema, wenn das in den von mir verwendeten Geräten sauber im IP-Stack implementiert ist.

Highlighted
Super User
12 von 17

Bin da völlig der gleichen Meinung wie Tuxone: IPv6 disablen ist gut zur Eingrenzung der Ursache. Das eigentliche Problem löst man damit aber keinesfalls.

Im vorliegenden Fall scheint es sich um einen Bug im IPv4-Stack von Android zu handeln, der im Dualstackbetrieb beim WLAN-Roaming auftritt. Ich erinnere mich an einige ähnliche Probleme mit KitKat, seit Lollipop wurde es etwas besser. Hast du die neuste Android-Version mit allen Updates drauf?

Super User hed
Super User
13 von 17

Schon klar, das Problem lässt sich lösen, wenn man die Geräte mit mangelhaft implementiertem IPv6-Stack ersetzt, sofern in absehbarer Zeit kein problemlösendes Upgrade zur Verfügung steht.

 

Ich bin allerdings nicht bereit, ein Gerät nur deswegen zum Elektroschrott zu erklären weil, es mit IPv6 nicht zurecht kommt. Zumal mit IPv4 eine gut funktionierende ausgereifte Alternative zur Verfügung steht.

 

Nebst der Fehlereingrenzung dient somit das desaktivieren von IPv6 auch als Workaround, bis alle Geräte im Netzwerk problemlos mit IPv6 umgehen können. Je nach Betriebsdauer eines Gerätes kann dieser Workaround somit noch für Jahre notwendig sein.

Contributor
14 von 17

@PowerMac Ja, auf meinem S4 ist die aktuellste Version, die für dieses Gerät verfügbar ist, drauf (5.0.1). Updates werden bei mir immer sehr zeitnah eingespielt.

Super User
15 von 17
Wie sagt man so schön: "IPv6 ist keine Option."
Ich wurde in diesem Fall mit dem Workaround fahren und nicht das ganze Protokoll deaktivieren weil 1 Gerät in einer speziellen Situation ein Problem damit hat.
Es ist wie mit 4 Adrigen Netzwerkkabel. Wieso alles austauschen weil die Internet Box ein Problem damit hat?
Verstehe ich nicht.
Muss allerdings sagen, dass ich auch nicht bei Swisscom arbeite. Sonst käme ich vermutlich auch noch zu solchen Fantasievorstellungen...

Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Selbstdeklaration


Swisscom spezifische Kenntnisse in Sales/Tech:

inOne/inOne KMU > In allen Rollen sowie own Gateway, own SIP Device

Smart Business Connect: Business Internet Services > CB2 Router Konfig in allen Rollen, Business Communication Services > Hosted, Trunk direct, UCC

BNS Business Network Solutions: Managed LAN > Switches, Access Points. Managed Security > Antivirus, Webfilter. RAS, PWLAN, DCS Anbindung

Generell: L1-L7, Firewall, DMZ, VPN Client/Site-Site, 802.1x, SIP, ISDN, Mivoice400, DNS, Dual Stack uvm. wie zB. Fachkundigkeit nach NIV.
Expert
16 von 17

@swim schrieb:

Netzwerk.jpg


Das Problem ist deine SSID = ACAB

 

All Cops Are Bastards

 

Was treibst du denn schönes in deiner Scheune? :smileyvery-happy:

Super User
17 von 17

Tja, dann bleibt noch die Hoffnung dass das in einem künftigen Update behoben wird. Auf der Android-Entwicklerseite habe ich auf die Schnelle keinen offenen Case gefunden der deiner Beschreibung ähnlich ist, je nach dem wie reproduzierbar dein Problem ist lohnt sich evt. eine Bugmeldung. Interessant für eine Meldung wäre allenfalls noch, ob das Problem nur beim WLAN-Roaming in einer Richtung, dh. nur von Scheune nach Haus, oder auch von Haus nach Scheune auftritt.

Der Vorschlag von Tux0ne mit der fixen IP ist jedenfalls ein guter Workaround, AFAIR speichert Android die IP-Settings pro SSID getrennt.