cancel
Showing results for 
Search instead for 
Did you mean: 
  • Closed

Internet connection fails repeatedly - WLAN ok

Novice
1 of 6

Hi everyone,

 

We're having some serious problems with our Internet connections. They began Feb 5 2014.

 

We can connect to our WLAN network, but there is no Internet connection. Unplugging the router and re-plugging after 30 sec restores Internet, but only for a little time. 

 

We have 1 PC, 2 iPhones and 1 Macbook Pro. Often, but not always, the Macbook remains connected to the Internet while all other devices cannot. Some times, Internet connection goes down shortly after the MacBook connects - but not always!

 

We have called Swisscom practically every day without solution. We switched to fibre optic yesterday and hoped that would fix everything. It didn't. Exact same problems. Swisscom believes that it's a rooter problem, which would that our old router AND our brand-new fibre optic router have problems with wi fi. I find that extremely unlikely, and expect that the problem will persist after we install the third router.

 

Any advice? We've done every single thing from switching the router on and off to hard restarts and reboots. I've accessed the router through the network and the Overview will indicate that everything's fine while there is no Internet connection. However, it does say that IPv6 Prefix is not assigned - whatever that means.

 

Also, the Macbook uses a sort of VPN, and I've wondered if that confuses the network. Can't imagine why, though, as everything has been been working fine up until now.

 

Many thanks in advance!

 

 

Edited
5 Comments
Expert
2 of 6

Hi

 

Did you do some troubleshooting or just rebooting the router and devices?

 

As I understand the wlan is working but you can't connect to the internet.

Next time you loose the connection try the following steps on the pc or mac (Whichever isn't working):

 

1. Ping the Router/Gateway

2. Ping a Website like google.com (by name)

3. Ping a Website like google.com (by IP)

4. Do a nslookup of www.google.com

 

It's hard to tell what's wrong without more information 🙂

Highlighted
Novice
3 of 6

Thanks for the reply! 

 

I've just been rebooting/restarting/unplugging-replugging the router.

 

How do I ping a website? Sorry, I'm not very knowledgable on network stuff 🙂

Expert
4 of 6

For Windows PC:

Start > Run Command > cmd

Now you should see a command prompt.

The commands are ping and nslookup

 

For Mac: Finder > Terminal

(I think, I don't hava a Mac)

The commands are also ping and nslookup

 

Examples:

ping www.google.com

ping 195.186.1.162

nslookup www.google.com

(Google for it and you will find loads of examples)

Edited
Novice
5 of 6

I did them when we lost Internet today, and I got 0s for pinging www.google.ch. Tracerouting failed, since there was no Internet connection.

 

 

My wife's Macbook connects to the Internet through a work VPN (she runs Windows on it remotely). Whenever she connects it to our WLAN, every device loses Internet connection except for her Mac - even after re-starting the router. So I'm beginning to wonder if the problem lies there.

 

I also tried connecting my PC laptop to the Internet via cable into the router. It said "limited" and didn't connect.

The most frustrating thing is that during all this mess, the router's Overview shows everything green, ticked and running perfectly.

 

Any other ideas? I really appreciate your help!

Expert
6 of 6

Could you do the following steps:

 

Wait till you loose connection on the PC.

Start the cmd tool.

run "ipconfig /all"

Look for the line Default Gateway, remember the IP address (Probably 192.168.1.1)

run "ping 192.168.1.1" (Or whaterver the IP of your default gateway is)

If you get answers from the gateway, try and run "ping 195.186.1.162"

If you get answers run nslookup www.google.com

 

Please make print screens from the outputs and post them here.