abbrechen
Suchergebnisse werden angezeigt für 
Anzeigen  nur  | Stattdessen suchen nach 
Meintest du: 
Gelöst
  • Der Fragesteller hat diesen Beitrag als gelöst markiert.
  • Geschlossen

Firewall Eigenbau (IPFire alix) just for fun

PowerMac
Super User
101 von 119

Wo wir gleich dabei sind: die Zeile "altnet 239.0.0.0/8" kann eigentlich auch auskommentiert oder gelöscht werden, da es sich um eine Teilmenge des nachfolgenden Range handelt (oder einfacher gesagt: schadet nichts, nützt aber auch nichts).

have you tried turning it off and on again?
ogret
Level 1
102 von 119

Folgendes Problem ist aufgetaucht:

 

So funktioniert Swisscom TV dafür das WLAN nicht mehr.

 

##------------------------------------------------------
## Enable Quickleave mode (Sends Leave instantly)
##------------------------------------------------------
quickleave


##------------------------------------------------------
## Configuration for eth0 (Upstream Interface)
##------------------------------------------------------
phyint red0 upstream  ratelimit 0  threshold 1
        altnet 224.0.0.0/4       #Well know Mcst
        altnet 195.186.0.0/16    #Swisscom Infra

##------------------------------------------------------
## Configuration for eth1 (Downstream Interface)
##------------------------------------------------------
phyint green0 downstream  ratelimit 0  threshold 1

##------------------------------------------------------
## Configuration for eth2 (Disabled Interface)
##------------------------------------------------------
phyint tun0 disabled
phyint red0 disabled
phyint orange0 disabled

 

 

So funktiniert das WLAN dafür Swisscom TV nicht mehr.

 

##------------------------------------------------------
## Enable Quickleave mode (Sends Leave instantly)
##------------------------------------------------------
quickleave


##------------------------------------------------------
## Configuration for eth0 (Upstream Interface)
##------------------------------------------------------
phyint red0 upstream  ratelimit 0  threshold 1
        altnet 224.0.0.0/4       #Well know Mcst
        altnet 195.186.0.0/16    #Swisscom Infra

        altnet 192.168.111.75/32    #Swisscom TV BOX
##------------------------------------------------------
## Configuration for eth1 (Downstream Interface)
##------------------------------------------------------
phyint green0 downstream  ratelimit 0  threshold 1
       altnet 192.168.111.75/32    #Swisscom TV BOX
##------------------------------------------------------
## Configuration for eth2 (Disabled Interface)
##------------------------------------------------------
phyint tun0 disabled
phyint red0 disabled
phyint orange0 disabled

 

 

Leider läuft nicht beides parallel hat jemand eine idee?

ogret
Level 1
103 von 119

Vorübergehend habe ich das Problem mit einer DMZ gelöst für das WLAN.

 

Trotzdem wär ich froh, wenn jemand mir ev. helfen könnte.

 

Das Problem besteht weiterhin nur im WLAN im LAN funktioniert alles.

 

Danke.

PowerMac
Super User
104 von 119

Wie genau hast du die Interfaces konfiguriert? Hattest du eine Bridge zwischen den Interfaces blue0 und green0 erstellt, wie z.B. in dieser Anleitung beschrieben?

Falls dem so ist, was ist der Output von folgendem Befehl:

[root@ipfire ~]# cat /sys/devices/virtual/net/green0/bridge/multicast_snooping

Wenn der Output eine "0" ist, gib folgenden Befehl ein:

[root@ipfire ~]# echo "1" > /sys/devices/virtual/net/green0/bridge/multicast_snooping

Falls der Output nicht "0" sondern "1" war... dann wüsste ich gerade auch nicht weiter.

have you tried turning it off and on again?
ogret
Level 1
105 von 119

Guten morgen,

 

nein ich habe kein Bridge zwischen meiner DMZ (Orange) und LAN (Green) erstellt.

 

Ich habe mich im vohrigen Post falsch ausgedrückt.

 

Das WLAN funktioniert in der DMZ tadellos.

 

Leider funktioniert das Internet im Green mit einem AP nicht. Sie erhalten eine IP-Adresse aber es kommt keine Webseite.

PowerMac
Super User
106 von 119

@ogret schrieb:
[...]

Leider funktioniert das Internet im Green mit einem AP nicht. Sie erhalten eine IP-Adresse aber es kommt keine Webseite.


Du hast zwei Möglichkeiten: entweder du lässt hardwaremässig alles so wie es jetzt ist und machst eine Softwarebridge zwischen dem DMZ-Port und dem green0-Port (wie in der vorher verlinkten Anleitung beschrieben), oder du kaufst einen IGMP-Snooping-fähigen Switch und hängst den AP dort dran.

have you tried turning it off and on again?
ogret
Level 1
107 von 119

Hehe, danke.

 

Der Netgear GS105E sollte funktionieren, da Prosafe.

 

Die frage ist ich habe mehrere Switches von Netgear ohne Prosafe. Muss ich nur 1 Prosafe kaufen und dort AP installieren oder alle Netgear Switches ersetzen?

 

Danke.

Editiert
PowerMac
Super User
108 von 119

Grundsätzlich sollte es reichen, den GS105E zwischen IPfire und AP zu schalten (falls du noch konfigurieren musst, findest du die Einstellungen hier). Besser wäre es, auf dem gesamten Pfad zur TV-Box solche Switches zu nehmen, und noch besser, wenn das im gesamten Netzwerk der Fall ist.

have you tried turning it off and on again?
ogret
Level 1
109 von 119

Meine Netgearswitches sind alle schon Netgear ProSafe GS105, diese reichen soweit ich verstehe nicht aus oder?

 

Es müssen wirklich Netgear ProSafe GS105E sein?

PowerMac
Super User
110 von 119

Jawoll, nur das Modell mit dem E unterstützt IGMP-Snooping. Eine Auflistung von tauglichen Switches findest du z.B. im Wiki.

have you tried turning it off and on again?
ogret
Level 1
111 von 119

Wieso taucht das Problem nur bei Geräten die AP benutzen? Wieso betrifft es nicht die PC's die am Netzwerkkabel hängen?

POGO 1104
Super User
112 von 119

@ogret schrieb:

Wieso taucht das Problem nur bei Geräten die AP benutzen? Wieso betrifft es nicht die PC's die am Netzwerkkabel hängen?


Hier findest du eine Erklärung:

http://www.tuxone.ch/2013/07/swisscom-multicast-im-lan.html

 

POGO 1104

keep on rockin'
ogret
Level 1
113 von 119

Das Netzwerk wurde erfolgreich eingerichtet.

 

Ich habe den GS105E direkt nach der Firewall angeschlossen an dem Green0 (LAN) Adapter.

 

Im Netzwerk selber habe ich noch 4 andere Netgear Swich ohne Prosafe. Das Netzwerk ist jetzt stabil. Ich kann an jedem anderen Switch den AP anschliessen ohne Fehlermeldung oder instabilität zu erzeuge.

 

Layout:

 

Ipfire:

                LAN(Green0)     WAN(Red0)---------Modem (Bridge Modus)

                       |

                       |

                       |

                       |

Swiss TV--- GS105E-----------------GS105---------------------GS105

                          |                                    |                                    |

                          |                                    PC                                Server

                  GS105--------AP

                      |

                      |

                  Drucker

                    

                 

 

 

 

 

 

PowerMac
Super User
114 von 119

Das Wörtchen "Prosafe" auf dem Gehäuse sagt noch nichts aus; so wie ich die Marketingterminologie von Netgear verstehe, müsstest du mindestens einen Switch aus der Reihe "Prosafe Plus" nehmen, da erst diese über rudimentäre Managementfunktionen (wie eben z.B. IGMP-Snooping) verfügen. Zur Sicherheit immer das Datenblatt konsultieren und sich über die Suchfunktion oder das Wiki hier im Forum versichern, dass der Switch geeignet ist.

have you tried turning it off and on again?
Editiert
Tux0ne
Level 9
115 von 119

Edit #1

 

altnet 213.3.72.0/24 #TV 2.0 Infra

 

Relevant für:

Empfang von Swisscom TV 2.0 Streams

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.
scream88
Level 2
116 von 119

@TuxOne: Boah, du warst ja schnell. Gestern bestellt aber leider noch nicht testen können. Muss noch bis am 10. April warten 😞

 

Danke für die Infos. 🙂

Tux0ne
Level 9
117 von 119

I mag mich erinnern das ich dies vor etwa einem halben Jahr schnell gelöst habe ja 🙂

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.
scream88
Level 2
118 von 119

Vor einem halben Jahr ;)? Okay. Dann hast du aber Beziehungen. 😛

Tux0ne
Level 9
119 von 119

All denen welche noch nicht gewechselt haben, empfehle ich das Update auf den neuen Release.

  • Weil die neue Firewall so viel geiler ist und vieles einfacher macht.
  • Aus Sicherheitsgründen.

http://www.ipfire.org/news/ipfire-2.15-core-update-77-freigegeben

 

Grundsätzlich ändert sich bezüglich der TV Konfiguration nichts.

 

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.
Nach oben