annuler
Affichage des résultats de 
Rechercher plutôt 
Vouliez-vous dire : 
RÉSOLU
  • L'auteur de la question a marqué cette contribution comme résolue.
  • Fermés

Configuration Cisco 887VA ?

Contributor
1 de 21

Bonjour,

 

J'ai réussi à configurer le Cisco 887VA à se connecter à Swisscom VDSL2.

Par contre, la Swisscom TV ne fonctionne pas très bien malgrès que

j'ai activé IGMPv3. J'ai environ 3 seconds de flux video et après

il s'arrête et la voix n'est pas syncro avec l'image.

 

Je souhaiterai savoir si vous avez une documentation technique

(pour Cisco ou generic) sur la configuration des routers pour une

connection Swisscom VDSL2.

 

J'aimerai aussi avoir des infos sur ce qu'il faut activer sur le router

pour correctement utiliser la Swisscom TV (IGMP Snooping, IGMP Proxy, etc.)

 

Je suppose que je dois activer du QoS ou utiliser du 802.1p ou 802.1q.

 

N.B. Le router Cisco 887VA est apprové par Swisscom :

http://www.swisscom.com/dam/swisscom/de/ws/documents/D_BBCS-Dokumente/E_BBCS_Supporting-Document_Pro...

 

 

 

RÉSPONSE LA PLUS UTILE

Solutions approuvées
Contributor
8 de 21

 

J'ai réussi la Swisscom TV fonctionne

sans coupure sur mon Cisco 887VA-W  

    => enfin !!!

 

 

Le secret ou plutot les secrets ?

 

 

  • L'IP RP (Rendezvous Point) chez Swisscom est bel et bien 1.1.1.1 !!!
    sans IP RP le flux s'arrete après environ 10 secondes (flux unicast avant multicast) 
  • ip igmp query-interval 125 ou 60 ou 30 ne fonctionne pas  (set igmp query-intvl 125)
  • ip igmp query-interval 12 fonctionne -- default Cisco (60) et Motorola (125)
    sans une valeur aussi basse le flux s'arrete avant 60 seconds ! 
  • Les timeout chez Motorola sont en deci-secondes tandis et chez Cisco en milli-secondes ! 

 

> je n'ai pas bcp de temps pour analyser ces données,

> mais au premier coup d'oeil je dirai que ce n'est pas possible que lP Rp soit 1.1.1.1!

 

Oui, pour moi je suis persuadé que IP RP Rendezvous Point est bien 1.1.1.1

chez Swisscom. Ce qui est un choix discutable vu que c'est un block routable

qui a été enlevé de la boggus list par IANA.. 

 

Au niveau du Cisco, j'ai obtenu ceci :

%SEC-6-IPACCESSLOGSP: list INTERNET-TO-WAN denied igmp 1.1.1.1 -> 224.0.0.1 (0), 1 packet

 

Au niveau du Motorola Netopia 3397GP et après avoir activé le mode bridge/router

et le mode log igmp ... bingo encore 1.1.1.1 !!!

 

Netopia-3000/31499700> config

Config Mode v1.3
Netopia-3000/31499700 (top)>> set igmp log-enable on
Netopia-3000/31499700 (top)>> save
WARNING: Concurrent-bridging/routing has been turned ON!


Configuration data saved.
Netopia-3000/31499700 (top)>> top
Netopia-3000/31499700 (top)>> cd ..
Error: Command ('cd') not found

Netopia-3000/31499700 (top)>> exit

Netopia-3000/31499700> show log

 

Message Log:
2/19/12 09:10:21 AM L3 TR-069: Closing connection on auth fail
2/19/12 09:10:21 AM L3 SSL: Closing Connection: rms.bluewin.ch
2/19/12 09:10:25 AM L3 IGMP: [ENWAN1] Received General Query host: 1.1.1.1 max-reponse-time 2 s
2/19/12 09:10:25 AM L3 IGMP: [en0] Received General Query host: 1.1.1.1 max-reponse-time 2 s
2/19/12 09:10:26 AM L3 IGMP: [ENWAN1] Sending v2-Report group: 239.255.255.250
2/19/12 09:10:26 AM L3 IGMP: [ENWAN1] Sending v2-Report group: 224.0.0.251
2/19/12 09:10:26 AM L3 IGMP: [ENWAN1] Sending v2-Report group: 239.186.63.6
2/19/12 09:10:26 AM L3 IGMP: [en0] Received v2-Report group: 239.186.63.6 host: 172.16.78.128
2/19/12 09:10:26 AM L3 IGMP: [en0] Received v2-Report group: 239.255.255.250 host: 172.16.78.128
2/19/12 09:10:27 AM L3 IGMP: [en0] Received v2-Report group: 224.0.0.251 host: 172.16.78.2
2/19/12 09:10:36 AM L3 IGMP: [ENWAN1] Received General Query host: 1.1.1.1 max-reponse-time 2 s
2/19/12 09:10:36 AM L3 IGMP: [en0] Received General Query host: 1.1.1.1 max-reponse-time 2 s
2/19/12 09:10:36 AM L3 IGMP: [ENWAN1] Sending v2-Report group: 239.186.63.6

Netopia-3000/31499700>

 

Meme si 1.0.0.0 a été assigné à APNIC il semble que Swisscom l'utilise en interne.

Tu peux d'ailleur pinger 1.1.1.1 depuis ta connexion Swisscom !

 

ping -c 1 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: icmp_seq=0 ttl=126 time=19.913 ms

--- 1.1.1.1 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 19.913/19.913/19.913/0.000 ms

 

1.1.1.1 n'arrive clairement pas chez au USA avec 19ms !

 

traceroute 1.1.1.1
traceroute to 1.1.1.1 (1.1.1.1), 64 hops max, 52 byte packets
1 * 172.16.78.1 (172.16.78.1) 0.591 ms 0.601 ms
2 1.1.1.1 (1.1.1.1) 19.706 ms 19.553 ms 19.902 ms

 

Voir aussi cet article 🙂

http://packetlife.net/blog/2010/feb/5/ripe-plays-with-1-0-0-0-network-apnic-allocation/

 

inetnum: 1.1.1.0 - 1.1.1.255
netname: Debogon-prefix
descr: APNIC Debogon Project
descr: APNIC Pty Ltd
country: AU
admin-c: AR302-AP
tech-c: AR302-AP
mnt-by: APNIC-HM
mnt-routes: MAINT-AU-APNIC-GM85-AP
mnt-irt: IRT-APNICRANDNET-AU
status: ASSIGNED PORTABLE
changed: hm-changed@apnic.net 20110922
source: APNIC

 

> le cmd sont normalmement

> set igmp snooping on

> set igmp robustness 2

> set igmp query-intvl 125

> set igmp query-response-intvl 100

> set igmp version 3

> set igmp fast-leave on

> set igmp log-enable off

> set igmp default-forwarding-allow on

> set ip igmp-forwarding on

 

Voici la configuration qui fonctionne avec la Swisscom TV et Swisscom VDSL2

 

!
service internal
!
memory-size iomem 20
!
controller VDSL 0
 operating mode vdsl2
 modem co5
!
ip pim rp-address 1.1.1.1
!
ip multicast-routing
!
ip igmp snooping
!
interface Ethernet0
 ip dhcp client broadcast-flag clear
 ip address dhcp
 no ip virtual-reassembly in
 no ip route-cache

 no ip mfib cef input
 no ip mfib cef output

 ip pim sparse-mode

 ip igmp query-interval 10
 ip igmp querier-timeout 60
 ip igmp query-max-response-time 8

 ip igmp last-member-query-interval 1000
 ip igmp last-member-query-count 2
 ip igmp version 3
 ip igmp proxy-service
 load-interval 30
 auto discovery qos
 service-policy output QoS-Ethernet0
!
interface Vlan1
 ip address 172.16.78.1 255.255.255.0
 ip nat inside
 no ip virtual-reassembly in
 ip tcp adjust-mss 1452
 ip pim sparse-mode

 ip igmp query-interval 10
 ip igmp querier-timeout 60
 ip igmp query-max-response-time 8

 ip igmp last-member-query-interval 1000
 ip igmp last-member-query-count 2
 ip igmp version 3
 ip igmp proxy-service
 ip igmp helper-address 1.1.1.1
 ip igmp explicit-tracking
 load-interval 30
 auto discovery qos
 service-policy output QoS-Vlan1
!
class-map match-any QoS-Video
 match protocol rtp video
 match ip dscp af41
!
policy-map QoS-Ethernet0
 class class-default
 fair-queue
!
policy-map QoS-Vlan1
 class QoS-Video
  set dscp af41
 class class-default
  set dscp default
!
ip forward-protocol nd
!
scheduler allocate 20000 1000
!
end

 

> Faut pas que tu n'en dormes pas du week-end :smileywink:

> Peut-être d'autres membres plus spécialisés que moi pourraient t'aider?

 

Je pense que c'est bon maintenant.

Merci encore de ton aide !

 

Faut dire que j'ai été dégouté pendant trois jours de repasser sur mon vieux

Motorola Netopia de 2008... pour que ma ptite famille regarde la Swisscom TV...

 

C'était étrange quand même qu'en connectant uniquement la Swisscom TV

sur le Cisco 887VA, le fux Swisscom TV se fige... C'est pas la QoS qui allait aider

car avec 22Mbps/5Mps c'est suffisant pour un flux de 12Mbps (HD) ou 5Mbps (SD)

 

DETAILS TECHNIQUES

 

> set igmp query-intvl 125
>
> Query Interval– the amount of time in seconds between IGMP General Query messages sent by the
> querier gateway. The default query interval is 125 seconds

 

C'ETAIT L'ORGINE DU STOP DE L'IMAGE APRES MOINS DE 60 SECONDES
(LE STOP APRES 10 SEC A ETE FIXE AVEC L'ADRESSE RendezvousPoint => 1.1.1.1)

 

CONFIG
ip igmp query-interval 10

 

CISCO
ip igmp query-interval ?
<1-18000> Query interval in seconds

 

INFO
Autant 125 (Motorola/RFC default) et 60 (Cisco default) et meme 30 ne fonctionne pas bien avec Swisscom TV.
Il faut ip igmp query-interval 12 !!!

 

<< Note : We recommend that you use the default IGMP query interval and timeout period.
The Cisco IOS software uses a default IGMP query interval of 60 seconds,
which is different from the RFC standard default of 125 seconds.
Using a lower default IGMP query interval of 60 seconds allows routers
to stop forwarding traffic faster when a member crashes without sending
leaves (in IGMPv2 or IGMPv3 environment) >>

 

> set igmp last-member-query-intvl 10
>
> Sets the last member quer y inter val: the amount of time in tenths of a second that the IGMP gateway
> waits to receive a response to a Group-Specific Quer y message. The last member quer y inter val is also
> the amount of time in seconds between successive Group-Specific Quer y messages.
> The default is 1 second (10 deci-seconds)

 

CONFIG

ip igmp last-member-query-interval 1000

 

CISCO
ip igmp last-member-query-interval ?
<100-25500> Last member query interval in milliseconds

 

INFO
Il faut faire très attention les valeurs Motorola sont en deci-seconds tandis que Cisco en millo-seconds !!!

 

> set igmp last-member-query-count 2

 

CONFIG
ip igmp last-member-query-count 2

 

CISCO
ip igmp last-member-query-count ?

<1-7> Last member query count

 

> set igmp query-response-intvl 100
>
> Sets the query-response interval range: from 5 deci-seconds (tenths of a second) – 255 deci-seconds.
> The default is 100 deci-seconds.
>
> Last Member Query Interval – the amount of time in tenths of a second that the IGMP gateway
> waits to receive a response to a Group-Specific Query message. The last member query interval is
> also the amount of time in seconds between successive Group-Specific Query messages. The
> default last member query interval is 1 second (10 deci-seconds).

 

INFO
pas info j'ai cru que c'était ip igmp last-member-query-interval ??

 

> set igmp version 3

 

CONFIG

ip igmp version 3

 

> set igmp snooping on

 

CONFIG
ip igmp snooping

 

INFO
et pas ip igmp snooping vlan 1

 

> set igmp default-forwarding-allow on

 

ip multicast-routing

 

> set igmp fast-leave on
>
> Fast Leave – set to off by default, fast leave enables a non-standard expedited leave mechanism.
> The querier keeps track of which client is requesting which channel by IP address. When a leave
> message is received, the querier can check its internal table to see if there are any more clients on
> this group. If there are none, it immediately sends an IGMP leave message to the upstream querier.

 

INFO
"ip igmp snooping fast-leave" pas dispo sur mon IOS

 

> set igmp robustness 2
>
> Robustness – a way of indicating how sensitive to lost packets the network is.
> IGMP can recover from robustness minus 1 lost IGMP packet. The default value is 2.

 

INFO
Pas dispo sur ma version IOS

 

> set igmp unsol-report-intvl 10
>
> Sets the unsolicited report interval: the amount of time in seconds between repetitions of a particular
> computer’s initial report of membership in a group. The default is 10 seconds

 

INFO
Pas info sur une commande similaire sur IOS


> set igmp wireless-m2u on
>
> This command allows you enable or disable wireless multicast-to-unicast if igmp snooping is set to on.
>
> Wireless Multicast to Unicast conversion – Only available if IGMP Snooping is enabled. If set to
> on, the Gateway replaces the multicast MAC-address with the physical MAC-address of the wireless
> client. If there is more than one wireless client interested in the same multicast group, the Gateway
> will rever t to multicasting the stream immediately. When one or more wireless clients leave a group,
> and the Gateway determines that only a single wireless client is interested in the stream, it will once

> again unicast the stream.

 

INFO
Pas info pour IOS

 

REFERENCES
Page 158 http://broadband.motorola.com/consumers/products/7107-65-10NA/downloads/AdminHndbkV784-sku29_34.pdf
http://www.cisco.com/en/US/docs/ios/ipmulti/command/reference/imc_02.html

http://www.sadikhov.com/forum/index.php?/topic/186519-cisco-88xva-%26-8211%3B-part-5-vdsl-advanced-c...

http://www.ditc.eu/downloads/Multicast_Cisco_T-Home_IPTV.pdf

 

Modifié
20 Commentaires
Expert
2 de 21
3 de 21

Bonjour,

hum il sera très intéressant de voir les résultats de vos recherches et la solution pour y parvenir. je pense que nombreux sont les membres intéressés par votre sujet.  

Mon manque de connaissance dans le sujet ne vous apportera certainement pas une solution, mais peut-être quelques propositions à suivre, ou pas...

Il faudrait procéder par étape afin de savoir si le problème survient plus de la priorisation du QoS ou du protocole IGMP. A utiliser 802.1p avec User Priority 4 (High) pour le Multicast.

Si tu ne laisses que la Box sur le router as-tu toujours le même problème? Si oui alors se pencher plus sur la configuration du protocole IGMP. Si le problème ne survient plus alors plus se pencher sur la priorisation QoS.

Moi je te dis bonne chance, tiens-nous informé de l'évolution de tes recherches et peut-être pourrons nous t'apporter quelques lumières 😉

++

ImSoGooooood

____________________________________________________________

Pour que cette communauté soit plus conviviale, et pour remercier les membres de leur aide, merci d'être actif en acceptant les réponses comme solution et en distribuant des Kudos.
Contributor
4 de 21

 

Mon problème est que le flux Swisscom TV s'arrête après environ 10 seconde.

Il semble que la Swisscom TV établit d'abord un flux unicast pour afficher les 10

première secondes le temps d'obtenir le flux multicast.

 

Je pense que le problème n'est pas le QoS (j'ai testé ça rapidement) mais

plutot au niveau de la configuration multicast ou igmp.

 

J'ai trouvé ce lien qui en parle voir la page 5

http://www.ditc.eu/downloads/Multicast_Cisco_T-Home_IPTV.pdf

http://translate.google.com/ pour le traduire... en francais...

 

En faisant debug ip cef, j'ai vu qu'il est nécessaire d'avoir ip multicast-routing

pour router vers 224/4. Par contre, je pense qu'il faut que je trouve l'IP

PIM RP (Rendezvous Point) utilisé par la Swisscom TV pour ajouter la 

ligne ip pim rp-address / ip igmp helper-address.

 

@+++

 

Guy

 

 

5 de 21

Salut,

10 secondes alors effectivement c’est un problème Multicast. Je pense toutefois que QoS va rester un problème sous-jacent, mais génère en général plus de Freeze que des blocages de l’image. Mais un mal après l’autre… 😉

Selon le pdf, pour connaître l’adresse IP pim rp-adress, il faut bloquer toutes les requêtes IP en créant une entrée dans l’access-control-list comme suit :

 

!

ip access-list extended PUBLIC-VDSL

 999 deny ip any any log

!

 

De cette façon dans le journal Log, tu devrais pouvoir trouver une annonce de blocage de l’adresse IP igmp. P.ex. list PUBLIC-VDSL denied igmp xxx.x.xxx.xx (là voila cette fameuse pim rp-adress).

Ensuite suivre point 1 et 2 de la page 3.

Quelques précisions complémentaires que j’ai retrouvées au fond d’un dossier…

Igmp doit supporter multihoming

Igmp Snooping on

Igmp robustness 2

Igmp query.intvl 125

Igmp version 3

Igmp fast-leave on

Igmp forwarding on

 

Vivement la suite 😉

++

ImSoGooooood

____________________________________________________________

Pour que cette communauté soit plus conviviale, et pour remercier les membres de leur aide, merci d'être actif en acceptant les réponses comme solution et en distribuant des Kudos.
Contributor
6 de 21

Salut,

 

Avant tout, il semblerait que IP RP(Rendezvous point) que

je cherchais chez Swisscom est ...      1.1.1.1 !!!

 

> 10 secondes alors effectivement c’est un problème Multicast.

 

En effet, c'était bien un problème de multicast et de igmp helper

 

> Je pense toutefois que QoS va rester un problème sous-jacent,

> mais génère en général plus de Freeze que des blocages de l’image.

> Mais un mal après l’autre… :smileywink:

 

Oui, maintenant ca freeze après environ 30-90 seconds donc

maintenant je peux regarder au niveau du QoS

 

> Selon le pdf, pour connaître l’adresse IP pim rp-adress,

> il faut bloquer toutes les requêtes IP en créant une entrée dans l’access-control-list comme suit :

> !

> ip access-list extended PUBLIC-VDSL

> 999 deny ip any any log

> !

>

> De cette façon dans le journal Log, tu devrais pouvoir trouver une annonce de blocage de l’adresse IP igmp. > P.ex. list PUBLIC-VDSL denied igmp xxx.x.xxx.xx (là voila cette fameuse pim rp-adress).

> Ensuite suivre point 1 et 2 de la page 3.

 

J'avais pas compris que c'était une ACL inbound sur le WAN.

 

> Quelques précisions complémentaires que j’ai retrouvées au fond d’un dossier…

 

Il doit etre digne d'un dossier X-Files 😉

 

> Igmp doit supporter multihoming

> Igmp robustness 2

> Igmp forwarding on

 

Tu connais les commande IOS correspondantes au multihoming, robustness et forwarding ?

 

> Vivement la suite :smileywink:

 

...

 

REFERENCES
http://www.ditc.eu/downloads/Multicast_Cisco_T-Home_IPTV.pdf
http://www.cisco.com/en/US/docs/ios/ipmulti/command/reference/imc_02.html
http://packetlife.net/blog/2010/feb/5/ripe-plays-with-1-0-0-0-network-apnic-allocation/ (fun with 1.1.1.1)

 

DEBUG

 

# INTERNET-TO-WAN IGMP Helper-Address (Rendezvous Point)
permit igmp host 1.1.1.1 any
permit icmp host 1.1.1.1 any
%SEC-6-IPACCESSLOGSP: list INTERNET-TO-WAN denied igmp 1.1.1.1 -> 224.0.0.1 (0), 1 packet

 

# WAN-TO-INTERNET IGMP Helper-Address (Rendezvous Point)
permit igmp any host 1.1.1.1
permit icmp any host 1.1.1.1
%SEC-6-IPACCESSLOGRP: list WAN-TO-INTERNET denied pim 172.16.78.1 -> 1.1.1.1, 1 packet

 

# INTERNET-TO-WAN UDP TV FLOW
permit udp any 224.0.0.0 15.255.255.255
%SEC-6-IPACCESSLOGP: list INTERNET-TO-WAN denied udp 195.186.40.122(1383) -> 239.186.36.23(10000), 1 packet

 

# LAN-TO-WAN NTP
permit udp any any eq 123
%SEC-6-IPACCESSLOGP: list LAN-TO-WAN denied udp 172.16.78.128(1032) (Vlan1 001c.eaae.ba0d) -> 195.186.150.230(123), 1 packet

 

# LAN-TO-WAN IGMP
permit igmp any 224.0.0.0 15.255.255.255
%SEC-6-IPACCESSLOGSP: list LAN-TO-WAN denied igmp 172.16.78.128 (Vlan1 001c.eaae.ba0d) -> 239.186.42.45 (22), 1 packet

 

# LAN-TO-WAN Microsoft SSDP Enables discovery of UPnP devices
permit udp any 224.0.0.0 15.255.255.255
%SEC-6-IPACCESSLOGP: list LAN-TO-WAN denied udp 172.16.78.138(4996) (Vlan1 0006.7808.09e1) -> 239.255.255.250(1900), 20 packets

 

# WAN-TO-INTERNET IGMP ???
permit udp any any gt 40000
%SEC-6-IPACCESSLOGP: list WAN-TO-INTERNET denied udp 85.4.244.43(2268) -> 195.186.147.91(47806), 1 packet

 

# LAN-TO-WAN WWW
permit tcp any any eq 80
%SEC-6-IPACCESSLOGP: list LAN-TO-WAN denied tcp 172.16.78.128(2298) (Vlan1 001c.eaae.ba0d) -> 195.186.132.21(80), 1 packet

 

@++

 

lordbaco

Modifié
7 de 21

salut,

 

je n'ai pas bcp de temps pour analyser ces données, mais au premier coup d'oeil je dirai que ce n'est pas possible que lP Rp soit 1.1.1.1!

 

le cmd sont normalmement

set igmp snooping on

set igmp robustness 2

set igmp query-intvl 125

set igmp query-response-intvl 100

set igmp version 3

set igmp fast-leave on

set igmp log-enable off

set igmp default-forwarding-allow on

set ip igmp-forwarding on

 

Faut pas que tu n'en dormes pas du week-end 😉

Peut-être d'autres membres plus spécialisés que moi pourraient t'aider?

++

ImSoGooooood

____________________________________________________________

Pour que cette communauté soit plus conviviale, et pour remercier les membres de leur aide, merci d'être actif en acceptant les réponses comme solution et en distribuant des Kudos.
Contributor
8 de 21

 

J'ai réussi la Swisscom TV fonctionne

sans coupure sur mon Cisco 887VA-W  

    => enfin !!!

 

 

Le secret ou plutot les secrets ?

 

 

  • L'IP RP (Rendezvous Point) chez Swisscom est bel et bien 1.1.1.1 !!!
    sans IP RP le flux s'arrete après environ 10 secondes (flux unicast avant multicast) 
  • ip igmp query-interval 125 ou 60 ou 30 ne fonctionne pas  (set igmp query-intvl 125)
  • ip igmp query-interval 12 fonctionne -- default Cisco (60) et Motorola (125)
    sans une valeur aussi basse le flux s'arrete avant 60 seconds ! 
  • Les timeout chez Motorola sont en deci-secondes tandis et chez Cisco en milli-secondes ! 

 

> je n'ai pas bcp de temps pour analyser ces données,

> mais au premier coup d'oeil je dirai que ce n'est pas possible que lP Rp soit 1.1.1.1!

 

Oui, pour moi je suis persuadé que IP RP Rendezvous Point est bien 1.1.1.1

chez Swisscom. Ce qui est un choix discutable vu que c'est un block routable

qui a été enlevé de la boggus list par IANA.. 

 

Au niveau du Cisco, j'ai obtenu ceci :

%SEC-6-IPACCESSLOGSP: list INTERNET-TO-WAN denied igmp 1.1.1.1 -> 224.0.0.1 (0), 1 packet

 

Au niveau du Motorola Netopia 3397GP et après avoir activé le mode bridge/router

et le mode log igmp ... bingo encore 1.1.1.1 !!!

 

Netopia-3000/31499700> config

Config Mode v1.3
Netopia-3000/31499700 (top)>> set igmp log-enable on
Netopia-3000/31499700 (top)>> save
WARNING: Concurrent-bridging/routing has been turned ON!


Configuration data saved.
Netopia-3000/31499700 (top)>> top
Netopia-3000/31499700 (top)>> cd ..
Error: Command ('cd') not found

Netopia-3000/31499700 (top)>> exit

Netopia-3000/31499700> show log

 

Message Log:
2/19/12 09:10:21 AM L3 TR-069: Closing connection on auth fail
2/19/12 09:10:21 AM L3 SSL: Closing Connection: rms.bluewin.ch
2/19/12 09:10:25 AM L3 IGMP: [ENWAN1] Received General Query host: 1.1.1.1 max-reponse-time 2 s
2/19/12 09:10:25 AM L3 IGMP: [en0] Received General Query host: 1.1.1.1 max-reponse-time 2 s
2/19/12 09:10:26 AM L3 IGMP: [ENWAN1] Sending v2-Report group: 239.255.255.250
2/19/12 09:10:26 AM L3 IGMP: [ENWAN1] Sending v2-Report group: 224.0.0.251
2/19/12 09:10:26 AM L3 IGMP: [ENWAN1] Sending v2-Report group: 239.186.63.6
2/19/12 09:10:26 AM L3 IGMP: [en0] Received v2-Report group: 239.186.63.6 host: 172.16.78.128
2/19/12 09:10:26 AM L3 IGMP: [en0] Received v2-Report group: 239.255.255.250 host: 172.16.78.128
2/19/12 09:10:27 AM L3 IGMP: [en0] Received v2-Report group: 224.0.0.251 host: 172.16.78.2
2/19/12 09:10:36 AM L3 IGMP: [ENWAN1] Received General Query host: 1.1.1.1 max-reponse-time 2 s
2/19/12 09:10:36 AM L3 IGMP: [en0] Received General Query host: 1.1.1.1 max-reponse-time 2 s
2/19/12 09:10:36 AM L3 IGMP: [ENWAN1] Sending v2-Report group: 239.186.63.6

Netopia-3000/31499700>

 

Meme si 1.0.0.0 a été assigné à APNIC il semble que Swisscom l'utilise en interne.

Tu peux d'ailleur pinger 1.1.1.1 depuis ta connexion Swisscom !

 

ping -c 1 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: icmp_seq=0 ttl=126 time=19.913 ms

--- 1.1.1.1 ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 19.913/19.913/19.913/0.000 ms

 

1.1.1.1 n'arrive clairement pas chez au USA avec 19ms !

 

traceroute 1.1.1.1
traceroute to 1.1.1.1 (1.1.1.1), 64 hops max, 52 byte packets
1 * 172.16.78.1 (172.16.78.1) 0.591 ms 0.601 ms
2 1.1.1.1 (1.1.1.1) 19.706 ms 19.553 ms 19.902 ms

 

Voir aussi cet article 🙂

http://packetlife.net/blog/2010/feb/5/ripe-plays-with-1-0-0-0-network-apnic-allocation/

 

inetnum: 1.1.1.0 - 1.1.1.255
netname: Debogon-prefix
descr: APNIC Debogon Project
descr: APNIC Pty Ltd
country: AU
admin-c: AR302-AP
tech-c: AR302-AP
mnt-by: APNIC-HM
mnt-routes: MAINT-AU-APNIC-GM85-AP
mnt-irt: IRT-APNICRANDNET-AU
status: ASSIGNED PORTABLE
changed: hm-changed@apnic.net 20110922
source: APNIC

 

> le cmd sont normalmement

> set igmp snooping on

> set igmp robustness 2

> set igmp query-intvl 125

> set igmp query-response-intvl 100

> set igmp version 3

> set igmp fast-leave on

> set igmp log-enable off

> set igmp default-forwarding-allow on

> set ip igmp-forwarding on

 

Voici la configuration qui fonctionne avec la Swisscom TV et Swisscom VDSL2

 

!
service internal
!
memory-size iomem 20
!
controller VDSL 0
 operating mode vdsl2
 modem co5
!
ip pim rp-address 1.1.1.1
!
ip multicast-routing
!
ip igmp snooping
!
interface Ethernet0
 ip dhcp client broadcast-flag clear
 ip address dhcp
 no ip virtual-reassembly in
 no ip route-cache

 no ip mfib cef input
 no ip mfib cef output

 ip pim sparse-mode

 ip igmp query-interval 10
 ip igmp querier-timeout 60
 ip igmp query-max-response-time 8

 ip igmp last-member-query-interval 1000
 ip igmp last-member-query-count 2
 ip igmp version 3
 ip igmp proxy-service
 load-interval 30
 auto discovery qos
 service-policy output QoS-Ethernet0
!
interface Vlan1
 ip address 172.16.78.1 255.255.255.0
 ip nat inside
 no ip virtual-reassembly in
 ip tcp adjust-mss 1452
 ip pim sparse-mode

 ip igmp query-interval 10
 ip igmp querier-timeout 60
 ip igmp query-max-response-time 8

 ip igmp last-member-query-interval 1000
 ip igmp last-member-query-count 2
 ip igmp version 3
 ip igmp proxy-service
 ip igmp helper-address 1.1.1.1
 ip igmp explicit-tracking
 load-interval 30
 auto discovery qos
 service-policy output QoS-Vlan1
!
class-map match-any QoS-Video
 match protocol rtp video
 match ip dscp af41
!
policy-map QoS-Ethernet0
 class class-default
 fair-queue
!
policy-map QoS-Vlan1
 class QoS-Video
  set dscp af41
 class class-default
  set dscp default
!
ip forward-protocol nd
!
scheduler allocate 20000 1000
!
end

 

> Faut pas que tu n'en dormes pas du week-end :smileywink:

> Peut-être d'autres membres plus spécialisés que moi pourraient t'aider?

 

Je pense que c'est bon maintenant.

Merci encore de ton aide !

 

Faut dire que j'ai été dégouté pendant trois jours de repasser sur mon vieux

Motorola Netopia de 2008... pour que ma ptite famille regarde la Swisscom TV...

 

C'était étrange quand même qu'en connectant uniquement la Swisscom TV

sur le Cisco 887VA, le fux Swisscom TV se fige... C'est pas la QoS qui allait aider

car avec 22Mbps/5Mps c'est suffisant pour un flux de 12Mbps (HD) ou 5Mbps (SD)

 

DETAILS TECHNIQUES

 

> set igmp query-intvl 125
>
> Query Interval– the amount of time in seconds between IGMP General Query messages sent by the
> querier gateway. The default query interval is 125 seconds

 

C'ETAIT L'ORGINE DU STOP DE L'IMAGE APRES MOINS DE 60 SECONDES
(LE STOP APRES 10 SEC A ETE FIXE AVEC L'ADRESSE RendezvousPoint => 1.1.1.1)

 

CONFIG
ip igmp query-interval 10

 

CISCO
ip igmp query-interval ?
<1-18000> Query interval in seconds

 

INFO
Autant 125 (Motorola/RFC default) et 60 (Cisco default) et meme 30 ne fonctionne pas bien avec Swisscom TV.
Il faut ip igmp query-interval 12 !!!

 

<< Note : We recommend that you use the default IGMP query interval and timeout period.
The Cisco IOS software uses a default IGMP query interval of 60 seconds,
which is different from the RFC standard default of 125 seconds.
Using a lower default IGMP query interval of 60 seconds allows routers
to stop forwarding traffic faster when a member crashes without sending
leaves (in IGMPv2 or IGMPv3 environment) >>

 

> set igmp last-member-query-intvl 10
>
> Sets the last member quer y inter val: the amount of time in tenths of a second that the IGMP gateway
> waits to receive a response to a Group-Specific Quer y message. The last member quer y inter val is also
> the amount of time in seconds between successive Group-Specific Quer y messages.
> The default is 1 second (10 deci-seconds)

 

CONFIG

ip igmp last-member-query-interval 1000

 

CISCO
ip igmp last-member-query-interval ?
<100-25500> Last member query interval in milliseconds

 

INFO
Il faut faire très attention les valeurs Motorola sont en deci-seconds tandis que Cisco en millo-seconds !!!

 

> set igmp last-member-query-count 2

 

CONFIG
ip igmp last-member-query-count 2

 

CISCO
ip igmp last-member-query-count ?

<1-7> Last member query count

 

> set igmp query-response-intvl 100
>
> Sets the query-response interval range: from 5 deci-seconds (tenths of a second) – 255 deci-seconds.
> The default is 100 deci-seconds.
>
> Last Member Query Interval – the amount of time in tenths of a second that the IGMP gateway
> waits to receive a response to a Group-Specific Query message. The last member query interval is
> also the amount of time in seconds between successive Group-Specific Query messages. The
> default last member query interval is 1 second (10 deci-seconds).

 

INFO
pas info j'ai cru que c'était ip igmp last-member-query-interval ??

 

> set igmp version 3

 

CONFIG

ip igmp version 3

 

> set igmp snooping on

 

CONFIG
ip igmp snooping

 

INFO
et pas ip igmp snooping vlan 1

 

> set igmp default-forwarding-allow on

 

ip multicast-routing

 

> set igmp fast-leave on
>
> Fast Leave – set to off by default, fast leave enables a non-standard expedited leave mechanism.
> The querier keeps track of which client is requesting which channel by IP address. When a leave
> message is received, the querier can check its internal table to see if there are any more clients on
> this group. If there are none, it immediately sends an IGMP leave message to the upstream querier.

 

INFO
"ip igmp snooping fast-leave" pas dispo sur mon IOS

 

> set igmp robustness 2
>
> Robustness – a way of indicating how sensitive to lost packets the network is.
> IGMP can recover from robustness minus 1 lost IGMP packet. The default value is 2.

 

INFO
Pas dispo sur ma version IOS

 

> set igmp unsol-report-intvl 10
>
> Sets the unsolicited report interval: the amount of time in seconds between repetitions of a particular
> computer’s initial report of membership in a group. The default is 10 seconds

 

INFO
Pas info sur une commande similaire sur IOS


> set igmp wireless-m2u on
>
> This command allows you enable or disable wireless multicast-to-unicast if igmp snooping is set to on.
>
> Wireless Multicast to Unicast conversion – Only available if IGMP Snooping is enabled. If set to
> on, the Gateway replaces the multicast MAC-address with the physical MAC-address of the wireless
> client. If there is more than one wireless client interested in the same multicast group, the Gateway
> will rever t to multicasting the stream immediately. When one or more wireless clients leave a group,
> and the Gateway determines that only a single wireless client is interested in the stream, it will once

> again unicast the stream.

 

INFO
Pas info pour IOS

 

REFERENCES
Page 158 http://broadband.motorola.com/consumers/products/7107-65-10NA/downloads/AdminHndbkV784-sku29_34.pdf
http://www.cisco.com/en/US/docs/ios/ipmulti/command/reference/imc_02.html

http://www.sadikhov.com/forum/index.php?/topic/186519-cisco-88xva-%26-8211%3B-part-5-vdsl-advanced-c...

http://www.ditc.eu/downloads/Multicast_Cisco_T-Home_IPTV.pdf

 

Modifié
Highlighted
9 de 21

Salut lordbaco,

 

Alors là que dire à part BRAVO et belle persévérance!

 

Je pense que ton post va faire des adeptes... si je pouvais, ca serait bien volontiers 10 kudos 😉

 

Merci de l'info et pour les autres qui sont intéressés, go acheter ce router et donner un Kudos à lordbaco.

++

ImSoGooooood

____________________________________________________________

Pour que cette communauté soit plus conviviale, et pour remercier les membres de leur aide, merci d'être actif en acceptant les réponses comme solution et en distribuant des Kudos.
Contributor
10 de 21

 

N.B. copy run start (write memory) fait saccader la Swisscom TV 😉

 

Après une journée d'enregistrement HD, SD et de TV ce soir

la TV est toujours stable. Parfois après 1-2 heures, j'ai

1 sec de désyncro du flux (comme default d'encodage).

 

J'ai donc testé encore un ajustement de 12 à 10.

Pour réduire de query-interval 12 à 10 il faut aussi

réduire query-max-response-time de 10 à 8.

 

Il faut se méfier si on test des valeurs car pendant le

stream multicast video la Swisscom TV buffer le fiux

(30-40 sec ?). Par example, j'ai testé à nouveau 125

de query-interval et 250 de querier-timeout et le

fux a à nouveau sacadé et s'est arrêté après 30

seconds... 

 

Et hop je suis vite revenu à une valeur d'environ 10

pour le query-interval et ca refonctionne parfaitement !

(parfait pour continuer à voir top chef)

 

 ip igmp query-interval 10
 ip igmp querier-timeout 60
 ip igmp query-max-response-time 8

 

J'ai aussi remarqué qu'il faut mieux manuellement configurer

querier-timeout car sinon la valeur n'est pas cohérente entre

l'interface Ethernet0 (WAN) et Vlan0 (LAN)

 

AVANT

 

show ip igmp interface

 

Ethernet0 is up, line protocol is up

 ...

 IGMP query interval is 10 seconds
 IGMP configured query interval is 10 seconds
 IGMP querier timeout is 100 seconds
 IGMP configured querier timeout is 100 seconds
 IGMP max query response time is 10 seconds
 Last member query count is 2
 Last member query response interval is 1000 ms

 ...

 IGMP querying router is 1.1.1.1
 No multicast groups joined by this system

 

Vlan1 is up, line protocol is up
 ...

 IGMP query interval is 12 seconds
 IGMP configured query interval is 12 seconds
 IGMP querier timeout is 24 seconds
 IGMP configured querier timeout is 24 seconds
 IGMP max query response time is 10 seconds
 Last member query count is 2
 Last member query response interval is 1000 ms
 ...

IGMP helper address is 1.1.1.1
 Multicast groups joined by this system (number of users): 224.0.1.40(1)

 

APRES

 

show ip igmp interface

 

Ethernet0 is up, line protocol is up
 ...

 IGMP query interval is 10 seconds
 IGMP configured query interval is 10 seconds
 IGMP querier timeout is 60 seconds
 IGMP configured querier timeout is 60 seconds
 IGMP max query response time is 8 seconds
 Last member query count is 2
 Last member query response interval is 1000 ms

 ...

 IGMP querying router is 1.1.1.1

 

Vlan1 is up, line protocol is up

 ...

 IGMP query interval is 10 seconds
 IGMP configured query interval is 10 seconds
 IGMP querier timeout is 60 seconds
 IGMP configured querier timeout is 60 seconds
 IGMP max query response time is 8 seconds
 Last member query count is 2
 Last member query response interval is 1000 ms
 ...

 IGMP helper address is 1.1.1.1
 Multicast groups joined by this system (number of users): 224.0.1.40(1)

 

P.S. Sinon mes collègues ont été épaté d'apprendre que 1.1.1.1 ping

depuis chez eux mais pas en dehors du réseau de Swisscom xDSL 😉

 

Modifié
Contributor
11 de 21

Hello, 

Tout d'abord merci pour la configuration, j'ai pas encore pu tester mais j'ai le même router que toi.

J'ai quelque petite question concernant le router, tu as la version 887Va-W ?

Moi j'ai cette version et je n'arrive pas à pouvoir configuration la mode AP via telnet/ssh.

D'autre part, as-tu aussi l'interface ATM0 et si oui peux-tu poster ta config ?

J'ai bien accès au router via telnet/ssh mais quand je tape service-module wlan-ap0 session j'obtiens un : 

 

router-1#service-module wlan-ap 0 session
% telnet connections not permitted from this terminal

 

As-tu une idée ?

Voilà ma config :

 

Current configuration : 3281 bytes
!
! Last configuration change at 21:43:11 UTC Fri May 18 2012 by jon
! NVRAM config last updated at 21:46:05 UTC Fri May 18 2012 by jon
! NVRAM config last updated at 21:46:05 UTC Fri May 18 2012 by jon
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router-1
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 xxxx
enable password xxxx
!
no aaa new-model
crypto pki token default removal timeout 0
!
!
ip source-route
ip cef
!
!
!
ip dhcp excluded-address 192.168.2.254
ip dhcp excluded-address 192.168.2.0 192.168.2.100
!
!
no ip domain lookup
ip domain name jbtech.local
ip name-server 195.186.1.162
ip name-server 195.186.4.162
ip multicast-routing
no ipv6 cef
!
!
license udi pid xsXXXxXXxXXx
!
!
username XxXX privilege 15 password 0 XXXXX
!
!
!
!
controller VDSL 0
operating mode vdsl2
modem co5
!
ip ssh version 2
!
class-map match-any Qos-Video
match protocol rtp video
match ip dscp af41
!
!
policy-map Qos-Ethernet0
class class-default
fair-queue
policy-map Qos-Vlan1
class Qos-Video
set dscp af41
class class-default
set dscp default
!
!
!
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface Ethernet0
ip dhcp client broadcast-flag clear
ip address dhcp
ip pim sparse-mode
no ip mfib cef input
no ip mfib cef output
ip nat inside
no ip virtual-reassembly in
no ip route-cache
ip igmp query-max-response-time 8
ip igmp version 3
ip igmp query-interval 10
ip igmp querier-timeout 60
ip igmp proxy-service
load-interval 30
service-policy output Qos-Ethernet0
!
interface FastEthernet0
switchport mode trunk
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Wlan-GigabitEthernet0
description Internal switch interface connecting to the embedded AP
no ip address
!
interface wlan-ap0
description Embedded Service module interface to manage the embedded AP
ip unnumbered Vlan1
!
interface Vlan1
ip address 192.168.2.254 255.255.255.0
ip pim sparse-mode
ip nat inside
no ip virtual-reassembly in
ip tcp adjust-mss 1452
ip igmp helper-address 1.1.1.1
ip igmp query-max-response-time 8
ip igmp version 3
ip igmp explicit-tracking
ip igmp query-interval 10
ip igmp querier-timeout 60
ip igmp proxy-service
load-interval 30
service-policy output Qos-Vlan1
!
interface Vlan20
description Vlan Wireless
ip address 192.168.20.1 255.255.255.0
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip pim rp-address 1.1.1.1
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit 192.168.2.254
!
!
!
!
snmp-server community public RO
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
privilege level 15
password xxxxxxxxxxxx
login local
transport input ssh
transport output ssh
!
scheduler allocate 20000 1000
end

 

D'avance merci et bonne soirée.

Jon

Expert
12 de 21

Pour samzor

Les présents échanges ont été mis en route par lordbaco, et ce dernier, ayant obtenu les réponses souhaitées, a conclu par un VU vert. Ainsi, samzor aurait de meilleures chances d'obtenir une réponse de lordbaco, avec une des deux méthodes suivantes:

- message privé à lordbaco

- mise en route d'un nouvel échange

Contributor
13 de 21

Hello, 

 

> Tout d'abord merci pour la configuration, j'ai pas encore pu tester mais j'ai le même router que toi.

> J'ai quelque petite question concernant le router, tu as la version 887Va-W ?

 

Oui, j'ai le C887VA-W-E-K9

 

> Moi j'ai cette version et je n'arrive pas à pouvoir configuration la mode AP via telnet/ssh.

 

Le module AP est un router séparé avec son propre IOS (mais inclus dans la même boite)

que tu peux accéder avec la commande "service-module wlan-ap 0 session"


je te conseille d'ajouter l'alias suivant : 

config terminal

alias exec dot11radio service-module wlan-ap 0 session"

end

copy run start

dot11radio


comme ca tu peux faire "dot11radio" sur le pompt pour accéder au router AP.

 

> D'autre part, as-tu aussi l'interface ATM0 et si oui peux-tu poster ta config ?

 

ATM0 est pas utile pour Swisscom seulement Ethernet0

 

!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Ethernet0
 ip address dhcp

!

controller VDSL 0
 operating mode vdsl2
 modem co5

!

 

> J'ai bien accès au router via telnet/ssh mais quand je tape service-module wlan-ap0 session j'obtiens un : 

>

> router-1#service-module wlan-ap 0 session
> % telnet connections not permitted from this terminal

> As-tu une idée ?

 

Il est possible que ton module WiFI (AP) n'est pas correctement configuré

pour y accéder via "service-module wlan-ap 0 session"

 

Je te conseille de lancer le Wizard Cisco Configuration Professional Express

(Cisco CP Express) via l'interface web et de configurer AP avec une

IP dédié (autre celle du router genre .1 pour router, .254 pour routerAP)

après tu peux désactiver l'interface web.

 

ip http server
ip http access-class 42
ip http authentication local
ip http secure-server

!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 login local
line aux 0
 transport input all
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 stopbits 1
line vty 0 4
 access-class 42 in
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 login local
 transport input ssh
!

access-list 42 permit 192.168.1.0 0.0.0.255

 

Sinon tu peux aussi essayer via cisco-config-pro-k9-pkg-2_6-en.zip sous Windows

http://www.cisco.com/cisco/software/release.html?mdfid=281795035&softwareid=282159854&release=2.6&re...

 

P.S. je suis pas fan de Wizard (gui for lamers) mais pour faire la config de base c'est pas mal

après tu peux t'en inspirer pour la configuration finale...


Modifié
Novice
14 de 21

Hello, j'ai le même router mais impossible de faire en sorte que cela fonctionne est-ce possible d'avoir un exemple de config ?

 

depuis le router je ping sur internet mais depuis mon laptop impossible il s'arrete au router, pour moi c'est un probleme de routage ou login. Quel est le mode de login ?

 

Merci Salutations

Contributor
15 de 21

Hello,

 

> depuis le router je ping sur internet mais depuis mon laptop impossible il s'arrete au router,

> pour moi c'est un probleme de routage ou login.

 

Je pense que c'est un problème de NAT du range privé.

 

> Quel est le mode de login ?

 

Il y a pas de login (c'est pas du PPPoE mais simplement du DHCP depuis Ethernet0).

 

> j'ai le même router mais impossible de faire en sorte que cela fonctionne

> est-ce possible d'avoir un exemple de config ?

 

!
multilink bundle-name authenticated
!
controller VDSL 0
 operating mode vdsl2
 sync mode itu
 modem co5
 description Swisscom Infinity VDSL2 20Mbps/5Mbps
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Ethernet0
 ip dhcp client broadcast-flag clear
 ip address dhcp
 no ip redirects
 ip pim sparse-mode
 ip nat outside
 no ip virtual-reassembly in
 no ip route-cache
 ip igmp version 3
 ip igmp query-interval 12
 ip igmp proxy-service
 load-interval 30
!
interface FastEthernet0
 no ip address
 load-interval 30
 duplex full
 speed 100
 spanning-tree portfast
!
interface Wlan-GigabitEthernet0
 description Internal switch interface connecting to the embedded AP
 no ip address
 load-interval 30
!
interface wlan-ap0
 description Embedded Service module interface to manage the embedded AP
 ip unnumbered Vlan1
 load-interval 30
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 ip address 172.16.78.1 255.255.255.0
 ip pim sparse-mode
 ip nat inside
 no ip virtual-reassembly in
 ip tcp adjust-mss 1452
 ip igmp helper-address 1.1.1.1
 ip igmp version 3
 ip igmp explicit-tracking
 ip igmp query-interval 12
 ip igmp proxy-service
 load-interval 30
!
ip forward-protocol nd
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip dns view default
 domain timeout 1
 domain retry 1
 domain name-server interface Ethernet0
ip dns server
ip pim rp-address 1.1.1.1
ip nat inside source list 23 interface Ethernet0 overload
!
access-list 23 permit 172.16.78.0 0.0.0.255
no cdp run
!
control-plane
!
alias exec dot11radio service-module wlan-ap 0 session
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 stopbits 1
line vty 0 4
 access-class 23 in
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 login local
 transport input ssh
!
scheduler allocate 20000 1000
end

 

Meilleures salutations

 

Guy

Novice
16 de 21

Merci je vais tester... mais encore une question, on utilise pas de dialer  avec mon login et pass ? (ppp chap ou autre )

Contributor
17 de 21

Merci je vais tester... mais encore une question,

> on utilise pas de dialer  avec mon login et pass ? (ppp chap ou autre )

 

Non pas de dialer (pas de PPPoE), pas de login et pas de pass

juste DHCP pour avoir une IP publique sur Ethernet 0

 

Le fait que vous pouvez pinger 8.8.8.8 (Google DNS) depuis le router

c'est que la connection Internet fonctionne déjà donc il faut juste

du NAT pour que les IPs privés du LAN puisse utiliser l'IP public assigné

au Cisco.

 

Meilleures salutations

 

Guy

 

Novice
18 de 21

Re voilà je test, ping 8.8.8.8 depuis le router ->ok ping ping depuis le pc ->ok mais impossible d'afficher une page web.... voici ma config...

 

 

Router#sh run
Building configuration...

Current configuration : 2864 bytes
!
! Last configuration change at 14:15:45 UTC Tue Apr 9 2013 by admin
! NVRAM config last updated at 13:56:34 UTC Tue Apr 9 2013 by admin
! NVRAM config last updated at 13:56:34 UTC Tue Apr 9 2013 by admin
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
enable password cisco
!
no aaa new-model
!
memory-size iomem 10
crypto pki token default removal timeout 0
!         
!
ip source-route
!
!
!
!
ip dhcp pool lan0
 network 192.168.2.0 255.255.255.0
 dns-server 195.186.1.162 195.186.4.162
 default-router 192.168.2.1
!
!
ip cef
ip domain retry 1
ip domain timeout 1
no ip domain lookup
ip name-server 195.186.1.162
ip name-server 195.186.4.162
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO887VA-M-K9 sn FCZ1620C51U
license accept end user agreement
license boot module c880-data level advipservices
!
!
vtp mode transparent
username admin privilege 15 password 0 cisco
!
!
!
!
controller VDSL 0
 operating mode vdsl2
 sync mode itu
 description Swisscom Infinity VDSL2 20Mbps/5Mbps
!
!
!
!
!
!
!
!
interface Ethernet0
 ip dhcp client broadcast-flag clear
 ip address dhcp
 no ip redirects
 ip pim sparse-mode
 ip nat outside
 ip virtual-reassembly in
 no ip route-cache
 ip igmp version 3
 ip igmp query-interval 12
 ip igmp proxy-service
 load-interval 30
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 no ip address
 load-interval 30
 duplex full
 speed 100
 spanning-tree portfast
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
 duplex full
 speed 100
!
interface FastEthernet3
 no ip address
 duplex full
 speed 100
!
interface Vlan1
 description Swisscom Access
 ip address 192.168.2.1 255.255.255.0
 ip pim sparse-mode
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1452
 ip igmp helper-address 1.1.1.1
 ip igmp version 3
 ip igmp explicit-tracking
 ip igmp query-interval 12
 ip igmp proxy-service
 load-interval 30
!
ip forward-protocol nd
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip dns view default
 domain timeout 1
 domain retry 1
 domain name-server interface Ethernet0
 no dns forwarding
ip dns server
ip pim rp-address 1.1.1.1
ip nat inside source list 23 interface Ethernet0 overload
!
access-list 1 permit 192.168.2.1
no cdp run
!
!
!
!         
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 login local
line aux 0
line vty 0 4
 session-timeout 30
 access-class 55 in
 exec-timeout 30 0
 privilege level 15
 logging synchronous
 login local
 history size 32
 transport input telnet
 transport output none
 escape-character 3
!
end
          
Router#

Contributor
19 de 21

Je pense qu'il manque l'ACL 23 pour la règle de NAT fonctionne...

sinon tester en utilisant le DNS de Google au lieu de celui de Swisscom.

 

!
access-list 23 permit 192.168.2.0 0.0.0.255
!
ip nat inside source list 23 interface Ethernet0 overload
!
ip dhcp pool lan0
 network 192.168.2.0 255.255.255.0
 dns-server 8.8.8.8
 default-router 192.168.2.1
!

 

 

Novice
20 de 21

Ca fonctionne merci pour votre aide :smileyhappy:

 

Haut de page