cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED
  • The questioner has marked this post as solved.
  • Closed

Can't add new device - haserl CGI Error

Contributor
1 of 8

I have problems with my Netopia Modem/Router.

When I try to add a new device I get the following error:

 

haserl CGI Error

[string "/www/swissbox/cgi-bin/devices.ha"]:55: bad argument #2 to 'format' (string expected, got nil)

 

I already have added a few devices.

 

Model: Motorola Netopia 7640-47 VDSL Modem

Firmware: 9.0.10h2d8

 

Any idea how to fix that?

MOST HELPFUL ANSWER

Accepted Solutions
Highlighted
Contributor
8 of 8

Yes, I tried all this.

 

So I deleted all the entries and started from scratch. This worked fine until I had 16 entries - then I got the same error again. It looks like there is a limit of 16 items for this list.

 

I deleted one and was able to add one 🙂

 

Very bad error description.

7 Comments
Super User
2 of 8

adding via web browser?

Contributor
3 of 8

Yes, using Safari on a Mac (latest versions). The first few weeks it was working well, and I've already added a few devices, but now I get this error.

Expert
4 of 8

Hello

 

Which name did you enter?

Maybe any special characters?

 

Contributor
5 of 8

Nothing special 🙂

['apollo', 'pegasus', 'wind']

 

Is there a limit on how many devices can be added to the list?

Expert
6 of 8

I'm not sure how many devices you can add and if there is a limit but you could try to delete one and add that one that gave you the error 🙂

 

 

Super User
7 of 8

spulver wrote:

Yes, using Safari on a Mac (latest versions). The first few weeks it was working well, and I've already added a few devices, but now I get this error.


what are the steps you do in ordner to add the devices?

I'll try to reproduce that.


Alternative --> did you check with Firefox?

Highlighted
Contributor
8 of 8

Yes, I tried all this.

 

So I deleted all the entries and started from scratch. This worked fine until I had 16 entries - then I got the same error again. It looks like there is a limit of 16 items for this list.

 

I deleted one and was able to add one 🙂

 

Very bad error description.