abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 
Gelöst
  • Der Fragesteller hat diesen Beitrag als gelöst markiert.
  • Geschlossen

Anderes Verhalten der Internet-Box App unter R7

Highlighted
Contributor
1 von 5

Hallo zusammen,

 

Seit R7 auf der IBP verhält sich die Internet-Box App auf iOS anders.

 

Unter R6 lief die App einwandfrei. Ich habe die IBP mit deaktiviertem DHCP im Einsatz, DHCP und DNS läuft auf dem OSX Server. Die DHCP Clients erhalten die DNS Adresse des Servers, der DNS Server hat eine Weiterleitung zur IBP.

 

Nun mit R7 auf der IBP verlangt die Internet-Box App, ich solle mich mit dem WLAN der IBP verbinden, was eigentlich schon der Fall ist, ich habe nur diesen AP. Die Icons in der App sind alle grau.

 

Nach einigen Versuchen zeigte sich, dass auf dem iOS Device der Eintrag des primären DNS Servers die IP der  IBP stehen muss. Bereits als sekundärer DNS Eintrag funktioniert die App nicht mehr, wie auch meine Konfig oben nicht. 

Verwendet man den DHCP Server der IBP hat man das Problem nicht, da der primäre DNS Eintrag auf die IP der IBP lautet.

 

Bug oder Feature? 

 

Gruess Roli

HILFREICHSTE ANTWORT

Akzeptierte Lösungen
Contributor
4 von 5

Danke @Tux0ne für den Tipp mit dem DNS Eintrag.

Ich habe eine neue primäre Zone "home" angelegt um dann einen A Eintrag für internetbox.home machen zu können. Weiter habe ich einen CNAME Eintrag von internetbox.b*****t.ch auf internetbox.home eingefügt. Die Such-Domains sind home und b*****t.ch. Jetzt wird auch http://internetbox ohne Suffix aufgelöst.

 

Rolis-MacBook:~ Roli$ host -a internetbox
Trying "internetbox.home"
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35048
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;internetbox.home.		IN	ANY

;; ANSWER SECTION:
internetbox.home.	10800	IN	A	192.168.5.1

;; AUTHORITY SECTION:
home.			10800	IN	NS	server.b*****t.ch.

;; ADDITIONAL SECTION:
server.b*****t.ch.	10800	IN	A	192.168.5.10

Received 100 bytes from 192.168.5.10#53 in 0 ms

Mit diesen Änderungen funktioniert die App mit meinem DNS Server bis auf den Speedtest.

Der Speedtest verweigert die Arbeit mit der selben Meldung wie im Web GUI der IBP:

 

Speedtest k.F..png

 

Die DNS Konfiguration in der IBP steht auf automatisch, also 

195.186.4.162 und 195.186.1.162

 

 

 

 

 

 

Die Lösung ist, dass der Applikationsteil eine eigene IP Adresse hat (am besten Fix vergeben), und auf den Namen "internetbox-nas.home" lautet. So habe ich im DNS die selben Einträge gemacht wie für "internetbox.home"; der Speedtest funktioniert.

 

Ich könnte mir vorstellen, dass unter R6 die mDNS Funktionalität von OSX die Namesauflösung gewährleistet hat, was jetzt unter R7 nicht mehr geht. 

 

Gruess

Roli

 

4 Kommentare
Super User
2 von 5

Afaik kommt bald eine an R7 angepasste App - also noch etwas warten....

keep on rockin'
Super User
3 von 5

Funktioniert die Namensauflösung nach internetbox?

Sonst würde ich dazu im DNS Server einen Eintrag machen.


Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Selbstdeklaration

Contributor
4 von 5

Danke @Tux0ne für den Tipp mit dem DNS Eintrag.

Ich habe eine neue primäre Zone "home" angelegt um dann einen A Eintrag für internetbox.home machen zu können. Weiter habe ich einen CNAME Eintrag von internetbox.b*****t.ch auf internetbox.home eingefügt. Die Such-Domains sind home und b*****t.ch. Jetzt wird auch http://internetbox ohne Suffix aufgelöst.

 

Rolis-MacBook:~ Roli$ host -a internetbox
Trying "internetbox.home"
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35048
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;internetbox.home.		IN	ANY

;; ANSWER SECTION:
internetbox.home.	10800	IN	A	192.168.5.1

;; AUTHORITY SECTION:
home.			10800	IN	NS	server.b*****t.ch.

;; ADDITIONAL SECTION:
server.b*****t.ch.	10800	IN	A	192.168.5.10

Received 100 bytes from 192.168.5.10#53 in 0 ms

Mit diesen Änderungen funktioniert die App mit meinem DNS Server bis auf den Speedtest.

Der Speedtest verweigert die Arbeit mit der selben Meldung wie im Web GUI der IBP:

 

Speedtest k.F..png

 

Die DNS Konfiguration in der IBP steht auf automatisch, also 

195.186.4.162 und 195.186.1.162

 

 

 

 

 

 

Die Lösung ist, dass der Applikationsteil eine eigene IP Adresse hat (am besten Fix vergeben), und auf den Namen "internetbox-nas.home" lautet. So habe ich im DNS die selben Einträge gemacht wie für "internetbox.home"; der Speedtest funktioniert.

 

Ich könnte mir vorstellen, dass unter R6 die mDNS Funktionalität von OSX die Namesauflösung gewährleistet hat, was jetzt unter R7 nicht mehr geht. 

 

Gruess

Roli

 

Swisscom
5 von 5

Die angepasste App wäre im Store (5.0.1). Wäre spannend ob du das Problem damit immer noch hast. 

Home App Projektteam