abbrechen
Suchergebnisse werden angezeigt für 
Stattdessen suchen nach 
Meintest du: 
Gelöst
  • Der Fragesteller hat diesen Beitrag als gelöst markiert.
  • Geschlossen

AVM Fritzbox 7490 mit IP Weiterleitung

Contributor
1 von 32

Hallo Community

 

Nachdem ich schon vor einigen Wochen vor allem hier viel über die FritzBox und AllIP gelesen habe, habe ich den Schritt gewagt und die Umstellung auf SwisscomTV2.0 mit AllIP vollzogen.

 

Die Umstellung hat nach vielen Problemen und einigen Stunden offline letztlich doch geklappt, so dass nun SwisscomTV2.0, Internet und Telefonie einwandfrei laufen.

 

Folgende Konf. habe ich:

 

192.168.1.1 CG mit FW 6.12 (die aktuellste)

192.168.1.3 FB7490 mit FW 6.20 (auch die aktuellste für die CH)

 

dahinter habe ich zahlreiche Clients, alle im selben Subnetz.

 

Nun habe ich die IP-Weiterleitung vom CG auf die FB aktiviert. Komisch ist aber, dass der CG momentan gar nicht mehr sichtbar ist, wenn ich 192.168.1.1 wähle, findet der Browser nix, auch ein Ping wird nicht beantwortet.

 

Wenn ich den PC direkt mit dem CG verbinde, dann wird CG gefunden.

 

Der Grund für die IP-Weiterleitung ist einfach: Ich habe in meinem Netz verschiedene Dienste am Laufen, die ich von Aussen erreichen möchte. Z.B. habe ich auf meinem Web-Server (externes Hosting) ein Script, der mir von meiner internen Webcam ein Bild runterlädt und dann die Wetterdaten meiner Wetterstation in das Bild reinschreibt (siehe: http://www.rheintalwetter.ch/joomla/rheintalwetter/webcam.html)

 

Wie man sieht, steht die Sache seit gestern morgen... halt seit der Umstellung auf All-IP. Oder z.B. will ich auf mein NAS zugreifen von aussen, etc. Weil das alles in der FB konfiguriert ist, will ich nicht auf die FB verzichten (und auch wegen der Telefonie, ich habe 2 Fritz Systemtelefone, die ich sonst schrotten kann).

 

Meine Frage: Kann mir jemand genau sagen, wie ich CG und FB bezüglich Netz/Subnetz und de rIP-Weiterleitung genau konfigurieren muss? Ich habe mit Subnetzen wenig Ahnung und bin bisher mit allem, was ich probiert habe angestanden.

 

DHCP habe ich im CG zwischendurch auch mal ausgeschaltet, da mir der PC immer wieder eine IP vom CG zugeordnet bekam. Auch hat die FB niemals die öffentliche IP erhalten (sondern immer eine aus dem DHCP Bereich des CG), obwohl ich die Weiterleitung aktiviert hatte und auch FB und CG neu gestartet habe. Komisch ist einfach, dass meistens der CG, manchmal aber auch nur die FB nicht erreicht werden in meinem Netz... Ich habe viel gelesen und alles probiert. Aber bisher bin ich immer gescheitert. So kurz vor dem Ziel!

 

Danke für eure Tips!

HILFREICHSTE ANTWORT

Akzeptierte Lösungen
Super User
6 von 32

Ja das wird wohl das Problem gewesen sein.

 

Falls du mal Interesse hast nur noch die Fritzbox zu verwenden habe ich dir hier eine weiter Inspiration.

So einfach war es noch nie 😉 http://www.tuxone.ch/2015/01/swisscom-sip-zugangsdaten-auslesen.html

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

31 Kommentare
Super User
2 von 32

Nein bei der IP Weiterleitung macht es natürlich Sinn dass die beiden Router eben NICHT im selben Subnet sind 😉

http://www.tuxone.ch/2012/11/betriebsmodi-swisscom-centro-routers.html

 

Evtl wird die IP Weiterleitung ab heute Abend obsolet. Würde darauf zukommen.

#getbackyourvoipcontrol

 

Die Lehren aus dem ersten Maleur hast du ja hoffentlich gelernt. (Dazumals ja sogar ohne VoIP Credentials.)

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Contributor
3 von 32

Hehe, ich hätte schwören können, dass Du zu den Helfern gehören wirst. :smileywink:

Danke schon mal dafür.

 

Und auch das mit dem Seitenhieb zur FB FW6.05 war zu erwarten. :smileyfrustrated:

 

Na, dann warte ich mal ab bis heute abend. Bin ja gespannt! Habe heute eh keine Zeit mehr, einen Abend Offline reicht für meine Familie :smileysurprised:

 

Verstehe ich das richtig, dass ich somit den CG einfach aus dem Netz 192.168.1.x rausnehmen muss z.B. auf 192.168.178.1? Und dann, wie reicht der CG dann die IP an die FB weiter? Kann der CG die IP ohne weitere Konfiguration in das Subnet der FB auf 192.168.1.3 weiterreichen? Ich meine, dass ich das gestern auch mal probiert habe. Danach ging aber gar nix mehr und ich musste die FB sogar mit einem Recovery Image neu aufspielen, weil die Obefläche nicht mehr erreichbar war. Auch den CG musste ich reseten (10 Sek. auf den Reset gedrückt). Danach konnte ich nach und nach alles wieder so weit in Betrieb nehmen.

Super User
4 von 32

Den Centro könnte man in seinen Standard Netz belassen. Schlau ist das nicht unbedingt. Wird man in Zukunft schon noch merken 🙂 Du kannst diesem Netz eine IP nach Gusto geben. zB. 192.168.66.0/24

 

Die Fritzbox muss bei einer IP Weiterleitung des Centro WAN seitig auf DHCP belassen sein.

Der eigentliche Witz an der Geschichte ist das das LAN Netz der Fritzbox sich vom LAN Netz des Centros unterscheiden muss.

Bsp.:

LAN Centro 192.168.66.0/24 IP Centro 192.168.66.1

WAN Fritz DHCP

LAN Fritz 192.168.88.0/24

 

Jetzt bekommt die Fritz aber via IP Weiterleitung des Centro so viel mir ist leider keine IP. Dann muss man den NAT Standard Modus benutzen.

Dabei braucht das WAN der Fritz eine IP aus dem LAN Range des Centro.

Bsp:

LAN Centro 192.168.66.0/24 IP Centro 192.168.66.1

WAN Fritz fix 192.168.66.2

LAN Fritz 192.168.88.0/24

 

 

Sollte mehr oder weniger im verlinkten Beitrag so stehen.

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Contributor
5 von 32

Aha, jetzt wird es aber interessant. Das würde meine Probleme mit dem Weiterleiten der IP an die FB erkären. Ich habe nämlich an der FB nie eine IP gesehen, die WAN-seitig öffentlich ist.

 

Wenn ich heute abend nix anderes vernehme, werde ich das mal so versuchen. Zumindest ist es ein für mich neuer Ansatz, den ich zwar schon irgendwo gelesen habe, den ich aber wieder verworfen habe, weil ich dachte, dass das mit der IP Weiterleitung hinkriegen müsste. Aber ich habe auch gelesen, dass die FB partout keine IP annehmen will. Somit könnte NAT weiterhelfen. Schauen wir mal. Ich melde mich sicher nochmals! Danke schon mal für die guten Lösungsansätze.

Super User
6 von 32

Ja das wird wohl das Problem gewesen sein.

 

Falls du mal Interesse hast nur noch die Fritzbox zu verwenden habe ich dir hier eine weiter Inspiration.

So einfach war es noch nie 😉 http://www.tuxone.ch/2015/01/swisscom-sip-zugangsdaten-auslesen.html

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Contributor
7 von 32

OK, super und danke für diese tolle Meldung. Habe das nun heute natürlich sofort probiert. Das Auslesen des CG war schon mal einfach und hat geklappt. Doch nun stehe ich vor dem Problem, die Daten in die FB7490 einzugeben. Leider habe ich es noch nicht geschafft, die Verbindung zum Laufen zu bringen.

 

Any tips?

Contributor
8 von 32

Ich habe übrigens folgendes in der FB eingegeben:

 

AllipFB7490.jpg

Benutzername und PW habe ich wie ausgelesen eingegeben. Muss ich evtl. den Port noch irgendwo eingeben? Leider funzt das so nicht. Hat jemand eine Ahnung wo der Bock ist?

Contributor
9 von 32

Hmm, komisch, nun ist die Lampe aufeinmal grün... jetzt geht alles!!

Da muss man offenbar noch etwas warten, bis das alles läuft!

 

Wow, supi, nun habe ich alles in der FB, CG ist somit überflüssig! 😄

Super User
10 von 32

Gibt es eine Anleitung dafür, was genau eingetragen wird?

Contributor
11 von 32

Was willst du genau wissen? Es ist eigentlich klar, was man wo eintragen muss. Die Einstellung der FB für den Internetzugang ist auch ganz einfach: Du musst nur Swisscom All IP eintragen beim Internetanbieter. That's it.

Und die Telefonie kannst Du wie obenstehend eintragen. Danach einige Minuten warten und dann läufts.

Super User
12 von 32
Wollte es mit dem Android Client eintragen. Er registriert und registriert und registriert. Nach 1 Minute hab ich abgebrochen. Oder brauchts so lange?
Highlighted
Contributor
13 von 32

bei mir hat's mindestens 10 minuten gedauert. und der test, den die FB anschliessend an das eintragen macht, der ist fehlgeschlagen, trotz richtigen daten... wieso auch immer... als ich dann mal für eine viertelstunde davon lief und alles so liess, wie es eingetragen war, war die lampe in der konfiguration plötzlich grün und seither laufen meine beiden AVM Fritz-Systemtelefone wie geschmiert! :smileyhappy:

Super User
14 von 32

Verwende als outbound proxy bc1.ims.swisscom.ch

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Contributor
15 von 32
interessanterweise läuft's auch mit swisscom.ch. sollte ich hier bc1.ims.swisscom.ch eintragen? werde ich heute abend mal testen.
Super User
16 von 32

Habs nochmals versucht im Android Client:

 

Benutzername: dort, wo Line.1.SIP:AuthUserName ist, also NCxxxx (ohne @swisscom.ch) 

Passwort: dort, was unter Line.1.SIP.Authpassword ist

Server: swisscom.ch

Optionale Einstellungen unter Ausgehende Proxy-Adresse gemäss TuxOne -> bc1.ims.swisscom.ch

 

Es heisst immer:

Konto konnte nicht registiert werden. transaction terminated, Bitte später erneut versuchen

 

 

Contributor
17 von 32

Ich habe den Benutzernamen mit @swisscom.ch eingetragen. Und ich denke, das muss so sein, sonst gehts nicht!

Super User
18 von 32

Im Android Client benötigt man beim Benutzernamen kein @swisscom.ch, weil das ja bereits unter Server eingetragen ist. Wenn ich es so eingebe inkl. @swisscom.ch, dann kommt der Fehler:

 

sip:NCxxx@swisscom.ch@swisscom.ch Illegal character in hostname:@ (at offset 30) (at offset 0)

 

 

Habs mit CSipSimple (Android App) versucht, irgendwie wills auch nicht...

 

Super User
19 von 32

Screenshot_2015-01-19-17-18-34.png

https://www.tuxone.ch
Falls du in deinem Thread eine Antwort von Tux0ne wünschst, so ergänze deinen Text mit @Tux0ne. Damit erhalte ich eine Benachrichtigung.

Super User
20 von 32

Danke, CSipSimple und auch der Android Client funktionieren jetzt. Danke!

Nach oben